Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Site news and information > Tutorials, Informative & Classic threads

Tutorials, Informative & Classic threads A new e-Group area for all the wonderful tutorials and helpful threads put on here by our members. Tutorials on using software, camera hardware - and feel free to request a tutorial if you need assistance!

Reply
 
Thread Tools Display Modes
  #16  
Old 24th April 2014
Ross the fiddler's Avatar
Ross the fiddler Ross the fiddler is offline
Full member
 
Join Date: Apr 2010
Location: Blue Mtns, NSW Australia
Posts: 14,224
Thanks: 2,090
Thanked 1,339 Times in 1,044 Posts
Likes: 5,531
Liked 2,177 Times in 1,160 Posts
Re: E-PL2 "Please check the status of a lens"

Quote:
Originally Posted by Bizoron View Post
Hello! Encountered the same problem "Please check the status of a lens". Can you tell me more, how and what did you do with the lens to correct the error.
The locking pin hole in the back of the lens can get a small burr on the edges which can prevent the pin from sitting in all the way after fitting the lens & by using a jewellers screw driver that burr can be scraped back to leave a clean hole for the lens locking pin (in the camera body) to lock in. It is because the pin can't seat properly that the camera comes up with that fault message.

__________________
Ross
I fiddle with violins (when I'm not fiddling with a camera).
Flickr: https://www.flickr.com/photos/ross-the-fiddler/
Cameras: OM-D E-M1 & Mk II, Olympus Stylus 1, OM-D E-M5.
Lenses: M.ZD7-14mm f2.8 PRO Lens, M.ZD12-40mm f2.8 PRO Lens, M.ZD40-150mm f2.8 PRO Lens, MC-14, MC-20, M.ZD12-50, M.ZD60 Macro, M.ZD75-300 Mk II, MMF-3, ZD14-54 II, Sigma 150mm F2.8 APO Macro DG HSM.
Flashes: FL36R X2, FL50R, FL50.
Software: Capture One Pro 10 (& Olympus Viewer 3).
Reply With Quote
  #17  
Old 26th April 2014
linuxdriver linuxdriver is offline
Junior Member
 
Join Date: Mar 2014
Location: cheshire
Posts: 4
Thanks: 1
Thanked 2 Times in 2 Posts
Likes: 0
Liked 0 Times in 0 Posts
Re: E-PL2 "Please check the status of a lens"

Sorry for the late reply but Ross said it all . Remove small screws from flange on base of rear of lens to remove the flimsy plastic round ring which sits on the camera mount .

Locating hole on the flange matches up to the locking pin which moves when you press the locking button on the camera . Ream this hole carefully to remove burr and slightly widen it to ease the seating of the locking pin .

Re-fit to the lens and check the fitting by pressing the locking button several times with the lens in situ . Careful rotation of the lens with the button depressed should " feel" different . Hopefully this clears the fault . Worked for me sice then and hope this helps
Reply With Quote
  #18  
Old 8th April 2015
bosko.m bosko.m is offline
Junior Member
 
Join Date: Apr 2015
Location: Bosna and Herzegovina.
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Likes: 0
Liked 0 Times in 0 Posts
Re: E-PL2 "Please check the status of a lens"

Hi, I have the same problem with my Olympus M.Zuiko 14-42mm f3.5-5.6 II R standard/kit lens, whenever i change the focal length to around 35mm "Please check the status of a lens" is displayed on the screen.

I have tryed to fix it on my own but idk. is it you or is it my not prefect eng. is the case so I haven't succeded fixing it following linuxdriver's instructions nor Ross the fiddler.
on the back of the lens is a round ring with 4 screws and an inner half ring because of the connectors with 2 screws.What exactly should i do, please explain it with detail or even better with images.

This is not the M.Zuiko 14-42mm f3.5-5.6 II R, it's an macro lens,but it has almost the same rear layout as the 14-42mm, I have removed the 4 screws from the lens but, I wasn't successful in locating and fixing the problem.

So if anyone could explain how to fix it in even more detail or with images i would been thankful!
Reply With Quote
  #19  
Old 8th April 2015
WilsonLaidlaw WilsonLaidlaw is offline
Full member
 
Join Date: Nov 2013
Location: Near Lewes, Sussex, UK and Tourtour, Var, France
Posts: 25
Thanks: 7
Thanked 0 Times in 0 Posts
Likes: 0
Liked 0 Times in 0 Posts
Re: E-PL2 "Please check the status of a lens"

Sadly it is not the locking tab hole in all cases. On my new 75-300 II ED it was faulty electronics, which I suspect had skipped the inspection at Oly Japan and had never worked. The seller immediately replaced the lens.

Wilson
Reply With Quote
  #20  
Old 8th April 2015
linuxdriver linuxdriver is offline
Junior Member
 
Join Date: Mar 2014
Location: cheshire
Posts: 4
Thanks: 1
Thanked 2 Times in 2 Posts
Likes: 0
Liked 0 Times in 0 Posts
Re: E-PL2 "Please check the status of a lens"

Unfortunately my eyesight has deteriorated to the point I can no longer use my trusty Olympus and can only sympathise as the lens base pictured looks metallic and rather more solid than mine so would be unlikely to benefit from reaming .

Recalling the inside of the lens there was a fragile looking ribbon cable which may lose contact on extreme zoom , sorry I cannot be more helpful but it sounds like a service agent job as has been pointed out
Reply With Quote
  #21  
Old 12th April 2015
bosko.m bosko.m is offline
Junior Member
 
Join Date: Apr 2015
Location: Bosna and Herzegovina.
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Likes: 0
Liked 0 Times in 0 Posts
Re: E-PL2 "Please check the status of a lens"

Quote:
Originally Posted by WilsonLaidlaw View Post
Sadly it is not the locking tab hole in all cases. On my new 75-300 II ED it was faulty electronics, which I suspect had skipped the inspection at Oly Japan and had never worked. The seller immediately replaced the lens.

Wilson
The thing is my worked just fine for a year and a half, and suddenly this error happened.Also in my country there is no official Olympus service nor a Olympus store so that I could send it for repairs.

Also linuxdriver, the picture I posted was the only one I could find online that has the same back layout, and on my lens it's not metal it's plastic, and black.
This is the image of the lens.
Reply With Quote
  #22  
Old 12th April 2015
linuxdriver linuxdriver is offline
Junior Member
 
Join Date: Mar 2014
Location: cheshire
Posts: 4
Thanks: 1
Thanked 2 Times in 2 Posts
Likes: 0
Liked 0 Times in 0 Posts
Cool Re: E-PL2 "Please check the status of a lens"

Relying on memory assisted by the attached picture from eBay of failed repairs ! The lens on then left shows the pin locating hole which might need widening next to one of the 4 screw holes on the outer plastic ring on the rest of the lens .

The centre lens shows a ribbon cable which may lose contact at extreme zoom if this is not the case , I recommend trying a different lens on the camera body first to rule out autofocus problems .

Not for the faint-hearted
Attached Images
File Type: jpg Screenshot_2015-04-12-23-29-38.jpg (19.5 KB, 26 views)
Reply With Quote
The Following User Says Thank You to linuxdriver For This Useful Post:
bosko.m (13th April 2015)
  #23  
Old 13th April 2015
bosko.m bosko.m is offline
Junior Member
 
Join Date: Apr 2015
Location: Bosna and Herzegovina.
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Likes: 0
Liked 0 Times in 0 Posts
Re: E-PL2 "Please check the status of a lens"

Thank you so much for your reply,I will give it a try.
Reply With Quote
  #24  
Old 13th April 2015
shonofear shonofear is offline
Junior Member
 
Join Date: Apr 2015
Location: australia
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Likes: 0
Liked 0 Times in 0 Posts
Re: E-PL2 "Please check the status of a lens"

hey this fixed my issue a few days ago..

"Put the camera on a tripod, switch to AF-C and hold the shutter half-pressed for 5 seconds until the back and forth hunting stops. Does it focus?"

mine seems fine now. weird.
Reply With Quote
  #25  
Old 13th April 2015
bosko.m bosko.m is offline
Junior Member
 
Join Date: Apr 2015
Location: Bosna and Herzegovina.
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Likes: 0
Liked 0 Times in 0 Posts
Re: E-PL2 "Please check the status of a lens"

Quote:
Originally Posted by shonofear View Post
hey this fixed my issue a few days ago..

"Put the camera on a tripod, switch to AF-C and hold the shutter half-pressed for 5 seconds until the back and forth hunting stops. Does it focus?"

mine seems fine now. weird.
Thank you, I'll give it a try and report back as soon as I can.
Reply With Quote
  #26  
Old 22nd April 2015
shonofear shonofear is offline
Junior Member
 
Join Date: Apr 2015
Location: australia
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Likes: 0
Liked 0 Times in 0 Posts
Re: E-PL2 "Please check the status of a lens"

well mine seems fine now after a few weeks of using. hope it works for you and others
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New lease of life for "OM" lens cases Simon Bee Lens focus 2 4th February 2013 12:30 AM
What's the difference between "zoom" and "magnify" ? DJMC Olympus OM-D E-M5 6 28th October 2012 10:30 PM
Using "astro photography" scopes as lens? Tordan58 Legacy Lenses 22 2nd May 2012 08:47 PM
"All" vs "Not Transferred Yet" When Uploading - Can I Set A Default On Launch? Phaedrus Software 1 4th July 2011 08:52 AM
IS & "Legacy" Lens focal length setting Graham_of_Rainham Olympus E-3 14 24th January 2009 06:37 PM


All times are GMT. The time now is 08:58 AM.


The Write Technology Ltd, 2007-2019, All rights reservedAd Management plugin by RedTyger