Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Cameras, lenses and system accessories > Camera conference > Micro Four Thirds > Olympus OM-D E-M1

Olympus OM-D E-M1 The first Micro Four Thirds camera that offers phase detect focusing so you can use Four Thirds DSLR lenses normally as well a Micro Four Thirds lenses.

Reply
 
Thread Tools Display Modes
  #1  
Old 11th October 2013
Tradetalk's Avatar
Tradetalk Tradetalk is offline
Full member
 
Join Date: Nov 2011
Location: Helmsdale
Posts: 99
Thanks: 32
Thanked 22 Times in 15 Posts
Likes: 13
Liked 3 Times in 3 Posts
Problem with My Olympus?

Not sure if this has been asked before but I can't seem to login to My Olympus.
All was OK when I registered for the free grip and MMF-3 (I went on to get the S/No. of my old E-3) but since then I simply get an account not found message. I've tried 'Forgot Password' but it just emails to say that the account does not exist!
Trying to register the E-M1 for Service Plus and still no joy and if I try to create a new account it simply crashes after you have entered all of the details.
Any ideas?
Thanks
__________________
Dave

'Always keep your expectations low ... then you won't be disappointed!'
Reply With Quote
  #2  
Old 11th October 2013
StephenL's Avatar
StephenL StephenL is offline
Senior Pixelmonger
 
Join Date: May 2008
Location: Yorkshire Dales
Posts: 9,863
Thanks: 984
Thanked 1,126 Times in 921 Posts
Likes: 658
Liked 755 Times in 499 Posts
Re: Problem with My Olympus?

I've just successfully logged in and viewed my registered products. Sometimes their server does take a scunner, though.
__________________
Stephen

A camera takes a picture. A photographer makes a picture

Fuji X system, + Leica and Bronica film

My Flickr site
Reply With Quote
The Following User Says Thank You to StephenL For This Useful Post:
Tradetalk (11th October 2013)
  #3  
Old 11th October 2013
bilbo bilbo is offline
Full member
 
Join Date: Jul 2010
Location: Lancashire
Posts: 1,079
Thanks: 255
Thanked 174 Times in 152 Posts
Likes: 148
Liked 205 Times in 110 Posts
Re: Problem with My Olympus?

It works fine for me too.

Apart from the smarmy geezer on the welcome page, that is.

https://myolympus.olympus-consumer.com/
Reply With Quote
The Following User Says Thank You to bilbo For This Useful Post:
Tradetalk (11th October 2013)
  #4  
Old 11th October 2013
DavyG DavyG is offline
Full member
 
Join Date: Dec 2007
Location: Suffolk
Posts: 3,256
Thanks: 615
Thanked 425 Times in 335 Posts
Likes: 1,854
Liked 1,471 Times in 326 Posts
Re: Problem with My Olympus?

I've just accessed the site, no difficulty in getting in.

It may be worth clearing your browsers cookies and trying again.

I hope you manage to resolve the problem.

Dave
Reply With Quote
The Following User Says Thank You to DavyG For This Useful Post:
Tradetalk (11th October 2013)
  #5  
Old 11th October 2013
George Dorn's Avatar
George Dorn George Dorn is offline
Full member
 
Join Date: Aug 2011
Location: North West Leicestershire
Posts: 1,120
Thanks: 216
Thanked 90 Times in 82 Posts
Likes: 677
Liked 129 Times in 69 Posts
Re: Problem with My Olympus?

Most of my registered products had disappeared when I visited and I had to re-register to go for the offer.
__________________
Colin
"Don't blame me..."
Reply With Quote
  #6  
Old 11th October 2013
Phill D's Avatar
Phill D Phill D is online now
Full member
 
Join Date: Apr 2011
Location: Derbyshire
Posts: 9,982
Thanks: 1,203
Thanked 1,435 Times in 1,325 Posts
Likes: 1,087
Liked 2,422 Times in 1,144 Posts
Re: Problem with My Olympus?

I just looked and it said I'd no registered products either? Now I'm confused as I registered for the grip and adaptor offer against my old E510 and had it accepted and have claimed?

So now slightly concerned nothing is registered
Reply With Quote
  #7  
Old 11th October 2013
jamsa jamsa is offline
Full member
 
Join Date: Jun 2008
Location: UK
Posts: 514
Thanks: 310
Thanked 78 Times in 56 Posts
Likes: 228
Liked 21 Times in 15 Posts
Re: Problem with My Olympus?

Just a thought ..are you on Olympus USA, UK, EU sites? Could they be different?
I have however checked my Olympus and my newest items are all showing but not my older gear.
Reply With Quote
  #8  
Old 11th October 2013
Phill D's Avatar
Phill D Phill D is online now
Full member
 
Join Date: Apr 2011
Location: Derbyshire
Posts: 9,982
Thanks: 1,203
Thanked 1,435 Times in 1,325 Posts
Likes: 1,087
Liked 2,422 Times in 1,144 Posts
Re: Problem with My Olympus?

I just made sure and registered my EM-1 on the UK site. It seems to have accepted it, lets see if it's still there tomorrow. Odd it doesn't show the old E510 though or the grip and adapter claim when I look at promotions?
Just checked Royal Mail my claim was delivered yesterday in Germany so fingers crossed it's OK.
Reply With Quote
  #9  
Old 11th October 2013
Tradetalk's Avatar
Tradetalk Tradetalk is offline
Full member
 
Join Date: Nov 2011
Location: Helmsdale
Posts: 99
Thanks: 32
Thanked 22 Times in 15 Posts
Likes: 13
Liked 3 Times in 3 Posts
Re: Problem with My Olympus?

Managed to create a new account with a different email to register the E-M1 but still no joy at accessing the original account which definitely worked last week!
__________________
Dave

'Always keep your expectations low ... then you won't be disappointed!'
Reply With Quote
  #10  
Old 12th October 2013
bilbo bilbo is offline
Full member
 
Join Date: Jul 2010
Location: Lancashire
Posts: 1,079
Thanks: 255
Thanked 174 Times in 152 Posts
Likes: 148
Liked 205 Times in 110 Posts
Re: Problem with My Olympus?

Quote:
Originally Posted by jamsa View Post
Just a thought ..are you on Olympus USA, UK, EU sites? Could they be different?
I have however checked my Olympus and my newest items are all showing but not my older gear.
I am, and have always been, registered here: https://myolympus.olympus-consumer.com/

No problems with stuff disappearing. Where are you registering?
Reply With Quote
  #11  
Old 12th October 2013
menace1944's Avatar
menace1944 menace1944 is offline
Full member
 
Join Date: Mar 2010
Location: Banchory, Aberdeenshire
Posts: 35
Thanks: 2
Thanked 0 Times in 0 Posts
Likes: 0
Liked 3 Times in 1 Post
Re: Problem with My Olympus?

Quote:
Originally Posted by bilbo View Post
I am, and have always been, registered here: https://myolympus.olympus-consumer.com/

No problems with stuff disappearing. Where are you registering?
I have just checked my account at above URL and only some items were shown. My 4 lenses were shown but not my E30. I have added this and it seems to have updated correctly and survived logging out and then logging in again. Luckily the purchase details for the E30 were the same as 2 of the lenses so I was able to put in the correct data.
__________________
Dennis

E-30; 9-18; 14-54 MkII; 40-150; 70-300; FL36R
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Olympus marketing problem? Anne The lounge 15 12th October 2013 12:04 AM
Olympus Digital Camera Updater problem David Morison Software 3 3rd September 2011 05:54 AM
HELP! FL-36 problem meach Flash 4 30th October 2009 12:18 PM
Is this a problem on my E3? brob108 Olympus E-3 17 12th February 2009 08:08 PM
Olympus UK web site. Login problem. Jim Ford The lounge 2 1st March 2008 01:02 PM


All times are GMT. The time now is 08:05 AM.


The Write Technology Ltd, 2007-2019, All rights reservedAd Management plugin by RedTyger