Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Cameras, lenses and system accessories > Camera conference > Micro Four Thirds > Olympus OM-D E-M1

Olympus OM-D E-M1 The first Micro Four Thirds camera that offers phase detect focusing so you can use Four Thirds DSLR lenses normally as well a Micro Four Thirds lenses.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11th October 2013
Tradetalk's Avatar
Tradetalk Tradetalk is offline
Full member
 
Join Date: Nov 2011
Location: Helmsdale
Posts: 99
Thanks: 32
Thanked 22 Times in 15 Posts
Likes: 13
Liked 3 Times in 3 Posts
Problem with My Olympus?

Not sure if this has been asked before but I can't seem to login to My Olympus.
All was OK when I registered for the free grip and MMF-3 (I went on to get the S/No. of my old E-3) but since then I simply get an account not found message. I've tried 'Forgot Password' but it just emails to say that the account does not exist!
Trying to register the E-M1 for Service Plus and still no joy and if I try to create a new account it simply crashes after you have entered all of the details.
Any ideas?
Thanks
__________________
Dave

'Always keep your expectations low ... then you won't be disappointed!'
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Olympus marketing problem? Anne The lounge 15 12th October 2013 12:04 AM
Olympus Digital Camera Updater problem David Morison Software 3 3rd September 2011 05:54 AM
HELP! FL-36 problem meach Flash 4 30th October 2009 12:18 PM
Is this a problem on my E3? brob108 Olympus E-3 17 12th February 2009 08:08 PM
Olympus UK web site. Login problem. Jim Ford The lounge 2 1st March 2008 01:02 PM


All times are GMT. The time now is 12:21 PM.


The Write Technology Ltd, 2007-2019, All rights reservedAd Management plugin by RedTyger