Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Cameras, lenses and system accessories > Camera conference

Camera conference General and model-specific E-System camera chat.

Reply
 
Thread Tools Display Modes
  #1  
Old 5th February 2011
Ellie Ellie is offline
Full member
 
Join Date: Jan 2008
Location: SW Hants, UK
Posts: 2,382
Thanks: 62
Thanked 16 Times in 16 Posts
Likes: 0
Liked 0 Times in 0 Posts
Question Cleaning lens/body contacts

My camera/lenses have developed an intermittent problem - the camera and lenses don't always want to communicate with each other, resulting in the lens(es) either freezing (doing nothing at all) or failing to focus properly even though there is a focus-confirm beep. It doesn't happen all the time so it suggests there may be dirty or sticking contacts.

I noticed something wrong after I bought a new-to-me lens - everything it took was out of focus, so I thought it was a bad lens and almost gave it back but I decided to wait until after going to Langstone on Friday. While we were there my E-30 /70-300mm froze a couple of times so I swapped to my 35mm macro to see if it made any difference ... and ended up with a few out of focus images! (Worse than could be attributed to slow shutter speed) This seemed to suggest a problem with the camera body ... but the 70-300mm also froze on Peter's E-3.

The other thing that happened on my E-30 was that the display stopped working properly, instead of the f number there was - - (two orange dashes).

Both the freezing and display problems resolved on rebooting the camera (which is when I remembered/realised it had happened before, last year, just before the warranty ran out!).

I did manage to take a few in focus pictures using both the E-3 and E-30 - so it isn't a permanent problem. The new lens/E-30 combination also managed to get some acceptable high ISO pictures of pansies in very poor light (it was getting dark).

I've so far only gently wiped the body contacts and also very gently depressed/released the pins using a lens cloth - haven't had the chance to see if it's improved the situation yet. But if it hasn't I don't know what else I could do.

The only other thing I have is lens cleaning wipes - the things that come in little packets. Can I use those on the contacts to degrease/demuck them, or are they too harsh? If so, what should I use and where could I get it from without it turning into an expedition? (The nearest camera shop is about 20 miles away.)

Sorry about the essay, but I thought it best to say everything I could think of in one go rather than trying to answer questions later.
__________________
- my pictures -
Reply With Quote
  #2  
Old 6th February 2011
David Morison's Avatar
David Morison David Morison is offline
Full member
 
Join Date: Dec 2010
Location: Fulbeck, Lincolnshire
Posts: 3,507
Thanks: 71
Thanked 588 Times in 472 Posts
Likes: 48
Liked 298 Times in 175 Posts
Re: Cleaning lens/body contacts

I have had the same problems with my new E5 which I have mentioned before in the thread on E5 and unsharp photographs. The main problem ocurred with the ZD300mm with focus confirm beep and light but the image was obviously OOF even through the viewfinder. This happened repeatedly until I focused on an object at a greater distance and then came back to the original subject which then focussed OK. This in a new camera and fairly new lens so probably wasn't due to dirty contacts. This only an intermittant problem and hasn't happened recently although I have been doing more MF with very small objects against a confusing background.

The issue of the camera not recognising the lens does occasionally happen when using my E30 with with Leica 14-150mm and EX25 and is corrected by removing and replacing the combo which probably indicates contact problems.

I don't have any answers yet apart from cleaning contacts with a Lenspen which I will try.

Anyone else any similar experiences?

David
Reply With Quote
The Following User Says Thank You to David Morison For This Useful Post:
Ellie (9th February 2011)
  #3  
Old 6th February 2011
Makonde
Guest
 
Posts: n/a
Re: Cleaning lens/body contacts

On the very few occcasions this sort of thing happened to me with the E520 (and a couple of times when the E5 has had stuck focus using the 50-200) I found that (a) powering off then on and/or (b) powering off, re-seating the lens, power on fixed the problem.

Once or twice I remember in retrospect that I forgot to power off before changing the lens - but that's not in every occurrence.

Over nearly 3 years I never had to clean the contacts on either lenses or camera. I think that unless they've been touched (greasy fingers) they are really unlikely to want cleaning, and are basically self-cleaning each time you change a lens. If I were to try cleaning I think a soft Kleenex with just a little isopropyl alcohol or similar would do.

I haven't had the blurry problem mentioned. If you have the camera set up for shutter release whether in focus or not, then that plus a stuck focus/premature shutter press might account for it sometimes? I only very rarely override the default lock on shutter release when not in focus. But then, if Ellie is getting the focus beep then the camera thinks it does have focus.
Reply With Quote
The Following User Says Thank You to For This Useful Post:
Ellie (9th February 2011)
  #4  
Old 6th February 2011
CaptainD's Avatar
CaptainD CaptainD is offline
Full member
 
Join Date: Nov 2007
Location: Surrey
Posts: 835
Thanks: 1
Thanked 48 Times in 30 Posts
Likes: 0
Liked 0 Times in 0 Posts
Re: Cleaning lens/body contacts

Dear Ellie,

I used to repair aircraft instruments and the stuff we used to clean contacts with was Isopropyl alcohol. You will also see it labelled as IPA, no the beer version btw!! It is cheap and very easy to buy, you can buy it in pre-soaked wipes just like a nurse would use before giving an injection. Alternatively you can buy it in liquid form. just apply it very sparingly, a soaked cotton bud is a good way. After applying it just give the contacts a good wipe with a microfibre or lint free cloth.

I keep an aerosol of IPA in the garage which I use, I just check Ebay and there are loads of sellers which which help from under 2 delivered.

Cheers

Chris
Reply With Quote
The Following User Says Thank You to CaptainD For This Useful Post:
Ellie (9th February 2011)
  #5  
Old 6th February 2011
Ross the fiddler's Avatar
Ross the fiddler Ross the fiddler is offline
Full member
 
Join Date: Apr 2010
Location: Blue Mtns, NSW Australia
Posts: 14,262
Thanks: 2,093
Thanked 1,341 Times in 1,046 Posts
Likes: 5,560
Liked 2,199 Times in 1,168 Posts
Re: Cleaning lens/body contacts

I have mentioned this before, but you need to also check how you are holding the camera. I noticed this when I first got my used E30 & was concerned like you. It may have been occuring with my 14-54 lens first, but this is it. Occasionally the left hand can bump the release button without you knowing it & not always return properly which disables the connections to the lens giving -- instead of the aperture & by gripping the lens & giving it a slight twist in both directions to reseat it, the locking pin connected to the button should pop out into the hole of the lens & all should be well. The camera doesn't need to be off when changing lenses because of this feature, but is better if it is, so when switching the camera back on, the sensor (filter) cleaner operates.

I'd be interested to know if that is the issue here.
__________________
Ross
I fiddle with violins (when I'm not fiddling with a camera).
Flickr: https://www.flickr.com/photos/ross-the-fiddler/
Cameras: OM-D E-M1 & Mk II, Olympus Stylus 1, OM-D E-M5.
Lenses: M.ZD7-14mm f2.8 PRO Lens, M.ZD12-40mm f2.8 PRO Lens, M.ZD40-150mm f2.8 PRO Lens, MC-14, MC-20, M.ZD45mm f1.8, M.ZD12-50, M.ZD60 Macro, M.ZD75-300 Mk II, MMF-3, ZD14-54 II, Sigma 150mm F2.8 APO Macro DG HSM.
Flashes: FL36R X2, FL50R, FL50.
Software: Capture One Pro 10 (& Olympus Viewer 3).
Reply With Quote
The Following User Says Thank You to Ross the fiddler For This Useful Post:
Ellie (9th February 2011)
  #6  
Old 6th February 2011
jamie allan jamie allan is offline
Full member
 
Join Date: Jun 2009
Location: Glasgow
Posts: 1,023
Thanks: 78
Thanked 92 Times in 76 Posts
Likes: 0
Liked 1 Time in 1 Post
Re: Cleaning lens/body contacts

Ellie,
Isopropyl Alcohol is your best bet as Chris has already said. Using this with a decent quality cotton bud that doesn't lose it's cotton hairs by gently rubbing the contacts and allowing any residue to vaporise before trying to mate the contacts. The Camlink camera cleaning kit has all you need to get cleaning. You can get it from Jessops.
__________________
Jamie

Last edited by jamie allan; 6th February 2011 at 01:27 PM. Reason: spelling error
Reply With Quote
The Following User Says Thank You to jamie allan For This Useful Post:
Ellie (9th February 2011)
  #7  
Old 9th February 2011
Ellie Ellie is offline
Full member
 
Join Date: Jan 2008
Location: SW Hants, UK
Posts: 2,382
Thanks: 62
Thanked 16 Times in 16 Posts
Likes: 0
Liked 0 Times in 0 Posts
Re: Cleaning lens/body contacts

Thanks for all the help and advice.

Quote:
I have mentioned this before, but you need to also check how you are holding the camera. I noticed this when I first got my used E30 & was concerned like you. It may have been occuring with my 14-54 lens first, but this is it. Occasionally the left hand can bump the release button without you knowing it & not always return properly which disables the connections to the lens giving -- instead of the aperture
I don't think I've ever knocked the release button, I don't think my thumb goes that far up the camera, but it's something to keep an eye on.

Quote:
Originally Posted by various
Isopropyl alcohol
I'll look for some, I'm guessing it's included in lens cleaning kits.

Quote:
a Lenspen
Would that be a 'pen' containing IPA?
__________________
- my pictures -
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Lens cleaning cloth Phill Olympus E-510 3 27th December 2010 09:47 PM
Wanted - body/lens/kit? chris For sale or wanted small ads 19 16th May 2010 04:02 PM
Lens cleaning/maintainance. ringneck Lens focus 4 1st April 2009 11:26 PM
Lens cleaning andym Lens focus 15 21st April 2008 01:03 PM
Cleaning a Lens... how...? theMusicMan Standard zoom and mid range 4 23rd December 2007 05:11 PM


All times are GMT. The time now is 03:30 AM.


The Write Technology Ltd, 2007-2019, All rights reservedAd Management plugin by RedTyger