Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Cameras, lenses and system accessories > Lens focus > Converters, adapters and extension tubes

Converters, adapters and extension tubes All those lens accessories that get in between the lens and the camera.

Reply
 
Thread Tools Display Modes
  #1  
Old 15th October 2019
Chris Hall Chris Hall is offline
Full member
 
Join Date: Jul 2013
Location: West Sussex, UK
Posts: 227
Thanks: 19
Thanked 10 Times in 10 Posts
Likes: 4
Liked 35 Times in 12 Posts
Problem with MC-20 2x Teleconverter

I recently bought an Olympus 40-150 f/2.8 Pro lens, together with an MC-20 2x Teleconverter for my OMD EM10 iii. Using it for the first time today, the camera and lens are functioning perfectly, Whe I attach the MC-2O, I am getting a black screen with the message 'Please check the status of a lens'. Any ideas please?
Reply With Quote
  #2  
Old 15th October 2019
MJ224's Avatar
MJ224 MJ224 is offline
Full member
 
Join Date: May 2016
Location: Carmarthenshire
Posts: 14,269
Thanks: 1,002
Thanked 777 Times in 721 Posts
Likes: 7,174
Liked 4,047 Times in 1,857 Posts
Re: Problem with MC-20 2x Teleconverter

Forgive me if this is obvious, are you sure the lenses and camera are fully clicked/connected. I have had similar problems with a Pany GX800 and a lens.

Otherwise no idea..

And good luck...
__________________
Mark Johnson

My Sailing Page

My Flickr
Reply With Quote
  #3  
Old 15th October 2019
Olybirder Olybirder is online now
Senior Member
 
Join Date: Apr 2011
Location: Norfolk
Posts: 6,994
Thanks: 2,483
Thanked 1,002 Times in 799 Posts
Likes: 2,083
Liked 3,217 Times in 905 Posts
Re: Problem with MC-20 2x Teleconverter

Have you updated the lens firmware to Version 1.3?

Ron
Reply With Quote
The Following User Says Thank You to Olybirder For This Useful Post:
OM USer (16th October 2019)
The Following User Liked This Post:
royd63uk (15th October 2019)
  #4  
Old 15th October 2019
Chris Hall Chris Hall is offline
Full member
 
Join Date: Jul 2013
Location: West Sussex, UK
Posts: 227
Thanks: 19
Thanked 10 Times in 10 Posts
Likes: 4
Liked 35 Times in 12 Posts
Re: Problem with MC-20 2x Teleconverter

I have made sure several times that the lens and converter are securely connected.
Reply With Quote
  #5  
Old 15th October 2019
Chris Hall Chris Hall is offline
Full member
 
Join Date: Jul 2013
Location: West Sussex, UK
Posts: 227
Thanks: 19
Thanked 10 Times in 10 Posts
Likes: 4
Liked 35 Times in 12 Posts
Re: Problem with MC-20 2x Teleconverter

I’ll check now that the firmware update is done. Will I need to update both the lens and the converter? Thank you.
Reply With Quote
  #6  
Old 15th October 2019
Olybirder Olybirder is online now
Senior Member
 
Join Date: Apr 2011
Location: Norfolk
Posts: 6,994
Thanks: 2,483
Thanked 1,002 Times in 799 Posts
Likes: 2,083
Liked 3,217 Times in 905 Posts
Re: Problem with MC-20 2x Teleconverter

No, I don't think there is an update for the converter. You will have to remove it to update the lens on the camera.

Ron
Reply With Quote
  #7  
Old 15th October 2019
Chris Hall Chris Hall is offline
Full member
 
Join Date: Jul 2013
Location: West Sussex, UK
Posts: 227
Thanks: 19
Thanked 10 Times in 10 Posts
Likes: 4
Liked 35 Times in 12 Posts
Re: Problem with MC-20 2x Teleconverter

Thank you! 🙂
Reply With Quote
  #8  
Old 15th October 2019
wornish's Avatar
wornish wornish is offline
Senior Member
 
Join Date: Sep 2015
Location: Cheshire
Posts: 6,289
Thanks: 355
Thanked 565 Times in 444 Posts
Likes: 2,998
Liked 1,651 Times in 816 Posts
Re: Problem with MC-20 2x Teleconverter

Don't think there is any firmware in the converter. There certainly isn't any in the MC-14.
__________________
Dave

My Flickr
Reply With Quote
  #9  
Old 15th October 2019
Chris Hall Chris Hall is offline
Full member
 
Join Date: Jul 2013
Location: West Sussex, UK
Posts: 227
Thanks: 19
Thanked 10 Times in 10 Posts
Likes: 4
Liked 35 Times in 12 Posts
Re: Problem with MC-20 2x Teleconverter

Thank you.
Reply With Quote
  #10  
Old 15th October 2019
Wildwood Wildwood is offline
Full member
 
Join Date: Jan 2017
Location: dfdsfsdf
Posts: 153
Thanks: 0
Thanked 37 Times in 36 Posts
Likes: 66
Liked 69 Times in 44 Posts
Re: Problem with MC-20 2x Teleconverter

The firmware update for the 300/f4 was for the MC-20. I assume there'll be one for the 40-150 too. It's definitely something you need to check.
__________________
Best wishes

Wildwood
Reply With Quote
The Following User Says Thank You to Wildwood For This Useful Post:
OM USer (16th October 2019)
  #11  
Old 15th October 2019
Chris Hall Chris Hall is offline
Full member
 
Join Date: Jul 2013
Location: West Sussex, UK
Posts: 227
Thanks: 19
Thanked 10 Times in 10 Posts
Likes: 4
Liked 35 Times in 12 Posts
Re: Problem with MC-20 2x Teleconverter

I will check tonight. Many thanks. ��
Reply With Quote
  #12  
Old 15th October 2019
Melaka's Avatar
Melaka Melaka is online now
Full member
 
Join Date: Nov 2007
Location: Bucks
Posts: 2,449
Thanks: 773
Thanked 240 Times in 166 Posts
Likes: 755
Liked 364 Times in 152 Posts
Send a message via ICQ to Melaka
Re: Problem with MC-20 2x Teleconverter

Firmware 1.3 released in June for the 40-150 is to support the MC20.
__________________
David

EM1ii, EM10ii
Reply With Quote
  #13  
Old 15th October 2019
Chris Hall Chris Hall is offline
Full member
 
Join Date: Jul 2013
Location: West Sussex, UK
Posts: 227
Thanks: 19
Thanked 10 Times in 10 Posts
Likes: 4
Liked 35 Times in 12 Posts
Re: Problem with MC-20 2x Teleconverter

Sorted now. Thanks everyone. 🙂
Reply With Quote
The Following User Liked This Post:
OM USer (16th October 2019)
  #14  
Old 16th October 2019
Phill D's Avatar
Phill D Phill D is offline
Full member
 
Join Date: Apr 2011
Location: Derbyshire
Posts: 10,073
Thanks: 1,203
Thanked 1,450 Times in 1,339 Posts
Likes: 1,128
Liked 2,438 Times in 1,156 Posts
Re: Problem with MC-20 2x Teleconverter

That caught me out too Chris. Glad it was a simple fix.
Reply With Quote
  #15  
Old 16th October 2019
Chris Hall Chris Hall is offline
Full member
 
Join Date: Jul 2013
Location: West Sussex, UK
Posts: 227
Thanks: 19
Thanked 10 Times in 10 Posts
Likes: 4
Liked 35 Times in 12 Posts
Re: Problem with MC-20 2x Teleconverter

Thanks Phill. ��
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
For sale 1.4x Teleconverter ec-14 olympusstar For sale or wanted small ads 11 6th May 2015 08:54 PM
For sale 4/3 EC-20 2 x teleconverter IamFisheye For sale or wanted small ads 1 10th February 2015 07:20 PM
For sale Oly EC-20 (x2 Teleconverter) CallaWolf For sale or wanted small ads 1 23rd June 2012 07:55 PM
OM Teleconverter Alan Clogwyn Converters, adapters and extension tubes 4 22nd October 2010 03:36 PM
EC-14 teleconverter Bonsaidad Lens focus 17 12th August 2010 04:12 PM


All times are GMT. The time now is 08:20 PM.


The Write Technology Ltd, 2007-2019, All rights reservedAd Management plugin by RedTyger