Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Cameras, lenses and system accessories > Camera conference > Olympus E-510

Olympus E-510 E-510 specific discussion.

Reply
 
Thread Tools Display Modes
  #1  
Old 8th December 2009
Glen Bentley's Avatar
Glen Bentley Glen Bentley is offline
Full member
 
Join Date: Mar 2008
Location: Epping, Essex
Posts: 71
Thanks: 0
Thanked 1 Time in 1 Post
Likes: 0
Liked 0 Times in 0 Posts
E510

I was out walking the weekend before last with E510 in hand, as is my way, when I lost my footing and ended up staring at the sky. Regrettably the camera took a clump although not too harsh as I had slid down in a graceful and controlled manner.

Tested the camera immediately and there was a slight buzzing which stopped and then it operated normally.

I have noticed now that on occasion, but not always, a red glow appears at the bottom of the viewfinder. Has any one else experienced this? I think this may be the lens mount but would appreciate some input if anyone knows of this or a similar problem and what should be done.

Is the light likely to show up on images? or any other consequences?

As I say the camera appears to be functioning normally otherwise.
__________________
Glen
Cogito sumere potum alterum
Reply With Quote
  #2  
Old 8th December 2009
andym's Avatar
andym andym is offline
Senior Member
 
Join Date: Nov 2007
Location: Epping Forest
Posts: 4,355
Thanks: 37
Thanked 346 Times in 258 Posts
Likes: 39
Liked 1,010 Times in 300 Posts
Re: E510

Hi

I would say that your focus screen may have come lose.The red light you are seeing is probably the LED that illuminates the focus points.

Check if the cradle that holds the focus screen is in place properly.There are two lugs at the back and a spring clip at the front.Be careful with the screen though as they scratch very easily.

Us old fools have to careful when walking in the forest.

Take care.

Ps be interested to see what others think.
__________________
All the best

Being left handed my brain sometimes works sdrawkcab

Andy

Lots of cameras and lenses.


My Flickr
Reply With Quote
  #3  
Old 8th December 2009
snaarman's Avatar
snaarman snaarman is offline
Full member
 
Join Date: Feb 2008
Location: Baaarkshire UK
Posts: 6,867
Thanks: 502
Thanked 417 Times in 325 Posts
Likes: 492
Liked 1,343 Times in 507 Posts
Re: E510

Quote:
Originally Posted by andym View Post
Hi

I would say that your focus screen may have come lose.The red light you are seeing is probably the LED that illuminates the focus points.


Ps be interested to see what others think.
Yes, focus led would be my suspect for this. Its in the right place and is the right colour. I just wonder if a displaced screen would show up some other features though??

Pete
__________________
Look, I'm an old man. I shouldn't be expected to put up with this.


Pete's photoblog Misleading the public since 2010.
Reply With Quote
  #4  
Old 11th December 2009
Glen Bentley's Avatar
Glen Bentley Glen Bentley is offline
Full member
 
Join Date: Mar 2008
Location: Epping, Essex
Posts: 71
Thanks: 0
Thanked 1 Time in 1 Post
Likes: 0
Liked 0 Times in 0 Posts
Re: E510

You're right it is the focus LED that is showing up but I don't recall it being there before.

Can't say that I understand the focus screen - is this the viewfinder screen, this has two grooves into which the eyecup slides. The actual viewfinder pane looks as if it is secured by 4 screws and isn't loose.

Perhaps I am imagining that the light did not show before.
__________________
Glen
Cogito sumere potum alterum
Reply With Quote
  #5  
Old 12th December 2009
snaarman's Avatar
snaarman snaarman is offline
Full member
 
Join Date: Feb 2008
Location: Baaarkshire UK
Posts: 6,867
Thanks: 502
Thanked 417 Times in 325 Posts
Likes: 492
Liked 1,343 Times in 507 Posts
Re: E510

Quote:
Originally Posted by Glen Bentley View Post
You're right it is the focus LED that is showing up but I don't recall it being there before.

Can't say that I understand the focus screen - is this the viewfinder screen, this has two grooves into which the eyecup slides. The actual viewfinder pane looks as if it is secured by 4 screws and isn't loose.

Perhaps I am imagining that the light did not show before.

No, the focus screen can only be seen if you take the lens off. If you look in the hole you see the mirror. Reflected in its surface you will see the focus screen

Pete
__________________
Look, I'm an old man. I shouldn't be expected to put up with this.


Pete's photoblog Misleading the public since 2010.
Reply With Quote
  #6  
Old 12th December 2009
Glen Bentley's Avatar
Glen Bentley Glen Bentley is offline
Full member
 
Join Date: Mar 2008
Location: Epping, Essex
Posts: 71
Thanks: 0
Thanked 1 Time in 1 Post
Likes: 0
Liked 0 Times in 0 Posts
Re: E510

Mmmm. I am now poorer, wiser and never want to open a camera again apart from changing lens.

I must conclude that the light has always been there and I just never noticed it.

Thanks for your input and I also know what people are now on about when they talk of split focus screens.
__________________
Glen
Cogito sumere potum alterum
Reply With Quote
  #7  
Old 12th December 2009
andym's Avatar
andym andym is offline
Senior Member
 
Join Date: Nov 2007
Location: Epping Forest
Posts: 4,355
Thanks: 37
Thanked 346 Times in 258 Posts
Likes: 39
Liked 1,010 Times in 300 Posts
Re: E510

What you been up to??

You should have gone down the Spurs,that could have been really depressing.
__________________
All the best

Being left handed my brain sometimes works sdrawkcab

Andy

Lots of cameras and lenses.


My Flickr
Reply With Quote
Reply

Tags
e510, red light

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
More from The Solway and the E510 gregles Foto Fair 11 2nd December 2009 09:50 PM
E510 Body Byford For sale or wanted small ads 0 4th October 2009 06:53 AM
E510/18-180 Walking Kit NeilDS Looking for improvement 0 31st May 2009 11:33 AM
Rugby with e510 mike_j Looking for improvement 5 23rd February 2009 03:26 PM
My E510 has arrived :-) bully74uk Olympus E-510 5 24th June 2008 04:50 PM


All times are GMT. The time now is 09:57 PM.


The Write Technology Ltd, 2007-2019, All rights reservedAd Management plugin by RedTyger