Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Cameras, lenses and system accessories > Camera conference > Micro Four Thirds > Olympus OM-D E-M5

Olympus OM-D E-M5 The first Micro Four Thirds camera from Olympus with an integrated Electronic Viewfinder

Reply
 
Thread Tools Display Modes
  #1  
Old 27th April 2017
snaarman's Avatar
snaarman snaarman is online now
Full member
 
Join Date: Feb 2008
Location: Baaarkshire UK
Posts: 6,842
Thanks: 495
Thanked 417 Times in 325 Posts
Likes: 492
Liked 1,301 Times in 499 Posts
HELP! E-M5 grip stopped working

EDIT: Problem fixed: see below


Hi guys

Well, I got my HLD-6P grip out of the cupboard and dusted it off (I hardly ever use it). There's a photo club meet tonight and I don't want my little E-M5 getting an inferiority complex.

Anyway: I find the grip shutter release does what it should but none of the three grip dials work. The two buttons don't do anything either.

It's so long since I used it - are there settings somewhere in the menus?

I have cleaned all the contacts. I charged all the batteries. I made certain the grip switch is not set to "lock" and I updated the camera to latest software with the grip attached. No joy.

Any ideas?

Pete
__________________
Look, I'm an old man. I shouldn't be expected to put up with this.


Pete's photoblog Misleading the public since 2010.
Reply With Quote
  #2  
Old 27th April 2017
andym's Avatar
andym andym is offline
Senior Member
 
Join Date: Nov 2007
Location: Epping Forest
Posts: 4,355
Thanks: 37
Thanked 346 Times in 258 Posts
Likes: 39
Liked 1,010 Times in 300 Posts
Re: HELP! E-M5 grip stopped working

Probably won't help you but used to find the dials on the grip were a bit temperamental in warm weather.
__________________
All the best

Being left handed my brain sometimes works sdrawkcab

Andy

Lots of cameras and lenses.


My Flickr
Reply With Quote
The Following User Says Thank You to andym For This Useful Post:
snaarman (27th April 2017)
  #3  
Old 27th April 2017
snaarman's Avatar
snaarman snaarman is online now
Full member
 
Join Date: Feb 2008
Location: Baaarkshire UK
Posts: 6,842
Thanks: 495
Thanked 417 Times in 325 Posts
Likes: 492
Liked 1,301 Times in 499 Posts
Re: HELP! E-M5 grip stopped working

FIXED

I guess it's obvious in a way. I cleaned all the gold contacts with isoprop alcohol even though they didn't look dirty.

I had given them a good thumb wipe before and there's plenty of spring in the sliding contacts - but that wasn't enough. So - mental note. Just because the contact's look OK that doesn't mean they will be OK.

:-)

Phew

Pete
__________________
Look, I'm an old man. I shouldn't be expected to put up with this.


Pete's photoblog Misleading the public since 2010.
Reply With Quote
The Following Users Liked This Post:
OM USer (30th July 2017), Ross the fiddler (28th April 2017)
  #4  
Old 30th July 2017
chipbutty chipbutty is offline
Member
 
Join Date: Feb 2014
Location: Sheffield
Posts: 73
Thanks: 6
Thanked 7 Times in 5 Posts
Likes: 42
Liked 42 Times in 16 Posts
Re: HELP! E-M5 grip stopped working

I had similar problems with my E-M5 and HLD6 grip. Alcohol didn't work for me but what I found to work great is one of those rubbers used to clean suede! I just rubbed the contacts and it did the trick.

__________________
My Flickr PhotoStream

Olympus OM-D E-M1, Ricoh GR ll
Reply With Quote
  #5  
Old 30th July 2017
Otto's Avatar
Otto Otto is online now
Full member
 
Join Date: Apr 2013
Location: North Yorkshire
Posts: 3,015
Thanks: 94
Thanked 274 Times in 241 Posts
Likes: 1,037
Liked 871 Times in 556 Posts
Re: HELP! E-M5 grip stopped working

It's a common problem with gold-plated contacts on printed circuit boards so it doesn't surprise me here. I still have a "gold rubber" used to fix them, but I've no idea where to get another one!
__________________
Regards
Richard
Reply With Quote
The Following User Liked This Post:
chipbutty (30th July 2017)
  #6  
Old 30th July 2017
George Dorn's Avatar
George Dorn George Dorn is offline
Full member
 
Join Date: Aug 2011
Location: North West Leicestershire
Posts: 1,120
Thanks: 216
Thanked 90 Times in 82 Posts
Likes: 677
Liked 129 Times in 69 Posts
Re: HELP! E-M5 grip stopped working

Don't go in to Boots to ask for one...
__________________
Colin
"Don't blame me..."
Reply With Quote
The Following User Liked This Post:
chipbutty (30th July 2017)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! Generic shutter release cables stopped working Ivor Olympus E-5 13 13th February 2016 05:54 PM
HELP! My E-P1 Viewfinder has stopped working OperaNut1972 Olympus Pen E-P1 3 5th October 2010 10:21 AM
Olympus is dead! (My camera stopped working) roadkill_6mm Foto Fair 17 3rd October 2010 05:51 PM
My Camera Has Stopped Working! Zuiko The lounge 10 20th September 2010 08:40 AM
Camera stopped working sapper Olympus E-3 5 21st September 2009 02:23 PM


All times are GMT. The time now is 08:48 AM.


The Write Technology Ltd, 2007-2019, All rights reservedAd Management plugin by RedTyger