Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Out of Focus area > The lounge

The lounge Relax, take a break from photo and camera talk - have a chat about something else for a change. Just keep it clean and polite!

Reply
 
Thread Tools Display Modes
  #1  
Old 25th May 2011
shauni
Guest
 
Posts: n/a
SP-950 mode dial help...its came off!

Hi, not sure if anyone can help.
I've rescued a SP-950. Picture was terrible (display was multi coloured) and lens loose.
I've managed to rectify these, but now have the issue of the the mode dial. Nothing appears to be broken, but i can't seem to clip it into place.
Not sure if theres a locking washer or something that i need to pop out.
Can anyone help? Does anyone have a service manual? Clutching at straws, but the camera is working like new and would be great to have in the car for the odd snap!
Many thanks
Shaun
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What program mode do you use ozzie Olympus E-5 16 11th May 2011 11:40 PM
Which Focus Mode? Seonnaidh Olympus E-5 4 18th March 2011 10:08 AM
HELP! E-1 Mode Dial problem bmul Olympus E-1 0 18th August 2010 09:12 PM
E3 focus mode monoboard Olympus E-3 7 27th June 2010 03:49 PM
Confusion over My Mode StephenL Olympus E-3 4 29th November 2008 03:57 PM


All times are GMT. The time now is 06:36 PM.


The Write Technology Ltd, 2007-2019, All rights reservedAd Management plugin by RedTyger