Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Cameras, lenses and system accessories > Camera conference > Olympus E-420

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 7th November 2012
Sharonpix
Guest
 
Posts: n/a
Problem with E-420

I wonder if anyone has come across this problem before?? I have bought a second hand E-420 as I wanted it for all the spares and extra lens it came with.
It arrived today and on using it, I found that when u look through the view finder, what you're looking at is blurred. When you take a picture, it shows clear and crisp on the LCD screen but looking through the view finder, its blurry.
Is this a fault that can be fixed relatively cheaply or would I be better off returning it?
Id appreciate any advice anyone can give me.

Thanks alot

Sharon
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
E5 problem Melaka Olympus E-5 9 11th March 2012 01:40 PM
HELP! 12-60 problem? tommy781 Wide angle 7 7th November 2011 04:40 PM
E-510 problem meach Olympus E-510 2 29th January 2010 01:03 PM
HELP! FL-36 problem meach Flash 4 30th October 2009 12:18 PM
Anyone Had This Problem? E-3 EH1 Olympus E-3 2 27th May 2009 06:00 PM


All times are GMT. The time now is 09:02 AM.


The Write Technology Ltd, 2007-2019, All rights reservedAd Management plugin by RedTyger