Olympus UK E-System User Group

Olympus UK E-System User Group (https://e-group.uk.net/forum/index.php)
-   Olympus E-510 (https://e-group.uk.net/forum/forumdisplay.php?f=13)
-   -   Prism and clips fell out E510 (https://e-group.uk.net/forum/showthread.php?t=46009)

Tripleteer 30th August 2017 10:59 AM

Prism and clips fell out E510
 
Hi all.
Cleaning the mirror on my E510 this morning and the prism (frosted glass thingy) and two clips fell into my hand, can anyone advise how to fit these items back, I took a picture of these items but I can't seem to upload them from my iPad. Thanks in advance for any help. Paul.

Zuiko 30th August 2017 04:23 PM

Re: Prism and clips fell out E510
 
Oh dear, Paul, I'm sorry to hear that. I wouldn't have a clue where to start, it might need a trip to a camera repairer such as Luton Cameras.

Tripleteer 30th August 2017 04:49 PM

Re: Prism and clips fell out E510
 
Hi All.
I found a video on YouTube and all is welll, Thanks to all for their interest, Paul.
It was actually the photo screen and brackets.

bassman 1st September 2017 08:08 AM

Re: Prism and clips fell out E510
 
Focus screen and clips... glad you're all sorted. Seem to remember upgrading the screen in my E-500 and was quite the norm with various 35mm SLR cameras.


Mark

shenstone 3rd September 2017 05:14 PM

Re: Prism and clips fell out E510
 
It happened to me once (I cant remember if it was the 500 or 510)

Scary isn't it...

Nice to hear you solved it like I was able to

Regards
Andy


All times are GMT. The time now is 05:58 AM.


The Write Technology Ltd, 2007-2019, All rights reservedAd Management plugin by RedTyger