Olympus UK E-System User Group

Olympus UK E-System User Group (https://e-group.uk.net/forum/index.php)
-   Olympus E-330 (https://e-group.uk.net/forum/forumdisplay.php?f=10)
-   -   Urgent Help - xD chip failure (https://e-group.uk.net/forum/showthread.php?t=30973)

blu-by-u 4th January 2014 01:35 AM

Urgent Help - xD chip failure
 
Was reviewing my shots taken when the camera sudden showed card error. I have since immediately removed the chip from the camera. From a card reader, the chip cannot be detected. What can I do to retrieve those pictures?

Please advice.

Wally 4th January 2014 09:16 AM

Re: Urgent Help - xD chip failure
 
Try gently cleaning the brass contacts with a soft pencil eraser. Sometimes this clears the problem. Not sure what else to try as the chips are very much a closed system.

Ulfric M Douglas 4th January 2014 10:02 AM

Re: Urgent Help - xD chip failure
 
And it could just be old age, those XD cards are ... ancient.

Phill D 4th January 2014 06:20 PM

Re: Urgent Help - xD chip failure
 
There are several file recovery programmes on the web that I'm told seem to work ok. Maybe one of them might help? I don't have any recommendations myself but maybe others will.

blu-by-u 6th January 2014 06:14 AM

Re: Urgent Help - xD chip failure
 
Did the cleaning. As of now, the chip is not even detected. :( Tried 3 different readers and nothing works.

It's got 3 days of my Hokkaido tour inside.


All times are GMT. The time now is 12:39 PM.


The Write Technology Ltd, 2007-2019, All rights reservedAd Management plugin by RedTyger