Announcement

Collapse
No announcement yet.

macOS update & compatability issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • macOS update & compatability issues

    Today Apple has released the latest version of macOS = 10.15 aka 'Catalina'.

    This OS version does not support any 32bit programs. Hence Olympus Digital Camera Updater and Capture will not work with this OS.
    I'm not sure if Viewer will run?

    Also for those of you still using Adobe "perpetual" licensed s/w, be aware that Lightroom v6 will stop working - even though it is stated to be 64bit, as it contains components which remain 32 bit.
    The Adobe Application Manager is also 32bit only.

    There are already reports of other major problems with more recent Adobe s/w and Catalina, including the 2018 versions of Adobe subscription s/w.

    You can check which of your installed programs are incompatible before updating the OS by:-
    1. Launch System Information
    2. Open 'System Report'
    3. Select 'Software'
    4. Click & expand 'Legacy Software'


    So if you are inclined to be an 'early adopter' of macOS (in order to benefit from numerous security fixes) be careful what you wish for
    Last edited by Gwyver; 8th October 2019, 04:07 PM. Reason: additional details included
    Chris

  • #2
    Re: macOS update & compatability issues

    Originally posted by Gwyver View Post
    This OS version does not support any 32bit programs. Hence Olympus Digital Camera Updater and Capture will not work with this OS.

    Are you "obliged" to update MacOS the way you are Windows 10 or can you just decline the updates? iOS13 has just launched too and guess what? My iPhone 6 and iPad Mini 2 are not compatible with it, but at least I can just carry on using iOS 12 for now. Something similar to the 32/64 bit issue happened with iOS a few years ago when some apps would no longer work under the new 64 bit iOS. Most were eventually updated but I still have an iPhone 4S just in case!
    Regards
    Richard

    Comment


    • #3
      Re: macOS update & compatability issues

      No obligation necessary, you can decide to update if and when you wish.
      Stewart

      My Zenfolio Site
      My Portfolio Site

      Olympus: E-M1 Mk11 | PEN-F + ECG-4 | XZ-1 | Lumix: G9 | LX100
      Zuiko: 40-150 Pro + MC-14 | 12-100 Pro | 7-14 Pro | 17 | 45 | 60 | OM 135
      Leica: 100-400 | 12-60 Lumix: 12-32 Samyang: 7.5 fisheye

      Comment


      • #4
        Re: macOS update & compatability issues

        Thanks for the warning about Lightroom. I had hoped it would be ok. Mind you, I am still running High Sierra since and don’t normally upgrade until the version I am running has ceased to be supported with security updates.

        Comment


        • #5
          Re: macOS update & compatability issues

          Catalina also takes Aperture out behind the shed and kills it. So if you have an Aperture based library ensure that you can continue to boot into Mojave or an earlier version.
          This space for rent

          Comment


          • #6
            Re: macOS update & compatability issues

            I thought that Macs 'Just worked'!

            Jim

            Comment


            • #7
              Re: macOS update & compatability issues

              All updated OK here, all seems to work as it should except the camera updater, so I'll leave my laptop until Olympus update the app.
              I didn’t get where I am today....

              Comment


              • #8
                Re: macOS update & compatability issues

                Originally posted by Jim Ford View Post
                I thought that Macs 'Just worked'!

                Jim
                Whatever!

                Old discussion not worthy of you!
                I didn’t get where I am today....

                Comment


                • #9
                  Re: macOS update & compatability issues

                  I'm basically planning not to update for some months, if indeed ever, since there are issues not only with Adobe stuff, but apparently with my colour calibration software, and all my printer drivers. So not only might I not be able to process, I couldn't calibrate or print anything!

                  And they call this Progress...
                  Margaret

                  my Website ; my Flickr ; my Facebook

                  Comment


                  • #10
                    Re: macOS update & compatability issues

                    Originally posted by MargaretR View Post
                    I'm basically planning not to update for some months, if indeed ever, since there are issues not only with Adobe stuff, but apparently with my colour calibration software, and all my printer drivers. So not only might I not be able to process, I couldn't calibrate or print anything!

                    And they call this Progress...
                    I didn’t get where I am today....

                    Comment


                    • #11
                      Re: macOS update & compatability issues

                      The Epson issue is not confined to MacOS, every time a Windows 10 "Feature Update" is rolled out it deletes all my Epson software and drivers because they are "unsigned". This means having to delve several levels down into the advanced options menu during boot-up to allow unsigned drivers to be installed. Next update deletes them again .
                      Regards
                      Richard

                      Comment


                      • #12
                        Re: macOS update & compatability issues

                        Thanks for the reminder and info. What I did last time was clone my system to an external bootable drive using Carbon Copy Cloner and do the upgrade on the external drive to try it out for a while. Then when I finally decided to upgrade the main drive, I made a bootable copy of the old OS-X system on an external drive so I could go back. In fact, I will have to do that as I want to be able to open my Aperture Libraries that I have not migrated to C1Pro. I've only been using Mojave for a short time since I updated to a new Mac Mini, so it seems a bit soon for a major update for me!
                        https://www.flickr.com/photos/macg33zr/

                        Comment


                        • #13

                          Comment


                          • #14
                            Re: macOS update & compatability issues

                            Capture One Pro

                            Comment


                            • #15
                              Re: macOS update & compatability issues

                              For those who have hung on to Picasa for display / management purposes, it no longer works. Fortunately I had the foresoght to look for something else and started playing with ACDSee Photo Studio about a year or so back. So no real disruption for me.

                              Capture One Pro works fine, as does Olympus Workspace, although I haven't played with it fully.
                              Larry

                              Cameras: Olympus OM-D E-M1 II, Olympus OM-D E-M1 | Flash: Olympus FL-50R
                              Lenses: Olympus M.ZUIKO DIGITAL 12-40mm f/2.8 PRO, Olympus M.ZUIKO DIGITAL ED 12-100mm f/4.0 IS PRO, Olympus MMF-3 adaptor, Olympus Zuiko Digital ED 12-60mm f2.8-4.0 SWD, Olympus Zuiko Digital 14-45mm 1:3.5-5.6, Olympus Zuiko Digital 40-150mm 1:3.5-4.5, Olympus Zuiko Digital 70-300mm 1:4-5.6, Panasonic Leica DG Vario-Elmar 100-400mm f4.0-6.3 ASPH

                              Comment

                              Working...
                              X