Announcement

Collapse

December's CHALLENGE

The topic to inspire your creative juices this month is BOXES

See more
See less

Panasonic Leica 100-400 on Olympus Body - Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Panasonic Leica 100-400 on Olympus Body - Problems

    Hi guys

    I have been following a very interesting thread in another forum about a problem when using a possibly faulty batch of Panny 100-400 lenses.

    If you have this combination, or even if you haven't, I would strongly suggest reading the thread. It does make interesting reading as you work your way through each post and finally get to the end.

    I hope it's ok posting this link to another forum but it is in the interest of all I think.

    Here it is -

    https://www.mu-43.com/threads/the-pa...-bodies.95115/

    Don't worry about the title or some of the earlier posts, it does get there, and with surprising results.

    Hope it's of interest to all

    Keith

  • #2
    Re: Panasonic Leica 100-400 on Olympus Body - Problems

    No obvious problem with my combination.

    Mind I don't tend to stand under waterfalls with the kit, and in rain try to protect the camera and lens as much as possible.................
    Mark Johnson

    My Sailing Page

    My Flickr

    Comment


    • #3
      Re: Panasonic Leica 100-400 on Olympus Body - Problems

      I read about that yesterday, and on inspecting my own 100-400, have noticed that the sealing ring has two small sections (about 2-3 mm) which has detached from the inner part of the mount.
      It is usually attached to my GX8, although I don't normally use it in rainy conditions.
      Stewart

      My Zenfolio Site
      My Portfolio Site

      Olympus: E-M1 Mk11 | PEN-F + ECG-4 | XZ-1 | EE-1 Dot Sight••• Lumix: G9 | LX100 ••• Nissin: i40
      Zuiko: 40-150 Pro + MC-14 | 12-100 Pro | 7-14 Pro | 17 | 45 | 60 | OM 135 ••• Leica: 100-400 | 12-60••• Samyang: 7.5 fisheye ••• Tamron: 14-150 •

      Comment


      • #4
        Re: Panasonic Leica 100-400 on Olympus Body - Problems

        This is what is being described:

        https://www.facebook.com/photo.php?f...&theater&ifg=1
        Graham

        We often repeat the mistakes we most enjoy...

        Comment


        • #5
          Re: Panasonic Leica 100-400 on Olympus Body - Problems

          As i said on the thread you must need a lot of force to cause that sort of damage,i still fail to see why any one would go through so many lenses and bodies before saying enough is enough.

          Comment


          • #6
            Re: Panasonic Leica 100-400 on Olympus Body - Problems

            This sounds like the same sort of problem that affected the original Sony A7 and A7R camera bodies, where the body mount was partially plastic and wore with heavy use to deposit shards within the body.
            They spotted the problem before launching the A7S, and this and all subsequent models have non-shredding bayonets.
            Regards,
            Mark

            ------------------------------
            http://www.microcontrast.com
            Too much Oly gear.
            Panasonic GM5, 12-32, 12-35, 15. Laowa 7.5.
            Assorted legacy lenses, plus a Fuji X70 & a Sony A7S.

            Comment


            • #7
              Re: Panasonic Leica 100-400 on Olympus Body - Problems

              have been using this lens since late march in all conditions on my mk2 body,it has a seal on the mount flange, the machining finish on the flange is good and there are no wear marks on lens or body. I also applied a minimum amount of silicon grease on the lens seal just in case, of rubber hardening etc applied some to zoom seal also being very careful to apply minimally

              Comment


              • #8
                Re: Panasonic Leica 100-400 on Olympus Body - Problems

                Sorry to resurrect an old thread but just wanted to flag up this problem with the 100-400 hasn't gone away. I bought one yesterday at the photo show and it has covered my lens bayonet and camera mount in metal shards
                Needless to say it's going back tomorrow - not impressed with Panasonic QC on this lens hopefully WEX will do the right thing and swap it for one that's OK if they have one! Might have to see if Olympus will take a look at my camera just to check I got all the bits off the mount.
                To say I'm not happy is an understatement
                http://www.flickr.com/photos/flip_photo_flickr/

                Comment


                • #9
                  Re: Panasonic Leica 100-400 on Olympus Body - Problems

                  That’s a bxxxxr
                  I’m sure it’s a good idea to get the Olympus elves to clean it out if you can.
                  Regards,
                  Mark

                  ------------------------------
                  http://www.microcontrast.com
                  Too much Oly gear.
                  Panasonic GM5, 12-32, 12-35, 15. Laowa 7.5.
                  Assorted legacy lenses, plus a Fuji X70 & a Sony A7S.

                  Comment


                  • #10
                    Re: Panasonic Leica 100-400 on Olympus Body - Problems

                    Originally posted by Phill D View Post
                    Sorry to resurrect an old thread but just wanted to flag up this problem with the 100-400 hasn't gone away. I bought one yesterday at the photo show and it has covered my lens bayonet and camera mount in metal shards
                    Needless to say it's going back tomorrow - not impressed with Panasonic QC on this lens hopefully WEX will do the right thing and swap it for one that's OK if they have one! Might have to see if Olympus will take a look at my camera just to check I got all the bits off the mount.
                    To say I'm not happy is an understatement
                    That sounds a bit rough. Can only say that mine fits like a glove...I would certainly be worried more about the camera being pristine inside. And they know what they can do with the lens! Perhaps you can fit a new lens and see if its the same before buying again...….Good luck
                    Mark Johnson

                    My Sailing Page

                    My Flickr

                    Comment


                    • #11
                      Re: Panasonic Leica 100-400 on Olympus Body - Problems

                      May well try another lens Mark but as you can imagine I'd want to be very careful. The returning lens was only put on once used for a few shots and removed. Luckily I noticed a couple of shiny spots on the camera flange that I managed to remove very very carefully with selotape but the lens flanges had a lot more bits on them. I've captured some of them on selotape too as evidence if I get any hassle returning it. Fingers crossed for a good outcome.
                      http://www.flickr.com/photos/flip_photo_flickr/

                      Comment


                      • #12
                        Re: Panasonic Leica 100-400 on Olympus Body - Problems

                        Interesting...

                        My own experience is a three hour long hike in rain forest in very moist and rainy conditions. Rain was light-moderate, not torrential. I'd assess the precipitation some 1-2 mm/h. No heavy showers to speak of.

                        I was using the E-M1 M2 and the m.Zuiko 40-150 PRO, my travel companion had a Panasonic GH9 fitted with m.Zuiko 12-40 PRO.

                        Back in the car after the hike we took a few last shorts from within the car, side window open. When quickly reviewing the harvest from the session we noticed that the contrast in the last pictures taken with the Panasonic/m.Zuiko combo from within the car seemed poor. A quick look revealed that humidity had condensated on the rear element of the m.Zuiko 12-40, and it also looked like condensation had creeped inside the lens. It was quite pronounced. Lucklily there were no droplets formed yet but the lens required a cure, leaving it in the tropical sun for a while fixed it. No sign of condensation inside the body.

                        The Olympus gear showed no signs of condensation whatsoever.

                        To me it demonstrates that the Olympus gear is truly weather sealed, but that the fitting/sealing between Olympus and Panasonic is not fully reliable.

                        Thought some of you would be interested reading about this.

                        Cheers
                        Tord

                        My Gallery on 500px

                        Comment

                        Working...
                        X