Announcement

Collapse

December's CHALLENGE

The topic to inspire your creative juices this month is BOXES Please don't forget to vote on November's LEAVES challenge and please re-vote if you already did but before the recent forum upgrade.

See more
See less

Am I missing something?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP! Am I missing something?

    I've just bought an E520 but there seems to be a problem - I can't achieve a focus lock.
    It came with the 40-150 zoom and this is OK on another body and I've tried a different lens on the 520 - no different.
    I went through the menus then reset then went through the menus again, still no joy.
    The only thing I haven't done yet is compared the settings to my E510.
    Any ideas or is the body faulty?

  • #2
    Re: Am I missing something?

    Does the body even attemot to focus the lens? If not it might be set to manual focus.

    Another problem could be dirty lens contacts in the body, try giving the a careful clean.

    Does the lens lock positively when mounted on the body, without any play? Damage to the lens mount on the body is another possibility.

    Good luck, hope it's easily sorted.
    John

    "A hundredth of a second here, a hundredth of a second there � even if you put them end to end, they still only add up to one, two, perhaps three seconds, snatched from eternity." ~ Robert Doisneau

    Comment


    • #3
      Re: Am I missing something?

      Hi John

      Thanks for your prompt reply.

      The camera does attempt to focus. As you activate the AF (set to Fn button) there is a delay before the lens focus 'zooms' out and back without achieving lock.

      I've rubbed the contacts with a clean cotton bud but no difference.

      There is no undue play in the mounting.

      Ian

      Comment


      • #4
        Re: Am I missing something?

        Hopefully some others will chip in with ideas. My only other thought at this stage, is it set to single or continuous AF?
        John

        "A hundredth of a second here, a hundredth of a second there � even if you put them end to end, they still only add up to one, two, perhaps three seconds, snatched from eternity." ~ Robert Doisneau

        Comment


        • #5
          Re: Am I missing something?

          When you half press the shutter - does the f-number display in the viewfinder, or does it remain blank. If the latter then it does suggest the contacts (or something else in the connection twixt camera/lens) is at fault.

          Nick
          Nick Temple-Fry

          Medicine as a science ranks somewhere between archaeology and economics.

          www.theChurchPhotographer.co.uk 90 Churches -- Fairford St Mary's, exceptionally splendid
          www.temple-fry.co.uk

          Comment


          • #6
            Re: Am I missing something?

            John

            The camera is set to S-AF+MF at present. Just tried it on C-AF and it behaves exactly the same.

            Nick

            The f-number etc is displayed.

            I'm thinking the camera is malfunctioning.

            Ian

            Comment


            • #7
              Re: Am I missing something?

              Must admit it seems to be a case of return to seller, what a nuisance.
              John

              "A hundredth of a second here, a hundredth of a second there � even if you put them end to end, they still only add up to one, two, perhaps three seconds, snatched from eternity." ~ Robert Doisneau

              Comment


              • #8
                Re: Am I missing something?

                You could try blowing out the AF sensor window in the throat of the camera, at the bottom, just behind the lens mount. There could be a bit of fluff in there.
                I don't have an E520 myself, but how does the live view work. Can you get it to focus in LV mode? (this would only be relevant if you can set it to Contrast AF in LV mode)


                Good luck
                Best Regards
                Bill

                The nearest I have to a home page.
                http://www.flickr.com/photos/peak4/
                They're Watching You!

                Comment


                • #9
                  Re: Am I missing something?

                  Thanks for all your help but still no joy.

                  I've contacted the seller about sending it back and he says he won't accept returns.

                  Since it was from Ebay I guess I'll have to make a claim.

                  Comment


                  • #10
                    Re: Am I missing something?

                    Originally posted by g9ern View Post
                    Thanks for all your help but still no joy.

                    I've contacted the seller about sending it back and he says he won't accept returns.

                    Since it was from Ebay I guess I'll have to make a claim.
                    It's not a return if it is faulty!
                    Get your claim in to ebay.

                    Comment


                    • #11
                      Re: Am I missing something?

                      He has no choice if it's faulty - you're covered by the Sale of Goods Act.
                      Paul

                      Comment


                      • #12
                        Re: Am I missing something?

                        Howi/Paul
                        I know, he's not willing to give me his address so it's off to Ebay we go!

                        Comment


                        • #13
                          Re: Am I missing something?

                          Originally posted by meach View Post
                          He has no choice if it's faulty - you're covered by the Sale of Goods Act.
                          Not if it's 2nd hand. Applies to new goods from a retailer only (or services).
                          It IS covered by contract law however, but ebay claim is easier and cheaper!

                          Have you tried re-setting defaults?

                          Ebay claim seems the best way. Usually works out fine, but a lengthy process!

                          David
                          --------------------------
                          -XZ-1 * VF-2+EP-9
                          --------------------------

                          Comment


                          • #14
                            Re: Am I missing something?

                            Originally posted by DJMC View Post
                            Not if it's 2nd hand. Applies to new goods from a retailer only (or services).
                            It IS covered by contract law however, but ebay claim is easier and cheaper!

                            Have you tried re-setting defaults?

                            Ebay claim seems the best way. Usually works out fine, but a lengthy process!

                            Yes, unfortunately I have had to do this before and it usually comes out on the buyers side.

                            Yes I tried the reset this morning.

                            Comment


                            • #15
                              Re: Am I missing something?

                              Originally posted by DJMC View Post
                              Not if it's 2nd hand. Applies to new goods from a retailer only (or services).
                              It IS covered by contract law however, but ebay claim is easier and cheaper!

                              Have you tried re-setting defaults?

                              Ebay claim seems the best way. Usually works out fine, but a lengthy process!

                              Not sure this is correct - any item sold (especially by a business - does the vendor have a 'shop' on eBay?) must meet the description as advertised and autofocus is fundamental to the operation of the camera.

                              Ian
                              Founder and editor of:
                              Olympus UK E-System User Group (http://e-group.uk.net)
                              Four Thirds User (http://fourthirds-user.com)
                              Digital Photography Now (http://dpnow.com)
                              Olympus camera, lens, and accessory hire (http://e-group.uk.net/hire)

                              Twitter: www.twitter.com/ian_burley
                              Flickr: www.flickr.com/photos/dpnow/
                              Pinterest: www.pinterest.com/ianburley/
                              NEW: My personal BLOG ianburley.com
                              sigpic

                              Comment

                              Working...
                              X