Announcement

Collapse
No announcement yet.

Olympus Pen E-PL1 showing blank screen with pentax k lens

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP! Olympus Pen E-PL1 showing blank screen with pentax k lens

    Hi,

    I have an Olympus pen e-pl1 camera, and bought a pentax pk to m43 lens adapter with some pentax pk lens. When everything is connected, the camera shows a black screen, but you can get into the different modes. Is there any settings to choose from on the menu or any changes needed to be made, to get the pentax lens working or even anything showing on screen? When I put the standard M Zuiko kit lens back on, it works as normal.

    Hope someone can help out

    Thanks

  • #2
    Re: Olympus Pen E-PL1 showing blank screen with pentax k lens

    Originally posted by RPXL UK View Post
    Hi,

    I have an Olympus pen e-pl1 camera, and bought a pentax pk to m43 lens adapter with some pentax pk lens. When everything is connected, the camera shows a black screen, but you can get into the different modes. Is there any settings to choose from on the menu or any changes needed to be made, to get the pentax lens working or even anything showing on screen? When I put the standard M Zuiko kit lens back on, it works as normal.

    Hope someone can help out

    Thanks
    Is the lens fully stopped down when it is mounted on the camera? It may simply be too dark to show anything?

    Ian
    Founder and editor of:
    Olympus UK E-System User Group (http://e-group.uk.net)
    Four Thirds User (http://fourthirds-user.com)
    Digital Photography Now (http://dpnow.com)
    Olympus camera, lens, and accessory hire (http://e-group.uk.net/hire)

    Twitter: www.twitter.com/ian_burley
    Flickr: www.flickr.com/photos/dpnow/
    Pinterest: www.pinterest.com/ianburley/
    NEW: My personal BLOG ianburley.com
    sigpic

    Comment


    • #3
      Re: Olympus Pen E-PL1 showing blank screen with pentax k lens

      Hi,

      The adapter is properly attached to the body and lens is aswel. I tried it in light conditions, same problem. By the way I am an amature photographer.

      Comment


      • #4
        Re: Olympus Pen E-PL1 showing blank screen with pentax k lens

        And I have rotated the aperture ring, opened and closed. Same problem

        Comment


        • #5
          Re: Olympus Pen E-PL1 showing blank screen with pentax k lens

          If you put the normal lens on is everything fine?

          Which exposure mode are you using when the Pentax lens is fitted?

          Ian

          Update - sorry - just read in the first post that the normal lens works OK.
          Founder and editor of:
          Olympus UK E-System User Group (http://e-group.uk.net)
          Four Thirds User (http://fourthirds-user.com)
          Digital Photography Now (http://dpnow.com)
          Olympus camera, lens, and accessory hire (http://e-group.uk.net/hire)

          Twitter: www.twitter.com/ian_burley
          Flickr: www.flickr.com/photos/dpnow/
          Pinterest: www.pinterest.com/ianburley/
          NEW: My personal BLOG ianburley.com
          sigpic

          Comment


          • #6
            Re: Olympus Pen E-PL1 showing blank screen with pentax k lens

            Hi

            Yes, when the normal kit lens is on, everything works. When using the pentax k lens, I try all modes, such as A, P, M. But dark screen, you can see info though such as ISO, M, etc

            Comment


            • #7
              Re: Olympus Pen E-PL1 showing blank screen with pentax k lens

              Wonder why it is not working

              Comment


              • #8
                Re: Olympus Pen E-PL1 showing blank screen with pentax k lens

                Originally posted by RPXL UK View Post
                Wonder why it is not working
                I have an OM lens mounted onto an E-PL1 using an MF-2 adapter here at the office and I haven't encountered a problem like yours. So this is a mystery!

                Ian
                Founder and editor of:
                Olympus UK E-System User Group (http://e-group.uk.net)
                Four Thirds User (http://fourthirds-user.com)
                Digital Photography Now (http://dpnow.com)
                Olympus camera, lens, and accessory hire (http://e-group.uk.net/hire)

                Twitter: www.twitter.com/ian_burley
                Flickr: www.flickr.com/photos/dpnow/
                Pinterest: www.pinterest.com/ianburley/
                NEW: My personal BLOG ianburley.com
                sigpic

                Comment


                • #9
                  Re: Olympus Pen E-PL1 showing blank screen with pentax k lens

                  Is there an option on the e-pl1 to switch off lens? I think on the panasonic m43 cameras there is an option to shoot without lens or something? That is what some people say on other forums regarding this.

                  Comment


                  • #10
                    Re: Olympus Pen E-PL1 showing blank screen with pentax k lens

                    I get this if the lens release button is not fully engaged and locked the lens onto the body. Press it in, turn the lens as if to take it off, then turn it back and listen for the click as the lens release pops out.

                    Hope this works.

                    Graham

                    We often repeat the mistakes we most enjoy...

                    Comment


                    • #11
                      Re: Olympus Pen E-PL1 showing blank screen with pentax k lens

                      There is an option for setting the focal length for accurate image stabilisation but I'm not aware of a setting for manual lenses other than this on Olympus cameras.

                      Ian
                      Founder and editor of:
                      Olympus UK E-System User Group (http://e-group.uk.net)
                      Four Thirds User (http://fourthirds-user.com)
                      Digital Photography Now (http://dpnow.com)
                      Olympus camera, lens, and accessory hire (http://e-group.uk.net/hire)

                      Twitter: www.twitter.com/ian_burley
                      Flickr: www.flickr.com/photos/dpnow/
                      Pinterest: www.pinterest.com/ianburley/
                      NEW: My personal BLOG ianburley.com
                      sigpic

                      Comment


                      • #12
                        Re: Olympus Pen E-PL1 showing blank screen with pentax k lens

                        Stupid question, but to rule out the obvious, is the lens cap on the Pentax lens? I've left the cap on mine a couple of times.

                        BTW I use a Pentax lens on the E-M5 which works fine.
                        Stephen

                        A camera takes a picture. A photographer makes a picture

                        Fuji X system, + Leica and Bronica film

                        My Flickr site

                        Comment


                        • #13
                          Re: Olympus Pen E-PL1 showing blank screen with pentax k lens

                          Originally posted by Graham_of_Rainham View Post
                          I get this if the lens release button is not fully engaged and locked the lens onto the body. Press it in, turn the lens as if to taks it off, then turn it back and listen for the click as the lens release pops out.

                          Hope this works.

                          That could be it I concur here with the E-PL1 in front of me. In fact there is a microswitch on the lens release button (on the camera body) and even if that is only pressed the screen goes blank. It could be that the Pentax adapter is not accurately machined and the lens release button is not being allowed to lock properly?

                          Ian
                          Founder and editor of:
                          Olympus UK E-System User Group (http://e-group.uk.net)
                          Four Thirds User (http://fourthirds-user.com)
                          Digital Photography Now (http://dpnow.com)
                          Olympus camera, lens, and accessory hire (http://e-group.uk.net/hire)

                          Twitter: www.twitter.com/ian_burley
                          Flickr: www.flickr.com/photos/dpnow/
                          Pinterest: www.pinterest.com/ianburley/
                          NEW: My personal BLOG ianburley.com
                          sigpic

                          Comment


                          • #14
                            Re: Olympus Pen E-PL1 showing blank screen with pentax k lens

                            I think you guys have got it! Though its not going to work for me. When i attach the olympus kit lens it makes a nice clicking noise, and the pentax m43 adapter doesn't. So this is it. Anyway to fix the problem????

                            Comment


                            • #15
                              Re: Olympus Pen E-PL1 showing blank screen with pentax k lens

                              The problem is with the Pentax adapter you are using. If you look at the camera's lens mount without the lens attached you will see a small lug at 3 o'clock sticking out a millimetre or so. When a lens is mounted but not in the correct position (fully turned in the mount) that lug is depressed and remains flush with the lens mount surface until the corresponding hole on the lens side of the mount aligns with the lug. The lug then springs back forward and the screen should work properly again. If your adapter doesn't have the corresponding hole or it has not been machined properly or is machined in the wrong positioned, you will have a problem as you have described. If the mount won't turn far enough, for example, you will need to get the adapter replaced.

                              Ian
                              Founder and editor of:
                              Olympus UK E-System User Group (http://e-group.uk.net)
                              Four Thirds User (http://fourthirds-user.com)
                              Digital Photography Now (http://dpnow.com)
                              Olympus camera, lens, and accessory hire (http://e-group.uk.net/hire)

                              Twitter: www.twitter.com/ian_burley
                              Flickr: www.flickr.com/photos/dpnow/
                              Pinterest: www.pinterest.com/ianburley/
                              NEW: My personal BLOG ianburley.com
                              sigpic

                              Comment

                              Working...
                              X