Announcement

Collapse

December's CHALLENGE

The topic to inspire your creative juices this month is BOXES

See more
See less

Is it something I am doing wrong?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is it something I am doing wrong?

    Just been out today with the E-M5 and a freshly charged original battery. It was pretty cold and I was out for about an hour, I'd taken about 50 shots when I noticed the dreaded red flash - familiar to many E-M5 users. I thought nothing more as it was pretty cold but when I got home I put the offending article on to charge and nothing happened! This is the third Olympus official battery I've had fail, one on the E30, one on the E5 and now this. Cheap nasty third market batteries seem to last as long and go on forever - long live dodgy eastern battery makers I say!

    I will be sending the battery back to SRS tomorrow to see if they can help, although I know the warranty does not cover batteries. Never had a problem with original batteries from any other manufacturer - my Leica Digilux battery, yes I only ever needed one, would last for around 900 shots and was still working perfectly when I sold the camera at around six years old. Another black mark against Olympus!

    David
    PBase Galleries:-http://www.pbase.com/davidmorisonimages

  • #2
    Re: Is it something I am doing wrong?

    I can't comment as I only use dodgy eastern batteries myself.
    Roger

    E-M5, 20mm/1.7, 45mm/1.8
    OM-1N, OM-10, OM-4ti, 24mm/2.8, 50mm/1.8, 85mm/2, Tamron 70-210mm/3.5
    cariadus.com | flickr | tumblr

    Comment


    • #3
      Re: Is it something I am doing wrong?

      Yep I'm a big fan of dodgy batteries myself.
      I agree with what has been said and to me it falls onto the same bottomless pit of despair that hugely expensive Oly official lens hoods reside in.
      It's not enough to make me forsake Oly but it does p*ss me off when I see budget Sigma lenses selling complete with lens hood, and the lenses are not all bad.
      I personally think that Oly need to climb down from their Ivory Tower and start treating their loyal customer base with a wee bit more respect.

      Rant over.


      "Always shoot in RAW and avoid JPEGs"

      William Shakespeare.

      Comment


      • #4
        Re: Is it something I am doing wrong?

        Olympus obviously have no idea there is a reccession on, I just looked at the price for an EC-20 at 387.00.

        Nikon @ 142
        Kenko @125.00
        Sigma @ 174.00
        Canon @238.00
        The picture tells the story, great when you have a bad memory.DW.

        Comment


        • #5
          Re: Is it something I am doing wrong?

          Originally posted by David Morison View Post
          Just been out today with the E-M5 and a freshly charged original battery. It was pretty cold and I was out for about an hour, I'd taken about 50 shots when I noticed the dreaded red flash - familiar to many E-M5 users. I thought nothing more as it was pretty cold but when I got home I put the offending article on to charge and nothing happened! This is the third Olympus official battery I've had fail, one on the E30, one on the E5 and now this. Cheap nasty third market batteries seem to last as long and go on forever - long live dodgy eastern battery makers I say!

          I will be sending the battery back to SRS tomorrow to see if they can help, although I know the warranty does not cover batteries. Never had a problem with original batteries from any other manufacturer - my Leica Digilux battery, yes I only ever needed one, would last for around 900 shots and was still working perfectly when I sold the camera at around six years old. Another black mark against Olympus!

          David
          I have a problem with a Hahnel battery which lasts only three or four dozen dozen shots. I'm waiting to see if a few charges improve things before sending it back.
          David

          EM1ii, EM10ii

          Comment


          • #6
            Re: Is it something I am doing wrong?

            I've had more chargers fail than batteries, but never "official" ones, of any make. I would be more than a little peeved if an "official" one failed so soon.
            Stephen

            A camera takes a picture. A photographer makes a picture

            Fuji X system, + Leica and Bronica film

            My Flickr site

            Comment


            • #7
              Re: Is it something I am doing wrong?

              Originally posted by StephenL View Post
              I've had more chargers fail than batteries, but never "official" ones, of any make. I would be more than a little peeved if an "official" one failed so soon.
              I've had a similar experience Stephen.
              My Expro dual charger has failed twice now, the first time when the LEDs stopped indicating the charge status. Second and most recent when I plugged the dual charger into the mains which accompanied by a disconcerting pop!

              To their credit Expro UK RMA'd and replaced the first one and are in the process of doing the same for the second one. I do wonder about the quality of the charger though, mind you it is handy having the dual version.
              Regards Huw


              Olympus equipment
              Capture One Pro
              My flickr

              Comment


              • #8
                Re: Is it something I am doing wrong?

                Originally posted by StephenL View Post
                I've had more chargers fail than batteries, but never "official" ones, of any make. I would be more than a little peeved if an "official" one failed so soon.
                To be fair it could be the charger that is at fault and as SRS have asked me to return the battery I will send the charger as well. Strange that the battery has enough left in it to operate the camera but won't charge so maybe......

                David
                PBase Galleries:-http://www.pbase.com/davidmorisonimages

                Comment

                Working...
                X