Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Cameras, lenses and system accessories > Camera conference > Olympus E-1

Olympus E-1 E-1 specific discussion.

Reply
 
Thread Tools Display Modes
  #1  
Old 27th July 2013
Footloose1949 Footloose1949 is offline
Full member
 
Join Date: Apr 2012
Location: Reading, Berkshire, UK
Posts: 86
Thanks: 0
Thanked 9 Times in 7 Posts
Likes: 0
Liked 4 Times in 2 Posts
E-1 rear grip problem solved!

For those of you who have been looking for what seems to date to be a permanent solution to the problem of the rear grip coming adrift from their E-1's, (and maybe other bodies too!) I'm pretty certain I've solved it, by using Evo-Stik's 'Serious Glue'! I applied a thin coating of this glue to the metal, and then carefully pressed the grip material to this. The glue takes about 3 hours to cure and has completely set after 24 hours. I'm guessing the alloy that these bodies are made of, is the culprit. Just make sure you have completely removed any traces of any other glue you have tried on the metal, and off the back of the grip.
Reply With Quote
The Following 3 Users Say Thank You to Footloose1949 For This Useful Post:
crimbo (27th July 2013), Imageryone (27th July 2013), timg (27th July 2013)
  #2  
Old 27th July 2013
timg timg is offline
Full member
 
Join Date: Aug 2008
Location: Cornwall, UK
Posts: 1,208
Thanks: 44
Thanked 116 Times in 111 Posts
Likes: 13
Liked 73 Times in 38 Posts
Re: E-1 rear grip problem solved!

A well timed piece of advice, the main grip has come away from my E1 recently!
__________________
GX7, EP3, 9-18, 14-45, 45-150, 20 1.7, 25 1.4, 45 1.8, FL36 & various OM glass. flickr
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
E-M5 grip problem brianvickers Accessory talk 12 16th July 2013 05:51 PM
E-M5 Grip problem David Morison General accessories 2 12th July 2013 11:15 AM
Problem solved… maybe? Wally The lounge 8 3rd June 2012 11:49 AM
E-1 rubber grip problem olympus ghillie Olympus E-1 9 13th December 2011 10:40 AM
Case of GAS solved iMac Olympus E-30 7 16th July 2009 05:56 PM


All times are GMT. The time now is 04:33 PM.


© The Write Technology Ltd, 2007-2017, All rights reservedAd Management plugin by RedTyger