Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Cameras, lenses and system accessories > Camera conference > Olympus E-620/600

Olympus E-620/600 An Olympus 12.1MP mid-range compact DSLR, the E-620 and the feature-reduiced version, the E-600.

Reply
 
Thread Tools Display Modes
  #1  
Old 8th July 2012
Ian Grego Ian Grego is offline
Full member
 
Join Date: Feb 2008
Location: Belper Derbyshire
Posts: 363
Thanks: 2
Thanked 37 Times in 37 Posts
Likes: 0
Liked 4 Times in 4 Posts
E 600 keeps dying ( any ideas why)?

Good evening all,

As the title says I am having problems with my E600. A couple of weeks ago while I was down in London with work it just died , by this I mean the screen just fades away and nothing will work. At first I just the battery was flat. On returning home and trying fully charged battery still the same. Left it over night then it all seemed ok. But out again yesterday and it started doing it again.

I know its not the battery because they were all charged, it does it wether single battery or with 2 batteries in the grip. Just been playing to see how long it will take it to die , managed 6 shots and now switch it on and touch any button and it dies.

Any advice from all you knowledgable fellows will be very much appreciated.

Keep dry if you can

Ian
Reply With Quote
  #2  
Old 8th July 2012
PeterBirder's Avatar
PeterBirder PeterBirder is offline
Senior Member
 
Join Date: Dec 2009
Location: BRAINTREE ESSEX
Posts: 5,950
Thanks: 1,760
Thanked 1,024 Times in 854 Posts
Likes: 1,922
Liked 797 Times in 466 Posts
Re: E 600 keeps dying ( any ideas why)?

Tordan58 had a problem like this a while back. See his thread http://e-group.uk.net/forum/showthread.php?t=18849

His last post says he got it working again when he accidently opened the card door without switching off the camera. This sounds similar to the procedure I've heard of for doing a complete reset but I can't remember the reference.

Hope this helps.
__________________
Peter

she looked at me and said "It's official. I hate your camera. It's just so amazing and perfect I want one!"

E-M10 MK II, E-M5, E-PL1, E-PM2, mZ 12-50, mZ 14-42mm EZ, mZ 17mm f 1.8, mZ 25mm f1.8, mZ 45mm f1.8, mZ 75-300mm II.
OM1n, OM 50mm f1.8.
Oly Viewer3, Dxo Pro 11. FastStone.
Reply With Quote
  #3  
Old 8th July 2012
IainMacD's Avatar
IainMacD IainMacD is offline
Full member
 
Join Date: Mar 2008
Location: Drumnadrochit
Posts: 3,933
Thanks: 1,226
Thanked 547 Times in 490 Posts
Likes: 1,849
Liked 846 Times in 238 Posts
Re: E 600 keeps dying ( any ideas why)?

A hard reset can be done by switching on with the card door open, then pressing menu and OK together, then press them again for 3 sec. This brings up a confirmation message.
I have done this to my E-620 and found the info here
__________________
Iain

E-M5 II, E-M1, E-M1 II, 7.5, 8-18, 12-40, 25, 40-150, 45, 60, 300

Website
Flickr
Reply With Quote
The Following User Says Thank You to IainMacD For This Useful Post:
PeterBirder (8th July 2012)
  #4  
Old 9th July 2012
Ian Grego Ian Grego is offline
Full member
 
Join Date: Feb 2008
Location: Belper Derbyshire
Posts: 363
Thanks: 2
Thanked 37 Times in 37 Posts
Likes: 0
Liked 4 Times in 4 Posts
Re: E 600 keeps dying ( any ideas why)?

Good evening,

Thanks for the replies.

Just got in from work and the camera seems to behaving itself again.

Tried the hard reset but did not get confirmation message up. All I got was Olympus E600 03 010 01 (or something like that).

Then I saw another comment about battery needs to be out for 24 hours to do this hard reset.

So battery now out and as I am in London for the next 2 days will see what happens on wednesday night.

Many thanks again for the replies. will let you know what develops

Ian
Reply With Quote
  #5  
Old 10th July 2012
Tordan58's Avatar
Tordan58 Tordan58 is offline
Full member
 
Join Date: Mar 2011
Location: Malmö, Sweden
Posts: 3,173
Thanks: 298
Thanked 384 Times in 320 Posts
Likes: 391
Liked 1,305 Times in 346 Posts
Re: E 600 keeps dying ( any ideas why)?

Quote:
Originally Posted by PeterBirder View Post
Tordan58 had a problem like this a while back. See his thread http://e-group.uk.net/forum/showthread.php?t=18849

His last post says he got it working again when he accidently opened the card door without switching off the camera. This sounds similar to the procedure I've heard of for doing a complete reset but I can't remember the reference.

Hope this helps.
Hi,

My E600 looked to work fine for a few days after I accidentally opened the card door, the problem came back after a few days unfortunately.

If I keep on pressing the playback button the camera will eventually display photos. It may work the first time, sometimes I will have to press the button 20 times. It's a matter of being persistent...

The strange thing: as long as the camera has not been switched on more than a few minutes, the display will always show the latest taken photograph for a few seconds (I think I have set the time to three seconds) so there is nothing wrong with the display as such. Furthermore, pressing the shutter button halfway will more often than not often result in settings displayed up on the LCD. However, (usually but not always), as soon as I operate any button (except the shutter release) the display fades quickly and turns black...

There seems to be a correlation with how long time the power has been on, the longer time the lower the likelihood that the camera will function the way it should.

For the sake of completeness I have an E620 showing the same symptoms, far as bad as the E600 though, the camera can be operated for 30 seconds or a minute and then fades.

Some thoughts on this forum was about me operating the cameras in cold weather conditions (-10C), causing the flexfilm (connecting the display to the body) to crack. This cannot be ruled out but what you write indicates your camera failed during summer?

I haven't done the complete reset - did not know about it until now. What I don't understand is how you can operate the complete reset sequence without battery!


/Tord
__________________

My Gallery on 500px
Reply With Quote
  #6  
Old 10th July 2012
Ian Grego Ian Grego is offline
Full member
 
Join Date: Feb 2008
Location: Belper Derbyshire
Posts: 363
Thanks: 2
Thanked 37 Times in 37 Posts
Likes: 0
Liked 4 Times in 4 Posts
Re: E 600 keeps dying ( any ideas why)?

Tord,

Thanks for the reply, much appreciated. As I said in my last post when I get home tomorrow night from sunny(not) London I will try the reset.
My thinking is you take battery out for 24 hours, will be more in my case and then put it back. I like you can not see it doing anything without battery.
So will keep you posted.

Ian
Reply With Quote
  #7  
Old 11th July 2012
Tordan58's Avatar
Tordan58 Tordan58 is offline
Full member
 
Join Date: Mar 2011
Location: Malmö, Sweden
Posts: 3,173
Thanks: 298
Thanked 384 Times in 320 Posts
Likes: 391
Liked 1,305 Times in 346 Posts
Re: E 600 keeps dying ( any ideas why)?

I ran through the complete reset sequence.
  • Power off,
  • Open card door,
  • Power on
  • Press menu and OK button and release ==> Message displayed E620 03 010 01 (or something like that)
  • Press menu and OK for three seconds, Confirmation message "Reset camera settings Y/N" (or something like that).

Did it remedy the issue with the fading display? No.

I could not find any reference to this reset sequence in the user manual (maybe it is described on Olympus Support site?), however I get the feeling that what it does is to revert all settings to factory settings.

/Tord
__________________

My Gallery on 500px
Reply With Quote
  #8  
Old 11th July 2012
Ian Grego Ian Grego is offline
Full member
 
Join Date: Feb 2008
Location: Belper Derbyshire
Posts: 363
Thanks: 2
Thanked 37 Times in 37 Posts
Likes: 0
Liked 4 Times in 4 Posts
Re: E 600 keeps dying ( any ideas why)?

Good evening all,

Thought I would keep you in the loop with this problem with my E600.

Did the hard reset this evening and all seemed ok. So outside just snapping nothing just making the camera work. kept going from taking photo`s to viewing photo`s as this is were the problem started, again seemed ok.
But after about 10 minutes the fading started again.

So I think it will be a call to Luton Cameras tomorrow to see what they suggest.

Will keep the update going

Ian
Reply With Quote
The Following User Says Thank You to Ian Grego For This Useful Post:
PeterBirder (11th July 2012)
  #9  
Old 13th July 2012
Tordan58's Avatar
Tordan58 Tordan58 is offline
Full member
 
Join Date: Mar 2011
Location: Malmö, Sweden
Posts: 3,173
Thanks: 298
Thanked 384 Times in 320 Posts
Likes: 391
Liked 1,305 Times in 346 Posts
Re: E 600 keeps dying ( any ideas why)?

Hi

I contacted Luton Camera Repair a couple of months ago (over the phone and also by email), describing the issue and asking if they would take on having a look at my cameras and quoting a repair cost. They said Yes to start with but I never got a quote, reminded them twice, but they never came back to me. If they respond to your inquiry I would be interested in hearing what the cost would be.

For your reference Olympus in Sweden would charge 2700 SEK (flat rate) for each camera repair.

/Tord
__________________

My Gallery on 500px
Reply With Quote
  #10  
Old 13th July 2012
Ian Grego Ian Grego is offline
Full member
 
Join Date: Feb 2008
Location: Belper Derbyshire
Posts: 363
Thanks: 2
Thanked 37 Times in 37 Posts
Likes: 0
Liked 4 Times in 4 Posts
Re: E 600 keeps dying ( any ideas why)?

Hello Tord,

I have contacted Luton Cameras via there online repair quote form at the moment. Not had a reply yet but only did it yesterday so must give them a little longer. If it comes to I will call in and talk to them next thursday when I am driving back from working in crazy London.
I will keep you upto date with developments.

Ian
Reply With Quote
The Following User Says Thank You to Ian Grego For This Useful Post:
Tordan58 (17th July 2012)
  #11  
Old 16th August 2012
ringneck's Avatar
ringneck ringneck is offline
Full member
 
Join Date: Feb 2009
Location: Birmingham
Posts: 2,859
Thanks: 59
Thanked 135 Times in 131 Posts
Likes: 159
Liked 48 Times in 32 Posts
Re: E 600 keeps dying ( any ideas why)?

Hi Ian...

I do not look at these sections much so have only just spotted this.

I had a similar thing with my 510 and ended up sending it to Luton Cameras where it was (mostly) sorted.
The issue with the Live View only started as I was sending it to them and it got "overlooked".

It all worked fine after until it went swimming about 6 months later.... it's on the windowsill now in bits ...I use it for spares on the 500 and 520.

Original thread.....http://e-group.uk.net/forum/showthread.php?t=10597

Update...... http://e-group.uk.net/forum/showthread.php?t=12810


Keith
__________________
Keith


http://www.flickr.com/photos/68459774@N05

E500,E510 now dead,E520 (now retired),E600 and Grip,14-42,14-45,2x40-150,Sigmas 105 and 135-400 Now Dead..ex 25. Manfrotto 190. Plus lots of OM stuff.
Now also 4 items from the dark side...........
Reply With Quote
  #12  
Old 16th August 2012
Tordan58's Avatar
Tordan58 Tordan58 is offline
Full member
 
Join Date: Mar 2011
Location: Malmö, Sweden
Posts: 3,173
Thanks: 298
Thanked 384 Times in 320 Posts
Likes: 391
Liked 1,305 Times in 346 Posts
Re: E 600 keeps dying ( any ideas why)?

Keith,

I think the issue that Ian and I have experienced is a different one than the one on your E510, but anyway thanks for the interest from your side.

Luton camera did come back with a repair quote, which was in the same magnitude as the Olympus Sweden standard repair fee, 2700 SEK (~260£).

At this price tag I have decided not to have my E620 and E600 cameras fixed. I have also learned the most critical menus by memory so I can operate the E600 advanced settings with black display, and I have given up the desire to check the pictures before I come near a computer.
__________________

My Gallery on 500px
Reply With Quote
  #13  
Old 16th August 2012
ringneck's Avatar
ringneck ringneck is offline
Full member
 
Join Date: Feb 2009
Location: Birmingham
Posts: 2,859
Thanks: 59
Thanked 135 Times in 131 Posts
Likes: 159
Liked 48 Times in 32 Posts
Re: E 600 keeps dying ( any ideas why)?

That's the spirit....it didn't stop us taking pics in the film days.

Keith
__________________
Keith


http://www.flickr.com/photos/68459774@N05

E500,E510 now dead,E520 (now retired),E600 and Grip,14-42,14-45,2x40-150,Sigmas 105 and 135-400 Now Dead..ex 25. Manfrotto 190. Plus lots of OM stuff.
Now also 4 items from the dark side...........
Reply With Quote
  #14  
Old 17th August 2012
Ulfric M Douglas Ulfric M Douglas is offline
Full member
 
Join Date: Mar 2010
Location: Northumberland
Posts: 2,894
Thanks: 262
Thanked 234 Times in 215 Posts
Likes: 128
Liked 172 Times in 119 Posts
Re: E 600 keeps dying

Quote:
Originally Posted by Tordan58 View Post
... I have also learned the most critical menus by memory so I can operate the E600 advanced settings with black display, ...
Good discipline!
I'm sure a cheap used one will come by soon too.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wild flower ID. Any ideas? timmypreston Foto Fair 8 16th June 2012 06:33 PM
Location ideas sapper The lounge 9 23rd April 2012 09:49 AM
Living and Dying shirley Looking for improvement 5 26th January 2009 12:45 AM
Any ideas in Northumberland. shirley The lounge 7 14th July 2008 03:18 PM
Any ideas of selling price for E-3 theMusicMan Olympus E-3 1 14th November 2007 08:26 PM


All times are GMT. The time now is 05:45 PM.


© The Write Technology Ltd, 2007-2019, All rights reservedAd Management plugin by RedTyger