Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Cameras, lenses and system accessories > Camera conference > Olympus E-620/600

Olympus E-620/600 An Olympus 12.1MP mid-range compact DSLR, the E-620 and the feature-reduiced version, the E-600.

Reply
 
Thread Tools Display Modes
  #1  
Old 27th June 2015
CarlosGR CarlosGR is offline
Junior Member
 
Join Date: Jun 2015
Location: Bahia Blanca - Argentina
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Likes: 0
Liked 0 Times in 0 Posts
Help! Screen on E-620 is vanished.

Hi everybody, I have an Olympus E-620 since October 2011. One week ago the screen is blank and the data from viewfinder as well. I can watch through the viewfinder, but the data below it is not showed. Therefore I can not watch the settings any more
I connected the camera to a TV (using the video cable) and the camera works perfect. I can watch everything, settings, menu, display options, LiewView, recorded pictures are played back, autofocus, etc. The camera is seemingly functioning perfectly apart from a blank screen.
The back light works as before. The screen is illuminated but illuminated all in black.
I turned the camera off and attached a different lens, but the problem remains.
I made a reset and a factory reset, changed the battery, the cards as well, but nothing happens.
Im disappointed, because always I have used it with care and I never rotate the screen.
Anyone know how this may be fixed?
Im sorry because my English is bad. Thanks in advance for your answers.
Reply With Quote
  #2  
Old 27th June 2015
Graham_of_Rainham's Avatar
Graham_of_Rainham Graham_of_Rainham is offline
Administrator
 
Join Date: Nov 2007
Location: Rainham
Posts: 8,050
Thanks: 635
Thanked 931 Times in 720 Posts
Likes: 2,241
Liked 1,568 Times in 900 Posts
Re: Help! Screen on E-620 is vanished.

Unfortunately this has been reported before, and while not a common fault, is one that requires a return to Olympus for repair.

Often there is a fixed fee for this repair of about $150 to $200. I may be more economic to get a new body from eBay.

It's far from ideal, but you could leave in in "AUTO" and use it like a "Point & Shoot" camera.
__________________
Graham

We often repeat the mistakes we most enjoy...
Reply With Quote
  #3  
Old 27th June 2015
CarlosGR CarlosGR is offline
Junior Member
 
Join Date: Jun 2015
Location: Bahia Blanca - Argentina
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Likes: 0
Liked 0 Times in 0 Posts
Re: Help! Screen on E-620 is vanished.

Thank you Graham for your prompt response!
Yes, I thought the same, to leave in AUTO and use it like a cell, more or less.
In Argentina is very difficult to get a good technical service and if it exists, the fixed fee would be more expensive that a new body price.
Thanks again!!
Reply With Quote
  #4  
Old 27th June 2015
PeterBirder's Avatar
PeterBirder PeterBirder is offline
Senior Member
 
Join Date: Dec 2009
Location: BRAINTREE ESSEX
Posts: 5,950
Thanks: 1,760
Thanked 1,024 Times in 854 Posts
Likes: 1,922
Liked 797 Times in 466 Posts
Re: Help! Screen on E-620 is vanished.

Hi Carlos.

I suspect you and Graham may be correct and the cheapest solution may be to buy a second hand (pre-owned) camera from eBay etc.

However, this link for Olympus Service in Argentina may be worth checking.
http://www.olympusamericalatina.com/...s.asp?region=1

At least you are in the same province.

Regards.
__________________
Peter

she looked at me and said "It's official. I hate your camera. It's just so amazing and perfect I want one!"

E-M10 MK II, E-M5, E-PL1, E-PM2, mZ 12-50, mZ 14-42mm EZ, mZ 17mm f 1.8, mZ 25mm f1.8, mZ 45mm f1.8, mZ 75-300mm II.
OM1n, OM 50mm f1.8.
Oly Viewer3, Dxo Pro 11. FastStone.
Reply With Quote
  #5  
Old 30th June 2015
CarlosGR CarlosGR is offline
Junior Member
 
Join Date: Jun 2015
Location: Bahia Blanca - Argentina
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Likes: 0
Liked 0 Times in 0 Posts
Re: Help! Screen on E-620 is vanished.

Hi Peter,
Today I contacted the Olympus service by email. They said me it is impossible that I can check the camera functions watching the settings using the video cable... But that is happening. I don't know. They suggested me to send the camera in order to take a look.
Just a comment: The LCD display and data from viewfinder vanished when I was using a lens Tamron 28-200mm f/3.8-5.6 with a mount adapter (because is a lens with Nikon mount). I used this lens a lot of time without any problem changing f stop manually.
Thank you Peter for your reference!
Reply With Quote
The Following User Says Thank You to CarlosGR For This Useful Post:
PeterBirder (30th June 2015)
  #6  
Old 30th June 2015
Graham_of_Rainham's Avatar
Graham_of_Rainham Graham_of_Rainham is offline
Administrator
 
Join Date: Nov 2007
Location: Rainham
Posts: 8,050
Thanks: 635
Thanked 931 Times in 720 Posts
Likes: 2,241
Liked 1,568 Times in 900 Posts
Re: Help! Screen on E-620 is vanished.

I use a 7" LCD TV to view the Live View and it has all the SCP & settings showing on the TV Screen.

SO You are right and they are wrong.
__________________
Graham

We often repeat the mistakes we most enjoy...
Reply With Quote
  #7  
Old 30th June 2015
Homer Simpson Homer Simpson is offline
Full member
 
Join Date: Feb 2010
Location: Loughborough
Posts: 544
Thanks: 81
Thanked 35 Times in 32 Posts
Likes: 26
Liked 30 Times in 22 Posts
Re: Help! Screen on E-620 is vanished.

Quote:
Originally Posted by Graham_of_Rainham View Post
I use a 7" LCD TV to view the Live View and it has all the SCP & settings showing on the TV Screen.

SO You are right and they are wrong.

Sorry to hijack the thread but do you know if you can do the same with a e520
__________________
E1, E520, ED14-42, ED 40-150, 70-300, Various legacy including 50mm f2 macro.
Reply With Quote
  #8  
Old 30th June 2015
Graham_of_Rainham's Avatar
Graham_of_Rainham Graham_of_Rainham is offline
Administrator
 
Join Date: Nov 2007
Location: Rainham
Posts: 8,050
Thanks: 635
Thanked 931 Times in 720 Posts
Likes: 2,241
Liked 1,568 Times in 900 Posts
Re: Help! Screen on E-620 is vanished.

Quote:
Originally Posted by Homer Simpson View Post
Sorry to hijack the thread but do you know if you can do the same with a e520
We have been able to connect a TV to our cameras since the E-3 introduced Live View AV stream

http://www.olympus.co.jp/en/support/...man_e520_e.pdf
__________________
Graham

We often repeat the mistakes we most enjoy...
Reply With Quote
  #9  
Old 2nd July 2015
Tordan58's Avatar
Tordan58 Tordan58 is offline
Full member
 
Join Date: Mar 2011
Location: Malm, Sweden
Posts: 3,176
Thanks: 298
Thanked 386 Times in 322 Posts
Likes: 391
Liked 1,305 Times in 346 Posts
Re: Help! Screen on E-620 is vanished.

Quote:
Originally Posted by CarlosGR View Post
Hi everybody, I have an Olympus E-620 since October 2011. One week ago the screen is blank and the data from viewfinder as well

...


Im sorry because my English is bad. Thanks in advance for your answers.
Hi Carlos,

Your English is good.

This has happened to me as well, twice actually.

First time was on E620. After power on screen showns menus for a few seconds, sometimes longer (> 1 minute), but after a while it will fade and turn black. So the camera is semi-usable if you are fast in operating the menus.

Second time it happened was E600 (mechanically identical to the E620). In this case it's really bad, the display goes black almost immediately after ower on. Unless you know the menus by heart or look up a reference, the camera is not usable except Auto.

I got repair quote from Olympus Sweden exceeding what the cameras are worth.

Shame since they are (were) nice cameras.
__________________

My Gallery on 500px
Reply With Quote
  #10  
Old 4th July 2015
CarlosGR CarlosGR is offline
Junior Member
 
Join Date: Jun 2015
Location: Bahia Blanca - Argentina
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Likes: 0
Liked 0 Times in 0 Posts
Re: Help! Screen on E-620 is vanished.

Hi Tord,
Thank you for share your experience. I will get repair quote from technical service in Argentina in order to know if it is similar or exceeds new body price...
I'm very dissapointed because always I have taken care of the camera and it has less than 8000 shootings.
I took a look of your pictures. Very nice, beautiful pictures. Congratulations!
Reply With Quote
Reply

Tags
display, e-620, lcd, screen

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen protector Shaw Olympus OM-D E-M1 6 8th November 2013 09:13 PM
Screen Goes off? timmypreston Olympus E-400 3 17th January 2012 10:03 PM
E3 Screen has came apart Garrie Olympus E-3 11 10th October 2010 07:06 PM
E3 screen flicker monoboard Olympus E-3 3 23rd May 2010 07:25 AM
Standard eyepiece for E-3... mine's just vanished!!! theMusicMan Olympus E-3 5 13th April 2008 09:42 AM


All times are GMT. The time now is 03:47 PM.


The Write Technology Ltd, 2007-2019, All rights reservedAd Management plugin by RedTyger