Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Motion pictures - video and animation > Movie mode - technical discussions

Movie mode - technical discussions Still imaging is complicated enough but for most of us video and movie making is a whole new world to get to grips with - here is the place to request help and advice and to post it too.

Reply
 
Thread Tools Display Modes
  #1  
Old 18th March 2017
Maria Maria is offline
Full member
 
Join Date: Jan 2017
Location: Stockport
Posts: 39
Thanks: 1
Thanked 13 Times in 7 Posts
Likes: 0
Liked 18 Times in 9 Posts
basic video help needed on EM1 Mk II

Let me start by saying I haven't much of a clue when it comes to video. I am almost entirely a stills photographer but very occasionally want to take a few short video clips of my grandsons. Up until December I had a Panasonic GH4 and when I wanted to take video, I switched the camera to iAuto and pressed record to shoot my clip. The files were full HD and in .MTS format, which played back nicely on my Panasonic TV.

In December I bought an EM1 MkII and last weekend I tried taking a few video clips for the first time. They play OK on my PC (though looked a bit over-exposed) but if I try to stream them to my TV, they are very jerky and don't play correctly - it appears that the TV doesn't support .MOV format. The only other format that appears to be available on the camera is for the 1280 HD, which saves as an .AVI. Though that will play, it isn't great resolution. I'm not particularly bothered about 4K but would like the clips to be full HD.

Any advice on how to set things up, for ease of (very occasional) use to get the best results, without having to delve too far into the intricacies of video? Is there a free/easy/safe converter that I can use to convert .MOV files to .MTS?

Any help and advice would be greatly appreciated!

Thanks in advance.
Reply With Quote
  #2  
Old 18th March 2017
Graham_of_Rainham's Avatar
Graham_of_Rainham Graham_of_Rainham is offline
Administrator
 
Join Date: Nov 2007
Location: Rainham
Posts: 7,322
Thanks: 582
Thanked 867 Times in 662 Posts
Likes: 1,955
Liked 1,253 Times in 739 Posts
Re: basic video help needed on EM1 Mk II

Page 102 of the manual tells you how to select what you want:

Setting the record mode
You can set combinations of movie image size and bit rate. The settings can be
selected from options of movie record mode (P. 56).
1 Select [n Specification Settings] in n Video Menu and press the Q button.
2 Select [nK] and press I.
3 Use FG to select the item and press I.
Use FG to select the setting and press the Q button.
Image size
Sets the image size to [C4K] (Custom only), [4K], [FHD] (Full HD), or [HD].

I suggest full HD (1920 x 1080). Use your stills skills to record the video, keeping the camera as still as possible and if panning & zooming do it as slow as possible. Cut from one sequence of action to the next. Keep the "shots" short and join them together later.
__________________
Graham

We often repeat the mistakes we most enjoy...
Reply With Quote
  #3  
Old 18th March 2017
Maria Maria is offline
Full member
 
Join Date: Jan 2017
Location: Stockport
Posts: 39
Thanks: 1
Thanked 13 Times in 7 Posts
Likes: 0
Liked 18 Times in 9 Posts
Re: basic video help needed on EM1 Mk II

Thanks Graham, I found the settings but anything other than HD (1280) saves as a .MOV file - the main issue I have is that this format doesn't work on my TV.
Reply With Quote
  #4  
Old 27th April 2017
josephlck josephlck is offline
Full member
 
Join Date: Jun 2012
Location: London
Posts: 60
Thanks: 2
Thanked 5 Times in 5 Posts
Likes: 0
Liked 1 Time in 1 Post
Re: basic video help needed on EM1 Mk II

I'm afraid i don't have an em1mk2 but i know a little about computers.
You are streaming from your computer to your TV right? It could be one of two things. Either the TV does not support .mov like you suggest and the computer is transcoding the file on the fly or the file has a bitrate which exceeds your network capacity.

If the former, you can try to transcode the file beforehand. There are several free programs. Try handbreak. Depending on your computer, you could also try different playback mechines. Some media centric devices have dedicated transcoding chips.

If it's a bandwidth problem, a clue would be the file sizes are much larger than you'd expect. Try a wired connection with Ethernet cables.

I think what's going on is the .mov wrapper is uncompressed footage while .avi is. I'm by no means an expert though.
Reply With Quote
  #5  
Old 27th April 2017
Maria Maria is offline
Full member
 
Join Date: Jan 2017
Location: Stockport
Posts: 39
Thanks: 1
Thanked 13 Times in 7 Posts
Likes: 0
Liked 18 Times in 9 Posts
Re: basic video help needed on EM1 Mk II

Hi Joseph - thanks for your response

After a bit of experimenting, I have no solutions - but this is what I've found so far. I created some simple clips (Full HD 50P), just panning slowly round my garden. If I play the video clips on the PC (Windows 10) in "Movies & TV" or "Windows Media Player" they play but rather jerkily, which is then even worse if cast to the TV. I eventually tried playing them on Olympus OV3 and found they play OK (well, as OK as my video capabilities). They also play OK in VLC, which someone suggested downloading. I found an option in OV3 (which I'm not at all familiar with) to export as MP4 - but this appear to create corrupted MP4s! I also found out I could connect the camera directly to the TV via HDMI and they played absolutely fine - but this isn't ideal for stored clips.

What I don't understand is why the clips play OK with OV3 or VLC but not using either windows 10 player - same clips, same PC, same hardware. The video settings are the same as I used with the GH4 (Full HD 50P) - but that allowed me to choose the recording format, which was set to AVCHD and not MOV - the files had a .MTS extension. Unless I'm missing something (which is possible) it doesn't seem possible to change the recording format on the EM1 MkII. I've tried changing the bit rate but it doesn't seem to make any difference.

With the GH4 I was able to plug my SD card into a Panasonic PVR, copy the clips to it's hard drive and play on the TV - unfortunately that does not recognise the .MOV files from the Olympus. I can also successfully cast/stream the GH4 videos from PC to TV with no issues - this would be the best solution if I can find a way of doing it successfully, as the (desktop) PC is upstairs (in a messy office) and the clips will be stored on it's hard drive, once the SD card is reused.

It was also suggested that I download some updated video Codecs (K-Lite Codec Pack) which I did - but it made no difference. This gave me another player "Media Player Classic" which also plays the clips OK - but none of the players that seem to play the clips OK give me the option of casting to the TV - or at least, I can't figure out how to.

Sorry if all this sounds a bit complicated - I've become totally confused by it all! If anyone has any suggestions on what could be going wrong, I'd be very grateful!
Reply With Quote
  #6  
Old 28th April 2017
AMc AMc is offline
Full member
 
Join Date: Oct 2015
Location: East Anglia
Posts: 978
Thanks: 78
Thanked 110 Times in 96 Posts
Likes: 470
Liked 200 Times in 115 Posts
Re: basic video help needed on EM1 Mk II

I'm not a video expert and don't own an E-M1 Mki but I do know a little.

The .mov .avi extensions on video files are confusing as they can contain video compressed with different codecs (compression/decompression algorithms).
Some codecs are supported in hardware on graphics cards and TVs etc. That means a comparatively low spec machine can play back a high quality video stream because it has a dedicated chip.

The camera is recording with a codec that OV3 and VLC support but Windows 10 Player and your TV don't understand or can't uncompress using hardware. That cause them to either not play or play back badly because the system is using the CPU to decode the video not the dedicated chip and it's not fast enough. It's also possible that the network is too slow to get the video file to the TV as it plays.
The bitrate and framerate aren't necessarily the problem, it's the codec and possibly file extension for the TV.

You're going to need transcode your video into something that will cast/stream from your PC.

Handbrake is a free and effective way to transcode video. You will either need to experiment to find the settings and format that work for your situation or find out what files your casting program and TV support.
https://handbrake.fr/

If you right click on one of your working video files and look at "properties>details" it may give you some clues as to what you need.
Reply With Quote
  #7  
Old 10th February 2018
blu-by-u blu-by-u is offline
Full member
 
Join Date: Mar 2008
Location: Selangor, Malaysia
Posts: 1,282
Thanks: 140
Thanked 63 Times in 53 Posts
Likes: 143
Liked 434 Times in 231 Posts
Re: basic video help needed on EM1 Mk II

HELP!

I shot the movie is Portrait, any software to rotate it to landscape?
__________________
* Henry
* Location: Subang Jaya, Selangor
* Malaysia


All my garbage so far.
Reply With Quote
  #8  
Old 10th February 2018
MJ224's Avatar
MJ224 MJ224 is online now
Full member
 
Join Date: May 2016
Location: Carmarthenshire
Posts: 7,547
Thanks: 458
Thanked 368 Times in 347 Posts
Likes: 3,472
Liked 1,635 Times in 844 Posts
Re: basic video help needed on EM1 Mk II

I use the Em1 ii for occaisional video, mainly holiday and short videos.

I process the files using Sony (Magix) Movie Studio 14. Not free but I have grown up with it! Once the clips are sorted, ie cut and joined up, and titled, I "make movie" in the Windows Media Player format. Several to choose from.

This format plays well on TV, YouTube etc.

So I suggest the answer is to process the video clips in appropriate software.

And you can re-orientate the video Henry

Good Luck...................
__________________
My Sailing Page

My Flickr
Reply With Quote
  #9  
Old 10th February 2018
Wreckdiver's Avatar
Wreckdiver Wreckdiver is offline
Full member
 
Join Date: Nov 2007
Location: From Liverpool, live in Chippenham, Wiltshire.
Posts: 1,637
Thanks: 80
Thanked 72 Times in 67 Posts
Likes: 89
Liked 80 Times in 42 Posts
Re: basic video help needed on EM1 Mk II

Quote:
Originally Posted by blu-by-u View Post
HELP!

I shot the movie is Portrait, any software to rotate it to landscape?
Re-shoot the video.

Edit: Sidetracking a bit and not relating to your video issue blu-by-u. Apple and other Smart phone manufacturers should be hung for creating such an appalling function as "vertical videos". My absolute hate are these damn videos. Sorry, rant over.

Steve
__________________
Old divers never die, they just go down on old wrecks
Take nothing but photographs, leave nothing but bubbles
My website
Reply With Quote
  #10  
Old 14th February 2018
blu-by-u blu-by-u is offline
Full member
 
Join Date: Mar 2008
Location: Selangor, Malaysia
Posts: 1,282
Thanks: 140
Thanked 63 Times in 53 Posts
Likes: 143
Liked 434 Times in 231 Posts
Re: basic video help needed on EM1 Mk II

Quote:
Originally Posted by Wreckdiver View Post
Re-shoot the video.

Edit: Sidetracking a bit and not relating to your video issue blu-by-u. Apple and other Smart phone manufacturers should be hung for creating such an appalling function as "vertical videos". My absolute hate are these damn videos. Sorry, rant over.

Steve
Yeah..go shoot the guy. (ie me) Am still having an issue like the TS. The MOV don't play in many devices.

I have managed to convert using VLC media player to mp4 but I can't seem to get it to upload into flickr.
__________________
* Henry
* Location: Subang Jaya, Selangor
* Malaysia


All my garbage so far.
Reply With Quote
  #11  
Old 18th February 2018
MJ224's Avatar
MJ224 MJ224 is online now
Full member
 
Join Date: May 2016
Location: Carmarthenshire
Posts: 7,547
Thanks: 458
Thanked 368 Times in 347 Posts
Likes: 3,472
Liked 1,635 Times in 844 Posts
Re: basic video help needed on EM1 Mk II

NCH suite is good for converting video formats..............
__________________
My Sailing Page

My Flickr
Reply With Quote
  #12  
Old 20th February 2018
blu-by-u blu-by-u is offline
Full member
 
Join Date: Mar 2008
Location: Selangor, Malaysia
Posts: 1,282
Thanks: 140
Thanked 63 Times in 53 Posts
Likes: 143
Liked 434 Times in 231 Posts
Re: basic video help needed on EM1 Mk II

Got that Movie Maker from the microsoft store. It's FREE. rotated the movie and saved as MP4.
__________________
* Henry
* Location: Subang Jaya, Selangor
* Malaysia


All my garbage so far.
Reply With Quote
The Following User Liked This Post:
MJ224 (20th February 2018)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Basic PC Problem - can you help? pandora The lounge 31 11th March 2016 10:30 AM
First Video made on E-5: music video to accompany recording - please watch! theMusicMan The lounge 25 19th February 2013 11:41 AM
Several basic mistakes? snaarman Looking for improvement 15 10th July 2012 12:35 PM
Basic Kit Squiggle ringneck Foto Fair 1 29th November 2011 10:14 PM
Basic flash bracket benvendetta Flash 3 20th April 2009 12:37 PM


All times are GMT. The time now is 10:57 PM.


The Write Technology Ltd, 2007-2018, All rights reservedAd Management plugin by RedTyger