Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Cameras, lenses and system accessories > Camera conference > Olympus E-300

Olympus E-300 E-300 specific discussion.

Reply
 
Thread Tools Display Modes
  #1  
Old 10th April 2011
pepper
Guest
 
Posts: n/a
E300 and 40-150 Mk2 Lens

Hi does anyone know if these two are compatible please?

I bought a 40-150 lens from here for a friend who has an E300 and it seems to lock the hole camera up and the only way of unlocking it is to take the battery out!

The lens works fine on my Panasonic L1 and my E3, so is there an update needed to get these two to work?
Reply With Quote
  #2  
Old 3rd August 2011
spark
Guest
 
Posts: n/a
Re: E300 and 40-150 Mk2 Lens

I use a 40-150 on my E-300 with no problems at all
Reply With Quote
  #3  
Old 3rd August 2011
pepper
Guest
 
Posts: n/a
Re: E300 and 40-150 Mk2 Lens

It's very strange, thanks for answering me though.

I reckon the software needs updating on the camera, trouble is she lives a 100 miles away and we don't see each other that often.
Reply With Quote
  #4  
Old 4th August 2011
Ulfric M Douglas Ulfric M Douglas is offline
Full member
 
Join Date: Mar 2010
Location: Northumberland
Posts: 2,794
Thanks: 252
Thanked 227 Times in 208 Posts
Likes: 108
Liked 147 Times in 103 Posts
Re: E300 and 40-150 Mk2 Lens

They should work just fine.

Every time I have a problem with one of these lenses I have a close look at the camera-body contact pins.
Mine can get a bit stuck sometimes ... and your e-300 would be older than this e-410 so there might be your problem. Clean 'em and make sure they pop down and up freeley.

Also, on other systems 'lock-up' is usually a dodgy batttery fault. Kind of.
Reply With Quote
  #5  
Old 4th August 2011
DJMC's Avatar
DJMC DJMC is offline
Full member
 
Join Date: Apr 2011
Location: Lutterworth, Leics
Posts: 1,236
Thanks: 2
Thanked 46 Times in 35 Posts
Likes: 0
Liked 0 Times in 0 Posts
Re: E300 and 40-150 Mk2 Lens

Quote:
Originally Posted by pepper View Post
It's very strange, thanks for answering me though.

I reckon the software needs updating on the camera, trouble is she lives a 100 miles away and we don't see each other that often.
Can't you talk her through the firmware updating procedure over the phone, just to knock that on the head?

Or, firstly, talk her through how to find what firmware version the camera and lens are on?

Does she have another lens that DOES work on the body? If yes, it's either the 40-150 lens that needs: contacts cleaning; firmware update; repair; testing again on another body before repair, OR the body needs a firmware update to work with the 40-150.

No blame on the seller here, as you've tested it on other bodies, BUT it may have been accidentally damaged since perhaps?

Good luck.

__________________
David
--------------------------
-XZ-1 * VF-2+EP-9
--------------------------
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Olympus E420 - 11-22mm Lens + 135- 400 lens + More For sale timphoto1 For sale or wanted small ads 11 10th May 2012 02:00 AM
E300 and bits for Sale Robusto For sale or wanted small ads 16 4th December 2011 11:52 PM
E300 Upgrading Robusto Camera conference 1 23rd March 2011 06:14 PM
Tamron Adaptall 2 Lens to Olympus OM 4/3 Lens Mount Adapter? BigBCC Accessory talk 7 13th July 2010 08:57 PM
E300 focusing screen Dicky Lens focus 6 13th November 2008 09:55 AM


All times are GMT. The time now is 08:44 AM.


The Write Technology Ltd, 2007-2018, All rights reservedAd Management plugin by RedTyger