Olympus UK E-System User Group
Olympus UK E-System User Group

Join our unique resource for Olympus Four Thirds E-System DSLR and Pen and OM-D Micro Four Thirds photographers. Show your images via our free e-group photo gallery. Please read the e-group.uk.net forum terms and conditions before posting for the first time. Above all, welcome!


Go Back   Olympus UK E-System User Group > Cameras, lenses and system accessories > Camera conference > Micro Four Thirds > Olympus OM-D E-M5

Olympus OM-D E-M5 The first Micro Four Thirds camera from Olympus with an integrated Electronic Viewfinder

Reply
 
Thread Tools Display Modes
  #1  
Old 4th March 2014
Zuiko's Avatar
Zuiko Zuiko is online now
Administrator
 
Join Date: Nov 2007
Location: Dunmow, Essex
Posts: 21,625
Thanks: 1,957
Thanked 3,070 Times in 2,386 Posts
Likes: 3,215
Liked 4,286 Times in 2,017 Posts
Firmware Update Problem

I wasn't going to bother updating the firmware on my E-M5 because the Olympus method seems fraught with potential problems, but with my recent purchase of a 45mm f1.8 the option of ISO 100 really would be useful.

However, as expected, it's not going smoothly for me!

I've updated Viewer 2 to the latest version, switched on my camera (with a fresh battery), connected it to my pc with a USB lead and clicked on Camera Update in Viewer. A message then displays that no camera is detected. Any ideas what I'm doing wrong?
__________________
John

"A hundredth of a second here, a hundredth of a second there even if you put them end to end, they still only add up to one, two, perhaps three seconds, snatched from eternity." ~ Robert Doisneau
Reply With Quote
  #2  
Old 4th March 2014
Graham_of_Rainham's Avatar
Graham_of_Rainham Graham_of_Rainham is offline
Administrator
 
Join Date: Nov 2007
Location: Rainham
Posts: 7,903
Thanks: 629
Thanked 918 Times in 710 Posts
Likes: 2,187
Liked 1,522 Times in 865 Posts
Re: Firmware Update Problem

I had a similar problem. Some software needs to be started "fresh" having been updated.

Basically try the old "Turn it off and on again" aka Re-Boot...

Good luck

__________________
Graham

We often repeat the mistakes we most enjoy...
Reply With Quote
  #3  
Old 4th March 2014
Zuiko's Avatar
Zuiko Zuiko is online now
Administrator
 
Join Date: Nov 2007
Location: Dunmow, Essex
Posts: 21,625
Thanks: 1,957
Thanked 3,070 Times in 2,386 Posts
Likes: 3,215
Liked 4,286 Times in 2,017 Posts
Re: Firmware Update Problem

Quote:
Originally Posted by Graham_of_Rainham View Post
I had a similar problem. Some software needs to be started "fresh" having been updated.

Basically try the old "Turn it off and on again" aka Re-Boot...

Good luck

Thanks Graham, that was quick! Forgot to mention that I did try that.
__________________
John

"A hundredth of a second here, a hundredth of a second there even if you put them end to end, they still only add up to one, two, perhaps three seconds, snatched from eternity." ~ Robert Doisneau
Reply With Quote
  #4  
Old 4th March 2014
Graham_of_Rainham's Avatar
Graham_of_Rainham Graham_of_Rainham is offline
Administrator
 
Join Date: Nov 2007
Location: Rainham
Posts: 7,903
Thanks: 629
Thanked 918 Times in 710 Posts
Likes: 2,187
Liked 1,522 Times in 865 Posts
Re: Firmware Update Problem

In that case connect the camera without Viewer 3 running and establish a connection to the camera via Windows Explorer.

Then start Viewer 3 and see if that works.
__________________
Graham

We often repeat the mistakes we most enjoy...
Reply With Quote
  #5  
Old 4th March 2014
Olybirder Olybirder is online now
Senior Member
 
Join Date: Apr 2011
Location: Norfolk
Posts: 6,279
Thanks: 2,323
Thanked 946 Times in 754 Posts
Likes: 1,746
Liked 2,629 Times in 809 Posts
Re: Firmware Update Problem

Do you need to set the USB mode on the camera to 'Storage'?

Ron
Reply With Quote
  #6  
Old 4th March 2014
Graham_of_Rainham's Avatar
Graham_of_Rainham Graham_of_Rainham is offline
Administrator
 
Join Date: Nov 2007
Location: Rainham
Posts: 7,903
Thanks: 629
Thanked 918 Times in 710 Posts
Likes: 2,187
Liked 1,522 Times in 865 Posts
Re: Firmware Update Problem

I sometimes used a standalone firmware updater available

HERE

Again, good luck

__________________
Graham

We often repeat the mistakes we most enjoy...
Reply With Quote
  #7  
Old 4th March 2014
OlyPaul's Avatar
OlyPaul OlyPaul is offline
Senior Member
 
Join Date: Nov 2007
Location: West Midlands
Posts: 5,470
Thanks: 140
Thanked 715 Times in 577 Posts
Likes: 177
Liked 875 Times in 355 Posts
Re: Firmware Update Problem

Quote:
Originally Posted by Graham_of_Rainham View Post
I sometimes used a standalone firmware updater available

HERE

Again, good luck

John that's the one that I used to update my E-M5 and I had no problems, always did have problems doing it with viewer.
__________________
Regards Paul.
One day I hope to be the person my dogs think I am.

https://www.flickr.com/photos/paul_silk/
Reply With Quote
  #8  
Old 4th March 2014
Zuiko's Avatar
Zuiko Zuiko is online now
Administrator
 
Join Date: Nov 2007
Location: Dunmow, Essex
Posts: 21,625
Thanks: 1,957
Thanked 3,070 Times in 2,386 Posts
Likes: 3,215
Liked 4,286 Times in 2,017 Posts
Re: Firmware Update Problem

Thanks guys, I think what i was doing wrong was not restarting the computer, only closing and re-opening Viewer. I've now got the "Low" ISO setting and the Firmware displays as version 2. I can't see any difference with the small AF box but hey, thats not an issue anyway. The main thing is that the camera is still working. Looks like my 12-50mm needs updating too, but I think I might do that on my old E-P2.
__________________
John

"A hundredth of a second here, a hundredth of a second there even if you put them end to end, they still only add up to one, two, perhaps three seconds, snatched from eternity." ~ Robert Doisneau
Reply With Quote
  #9  
Old 4th March 2014
pvasc pvasc is offline
Full member
 
Join Date: Apr 2012
Location: UK
Posts: 667
Thanks: 90
Thanked 139 Times in 112 Posts
Likes: 58
Liked 98 Times in 58 Posts
Re: Firmware Update Problem

Quote:
Originally Posted by Zuiko View Post
Thanks guys, I think what i was doing wrong was not restarting the computer, only closing and re-opening Viewer. I've now got the "Low" ISO setting and the Firmware displays as version 2. I can't see any difference with the small AF box but hey, thats not an issue anyway. The main thing is that the camera is still working. Looks like my 12-50mm needs updating too, but I think I might do that on my old E-P2.
Did you bring up focus grid in SCP and press info, and press the up and, or down buttons?
Reply With Quote
  #10  
Old 4th March 2014
Zuiko's Avatar
Zuiko Zuiko is online now
Administrator
 
Join Date: Nov 2007
Location: Dunmow, Essex
Posts: 21,625
Thanks: 1,957
Thanked 3,070 Times in 2,386 Posts
Likes: 3,215
Liked 4,286 Times in 2,017 Posts
Re: Firmware Update Problem

Quote:
Originally Posted by pvasc View Post
Did you bring up focus grid in SCP and press info, and press the up and, or down buttons?
Ah, so that's how it's done, rather than via the magnify function. Thank you for that.
__________________
John

"A hundredth of a second here, a hundredth of a second there even if you put them end to end, they still only add up to one, two, perhaps three seconds, snatched from eternity." ~ Robert Doisneau
Reply With Quote
  #11  
Old 4th March 2014
PeterBirder's Avatar
PeterBirder PeterBirder is offline
Senior Member
 
Join Date: Dec 2009
Location: BRAINTREE ESSEX
Posts: 5,950
Thanks: 1,760
Thanked 1,024 Times in 854 Posts
Likes: 1,922
Liked 797 Times in 466 Posts
Re: Firmware Update Problem

Quote:
Originally Posted by Zuiko View Post
Ah, so that's how it's done, rather than via the magnify function. Thank you for that.
I've assigned the "Focus box Home" function to the Fn2 button so I just have to press Fn2 to toggle between the standard and small focus boxes. I'll show you on Friday.

Regards.
__________________
Peter

she looked at me and said "It's official. I hate your camera. It's just so amazing and perfect I want one!"

E-M10 MK II, E-M5, E-PL1, E-PM2, mZ 12-50, mZ 14-42mm EZ, mZ 17mm f 1.8, mZ 25mm f1.8, mZ 45mm f1.8, mZ 75-300mm II.
OM1n, OM 50mm f1.8.
Oly Viewer3, Dxo Pro 11. FastStone.
Reply With Quote
The Following 3 Users Say Thank You to PeterBirder For This Useful Post:
OM USer (4th March 2014), Wee man (4th March 2014), Zuiko (4th March 2014)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Firmware update help! byegad Olympus Pen E-P3 5 25th October 2013 12:00 PM
Sensor cleaning problem after firmware update ? Taz Standard zoom and mid range 7 2nd March 2012 12:38 AM
firmware update problem Xpres Olympus Pen E-P2 15 24th February 2011 09:57 AM
How to ... update your firmware Jonesgj Software 5 20th March 2009 06:24 PM
Update to E3 firmware V1.2 Bo_Nydahl Olympus E-3 14 21st June 2008 02:04 PM


All times are GMT. The time now is 06:26 PM.


The Write Technology Ltd, 2007-2018, All rights reservedAd Management plugin by RedTyger