View Single Post
  #15  
Old 18th November 2013
Angus Angus is offline
Full member
 
Join Date: Nov 2013
Location: Surrey, UK
Posts: 80
Thanks: 0
Thanked 13 Times in 7 Posts
Likes: 0
Liked 11 Times in 7 Posts
Re: E-M1 mystery noise (and battery life) issue

Quote:
Originally Posted by ayewing View Post
Hello Angus,
welcome to the forum.
I would guess from your comments that you are blessed with acute hearing. Being hard of hearing I cannot help you regarding the noises as I never hear them.

However as regards the battery, I have noticed that the battery in the E-M1 did not seem to last very long between charges during my first week of use but now that it has had a few charging cycles it is doing much better. I think this is recognised battery behaviour.

Also you mentioned that you are new to Olympus so I suspect you spent the first few days exploring the menus and trying out various settings and checking the resulting images more frequently than normal, I certainly did, so this may have increased the drain on the battery. That said I do have the impression that battery life of the E-M1 is not quite as good as the E-M5.
Good points Archie especially the one about all the playing with the sessings I inevitably did do in the first days which obviously would drainn the battery faster than average. And I have also heard from other sources the idea that battries do improve over the first few charges. I'm not unduly worried by this yet (though I can tell already I'll need to buy an additional battery). But it's the noise I find more troubling.
Reply With Quote