PDA

View Full Version : My trusty E3 is back from repair


Kiwi Paul
16th March 2010, 09:51 PM
and they have fixed the broken viewfinder display but not straightened the viewfinder tilt and "adjusted" the diopter so now even wound completely anticlockwise I still can't quite get a sharp focus with my left eye, I can with my right eye but only just, it was fine before it "got fixed".

So now I have to arrange to send it back, dither about with couriers etc etc, I'm not a happy camper, I've been over 3 weeks without it.

Wonder if they'll loan me one?

Paul

DekHog
16th March 2010, 10:38 PM
Not good, is it? I always wonder why it takes so long... are they really that busy they always have a three week backlog of work, or does it just sit on shelf for about 18 days before anyone decides it's time to get it done? If they are that busy, they need more staff, and plenty people need jobs!

Kiwi Paul
16th March 2010, 10:41 PM
No it wasn't Oly that were slow the repair was very quick but they send a courier pack for you to send the camera back in, that took about 5 days to arrive, then it took the courier another 3 days to pick the camera up, Oly turned it around in 3 days then 4 days to get it back.
I'll send it RMSD this time and just pay the £7, saves loads of hassle and time.

Paul

DekHog
16th March 2010, 10:45 PM
So sending the courier pack takes longer than the repair? Interesting... :confused:

Kiwi Paul
16th March 2010, 10:48 PM
The courier kept coming when I was out so kept missing him, he eventually came on a Sunday, then DHL were supposed to pick it up on a Tuesday but for whatever reason it didn't get picked up till the Thursday, not Olys fault, but getting the diopter adjustment wrong is their fault

Paul

j.baker
17th March 2010, 07:45 AM
Dont expect special delivery to be quicker than a courier.

I sent my E30 in for a clean and a service on the 11th. It was delivered to the PO-BOX address, and is still there waiting to be collected, according to RM.

Not happy about it.

snaarman
17th March 2010, 08:17 AM
Well its a bad deal to get more faults than you started with. You did at least get a quicker fix than I have. Its a month ago tomorrow that I posted my lens for repair.

I wonder where it is? :(

Pete

Ian
17th March 2010, 11:21 AM
Your repair issues will be on the agenda today (not with Toshi san, but his Oly UK host :))

Ian

Kiwi Paul
17th March 2010, 11:26 AM
Cheers Ian,

I rang the UK repair centre and the woman on the phone said to send it back and they will turn it around ASAP, I'll just send it RMSD that will save all the previous courier hassles and delays.

Paul

Rod Souter
17th March 2010, 08:21 PM
I sent my E-3 for repair, the splitting along the seam of the LCD fault.

Sent by courier on 4th March, picked up at 16:30, delivered to Olympus at 08:20 on 5th March, returned to me 15th March.

There appears to have been some furtling with the diopter adjuster. LCD now looks OK.

Doh, forgot to note all the settings:rolleyes:

Rod

yorky
18th March 2010, 09:51 AM
There certainly seems to a lack of coordination at the U.K. Olympus end. My experiance over the 9-18 lens was frankly pathethic. No one at the end of the phones seems to tell the same tale. The end result was fine but the messing about etc was like something from John Cleese's show

Kiwi Paul
22nd March 2010, 11:51 AM
Now it's lost, Olympus haven't got it, Royal Mail don't know where it is, looks like I may have sent to the wrong address, I sent it to the address on the Oly Website but the woman I spoke to on the phone says the post code was wrong. (should have gone to ....8RU I sent it to .....8QH). So who knows now.

Paul

DekHog
22nd March 2010, 11:54 AM
The postcode on the website was wrong, or you addressed it wrongly? Goes from bad to worse, eh?

j.baker
22nd March 2010, 12:00 PM
Sorry to hear about your problems.

My E30, that I sent for cleaning about a week ago, has just returned.

snaarman
22nd March 2010, 12:05 PM
Now it's lost, Olympus haven't got it, Royal Mail don't know where it is
Paul

Grrrr...

I have given up asking if there is a parcel for me when I get home. I guess I will get my lens when I get it.

OK, I figure the repair centre in Portugal is also probably handling all the broken P+S cameras as well, and I figure £140 wouldn't buy you much of my time at work.. Even so its a drag to have to wait 3 weeks to then be told they don't have the spare parts in stock. What now, they order the parts from Japan? By air I hope.

Pete

Kiwi Paul
22nd March 2010, 12:31 PM
I sent it to the address on the bottom of the repair form and that's also the address is says to send it to on the Website but the woman I spoke to on the phone says that it should have gone to a different postcode (well the last 2 letters are different).

Waiting for RM to get back to me, it's under investigation.

Paul

E-3
22nd March 2010, 12:34 PM
How very annoying :mad: I hope you get it sorted out quickly :)

j.baker
22nd March 2010, 12:35 PM
Did you send it special delivery? Did you add the extra insurance to cover £1000?

Kiwi Paul
22nd March 2010, 01:27 PM
Yep RMSD insurance for £1K

Paul

j.baker
22nd March 2010, 01:45 PM
I hopy you get it sorted out quickly.

If you got the address information, which turned our toi be incorrect, from an Olympus website, then Olympus should try to help you.

Did you have your return address on the package? If so, it may get returned to you, assuming no one signed for it.

Did you look up the package location via the RM website, or did you call them.

My E30 has yet to be delviered to Olympus according to the RM traching website.

Kiwi Paul
22nd March 2010, 01:58 PM
Yes it has my return address on it, I checked on the RM Website and phoned them, on Thursday they said it had been delivered to a PO Box and once Oly picked it up it would show up as been delivered but the guy today said it hadn't been delivered so they will investigate. OLy say that there is no such thing as a PO Box or it shouldn't have gone there.

I'll wait and see what RM say, thats all I can do.

Paul

j.baker
22nd March 2010, 02:03 PM
My E30 was sent to a POBOX. I confirmed the address before sending off to Oly.

I sent my E30 to Keymed House
PO BOX
Stock Road
Southend-on-sea
SS2 5QH

I have just re-checked with the RM tracking website, and they still have not delivered it.

I suggest calling Olympus again, give them the serial number and ask them to make sure that it has not been booked on their systems. I did take 6 days from the expected delviery date for Olympus to book it on their system.

I send the package on the 11th, it was booked in on the 17th (when I called them), and returned today (22nd)

Kiwi Paul
22nd March 2010, 02:14 PM
Hmmm that's the address I sent it to although didn't state PO Box but did state repair centre, I did give her the serial number but she only had a record for the first delivery 2 weeks ago, sounds like it has gone to the right place then, I'll give them a day and ring tomorrow.

Paul

Ian
22nd March 2010, 03:26 PM
Keymed House is the big Olympus UK HQ in Southend - the consumer imaging (cameras and lenses) division moved there from Watford last year. Keymed refers to the very profitable arm of Olympus that produces medical imaging equipment.

Ian

Kiwi Paul
24th March 2010, 02:07 PM
Hooray!!!! It's turned up and been looked at although don't know when it will be ready :-)

Paul

forester
24th March 2010, 02:24 PM
Hooray!!!! It's turned up and been looked at although don't know when it will be ready :-)

Paul

I recon it has been on itís holidayís, pity it did not send you a post card, although you usually get those several days after you get back :D *chr

E-3
25th March 2010, 01:03 PM
Hooray!!!! It's turned up and been looked at although don't know when it will be ready :-)

Paul

Good news, lets hope they get it back to you quickly :)

edmund473
25th March 2010, 02:26 PM
Hooray!!!! It's turned up and been looked at although don't know when it will be ready :-)

Paul

I have been following your sad predicament. I am so glad it has turned up and now it wont be to long before you have it back. regards JohnR.

Kiwi Paul
31st March 2010, 06:23 PM
My E3 is finally back AND this time it's fixed, the view finder is now not tilted, the diopter adjusts perfectly and the camera works as it should, just like a new one :D.

I dunno what they thought was wrong with it as all I asked for was the VF to be straightened and the Diopter adjuster to be fixed which has been done but the repair form says..."Fault: Exposure Reason: Shutter Action: Replaced. Go figure????

Paul

yorky
31st March 2010, 06:35 PM
Glad to hear that it is back and fixed. Just in time for Easter!

Macca
31st March 2010, 07:48 PM
I dunno what they thought was wrong with it as all I asked for was the VF to be straightened and the Diopter adjuster to be fixed which has been done but the repair form says..."Fault: Exposure Reason: Shutter Action: Replaced. Go figure????

Paul

I had the same "fault" on my E3 when I sent it in for something unconnected to exposure. Mine was only repaired though not replaced. It has since been back for another fault and they have taken over 3000 shots trying to see the fault. Maybe I should get it back in for a new shutter before the repair warranty expires ;)
Can't really complain; initially my focus screen was a mess and they didn't charge for cleaning and both the service admin and repair guys have tried hard working on my (very) intermittent fault.

E-3
31st March 2010, 08:04 PM
My E3 is finally back AND this time it's fixed, the view finder is now not tilted, the diopter adjusts perfectly and the camera works as it should, just like a new one :D.

I dunno what they thought was wrong with it as all I asked for was the VF to be straightened and the Diopter adjuster to be fixed which has been done but the repair form says..."Fault: Exposure Reason: Shutter Action: Replaced. Go figure????

Paul

Excellent news, now you can go & take some pictures of your spring snow :)

Kiwi Paul
31st March 2010, 08:04 PM
Well I'm glad to have my E3 back, been playing around with it checking it out and just re familiarising myself with it after using the E1 for the last month. It feels good, the E1 did grow on me but the E3 has much more functionality and I prefer the ergonomics etc.
I'll take it out tomorrow when I walk the dogs even though the forecast is crap, it's an E3 and the lenses are weather proof too lol ;)

Paul