PDA

View Full Version : E-510 USB Problems


Life of Brian
7th January 2010, 11:42 PM
Hi,

I have encountered a problem in the last couple of days and wonder if I am alone or if someone has come across this before.

The other day I was taking some images using my Ownuser Grip (E51R). I then tried to hook up my USB cable to the camera and noticed that I did not get the USB menu on the camera. I then went into Lightroom and tried to import manually and Lightroom could not see the camera.

I took the cable in and out a few times, changed the USB setting to "storage" and tried that with no success then put it back to "Auto". Eventually it just seemed to work. I noticed that while the menu would not come up that when I inadvertently pressed the shutter button the camera fired off shots repeatedly until I pulled the USB cable out?

Since then I have not been able to use my Ownuser Grip or my wired remote (non Olympus). However my USB to computer connection works every time, i.e. camera goes to USB option menu. None of my connectors other than the Ownuser Grip actually seem very snug in the connector making me thing it was a connector problem. However given the USB connector to the laptop is the most loose I cannot help but think it could be a setting in the camera that is not recognising remote triggers which effectively is what the Ownuser Grip is along with my actual wired remote trigger.

Has anyone any knowledge of a setting that would cause this? I have tried it with the trigger setting at remote and normal in the menu's. Both the grip and the trigger have worked perfectly well up until now. Is there a master reset on the camera back to factory settings anywhere?

Thanks in advance for any suggestions and thanks for taking the time to read my post.

Brian.

Meogeo
8th January 2010, 08:46 AM
Just a quick pointer have you tried it on another pc or laptop, just in case it could be a driver problem with your olympus camera on your computer.

Failing that reset the camera.

photo_owl
8th January 2010, 09:35 AM
there is a factory reset in the camera menu.

from your description I get the feeling that the camera is confused (beyond menus) about which mode it is in an what it's connected to - I don't see it as a PC issue, and probably not a cable/connection one either based on everything you say.

how that's happened is another matter!

Life of Brian
8th January 2010, 03:29 PM
Thanks guys, I'll try it on another pc but as I say it hooks up perfectly to the oc every time now but just does not like a remote shutter wired cable release or the Ownuser Battery Grip.

Life of Brian
14th January 2010, 11:23 PM
Just an update guys, both the Cable Release and the Ownuser Battery Grip work on another E-510, so at least I know its a Camera problem.

Brian.

Life of Brian
18th January 2010, 01:40 PM
Update, Olympus suggested resetting camera, using the menu system to do so nothing changed. I did find a link which told you how to do a hard reset by using a sequence of buttons which also made no difference. I got a lot of help from John at Biofos which was great.

So back to Olympus it is, not sure how much it will cost me but I expect a lot.

Thanks again,

Brian.

mike_j
18th January 2010, 03:31 PM
Check the USB connector in the camera carefully. The connector in my e510 broke and gave erratic operation and someone else on the forum reported the same problem.

It's not a trivial repair so I hope that it is not the cause.