PDA

View Full Version : HELP! XD card won't work!


TheStrummer
24th December 2009, 01:41 PM
Hey,

I've just bought myself an XD card for my e620, and despite formatting it and removing my regular card it won't work at all. When I put the camera onto panorama mode it just brings up a warning message saying XD card needed.

Have I done something really wrong here, or is it a dud card?

Clair

Graham_of_Rainham
24th December 2009, 01:52 PM
Having only just had a typh "H" XD Card fail, I know how you feel.

If it can be detected by a computer in a card reader or by the computer through the camera, then there is hope.

Not all XD cards have the panoramic function. I think it's only Genuine Olympus and some Fuji ones that have it.

Sorry this is not a lot of help.

Have a great Christmas

*chr

TheStrummer
24th December 2009, 02:26 PM
No worries thanks for your reply! It's a genuine Olympus one...hmm...oh well!

Have a great Christmas also!

Clair

StephenL
24th December 2009, 03:29 PM
Have you carried out the procedures in the manual p122 - error codes when using xD cards?

Ken Lister
24th December 2009, 08:01 PM
Hey,

I've just bought myself an XD card for my e620, and despite formatting it and removing my regular card it won't work at all. When I put the camera onto panorama mode it just brings up a warning message saying XD card needed.

Have I done something really wrong here, or is it a dud card?

Clair

My E510 will only work in panorama mode with a 1gb Olympus 'H' XD card. it doesn't like 'M' or Fuji ones. Having said that it is just as easy to shoot your panorama on the CF card and stitch the frames together on your photo software. XD cards are so slow and unreliable, anyway, that they are really only much use as an emergency backup.