PDA

View Full Version : Battery - charging error


clauwau
26th April 2017, 07:03 PM
A few weeks ago, I had a charge error while charging my battery for the OMD EM1 Mark II (blinking green light). I ordered a new battery thinking the problem is with the battery (I have not received it yet). Yesterday, I had the same charging error with another battery. Has anyone experienced this problem with their battery and/or battery charger?
Thanks, Claude

Graham from Wirral
26th April 2017, 07:26 PM
Charged two so far - no problem. A third is charging as I write this.

Bikie John
26th April 2017, 07:30 PM
Three batteries, through 2 or 3 charging cycles now and not seen this problem.

I hope that is not tempting fate!

I hope you get to the bottom of it and get it sorted out.

John

MJ224
29th April 2017, 09:27 AM
Does the battery actually charge?? ie when back in the camera show 100%

Might be the charger lights that have gone up the swanny.....:confused:

Bengeo
29th April 2017, 09:38 AM
I've had it happen once when I put what I thought was a fully charged battery in just to check it. Took it out and put it back in and it then showed steady green.

Beagletorque
29th April 2017, 10:08 AM
The new charger flashes Green when it is charging. It goes off completely when fully charged. Opposite to the mk 1.

Sent from my Nexus 5 using Tapatalk

Ricoh
29th April 2017, 11:39 AM
A few weeks ago, I had a charge error while charging my battery for the OMD EM1 Mark II (blinking green light). I ordered a new battery thinking the problem is with the battery (I have not received it yet). Yesterday, I had the same charging error with another battery. Has anyone experienced this problem with their battery and/or battery charger?
Thanks, Claude
This suggests it's the charger. Go to your 'friendly' retailer and ask if they can charge the battery in question. If yes, they make a sale of a new charger. Win-Win.

Growltiger
29th April 2017, 12:14 PM
The new charger flashes Green when it is charging. It goes off completely when fully charged. Opposite to the mk 1.

Sent from my Nexus 5 using Tapatalk

That is completely wrong! It flashes yellow when charging and then goes continuous green when finished.

Are you sure you have a genuine Olympus charger?

Beagletorque
29th April 2017, 12:51 PM
I'm colour blind.

MJ224
29th April 2017, 02:23 PM
That is completely wrong! It flashes yellow when charging and then goes continuous green when finished.

Are you sure you have a genuine Olympus charger?

+1.............................

Wee man
30th April 2017, 04:24 PM
I'm colour blind.
Me to


Wee Man

steveliddle
9th February 2019, 07:02 PM
Got two olympus batteries and original charger, had a flashing yellow light that suggested something was dud, cleaned the contacts on the charger and battery, then took the lead out and plugged it back in again. Charged from 29% to 100% in less than 30 mins :)

One problem is having several cameras and the chargers all have different colours:

Panasonic’s battery charger displays a green light while the battery is charging. The light goes off when charging is completed. Yet this camera seems to have a flashing green light and then when charged, a solid green light when charged and then there is the nikon and fujifilm :)

Growltiger
9th February 2019, 09:44 PM
Got two olympus batteries and original charger, had a flashing yellow light that suggested something was dud, ...


Do you understand that flashing yellow means it is charging normally?

TimP
10th February 2019, 08:49 AM
Got two olympus batteries and original charger, had a flashing yellow light that suggested something was dud............<snip> Yet this camera seems to have a flashing green light and then when charged, a solid green light when charged and then there is the nikon and fujifilm :)

Eh? Flashing yellow is normal and rate of flash indicates charge progress.

You say flashing green? Really?
Mine goes green, as others have said, when fully charged.

Phill D
10th February 2019, 11:49 AM
Mine's like yours Tim. Solid green when fully charged.

TimP
10th February 2019, 12:54 PM
Mine's like yours Tim. Solid green when fully charged.

I have to be honest and say I do have a second original charger from my second body which I’ve never used, maybe that one is different?

Growltiger
10th February 2019, 03:12 PM
For those who have not read the manual, here is what it says. And I assure you it is correct.


Charging indicator
- Charging in progress, Less than 50%: Blinks in orange 1 time/second
- 50% or more, Less than 80%: Blinks in orange 2 times/second
- 80% or more, Less than 100%: Blinks in orange 3 times/second
- Charging complete: Lights up in green
- Charging error: Blinks in green 5 times/second
(Charging time: Approximately 2 hours)


Those who are colour blind can still read the charging status accurately, by observing the blink rate.

Wee man
11th February 2019, 07:18 AM
That's what I do but now I know there is also a colour change!

Ed

Sent from my SM-G930F using Tapatalk

snerkler
21st February 2019, 04:31 PM
For those who have not read the manual, here is what it says. And I assure you it is correct.


Charging indicator
- Charging in progress, Less than 50%: Blinks in orange 1 time/second
- 50% or more, Less than 80%: Blinks in orange 2 times/second
- 80% or more, Less than 100%: Blinks in orange 3 times/second
- Charging complete: Lights up in green
- Charging error: Blinks in green 5 times/second
(Charging time: Approximately 2 hours)


Those who are colour blind can still read the charging status accurately, by observing the blink rate.

This is what charger is supposed to do, and it goes through all the series of different speed flashing amber light, but then it never seems to go green. However, when I turn off the charger it turns green momentarily before the light turns out and when I put it in my camera it says 100%.

Any ideas whether this is a charger fault, battery fault, or just lack of paitience on my behalf?

Growltiger
21st February 2019, 05:04 PM
Does it stop blinking and show a continuous light? That is the signal that it has finished charging.


Is this an Olympus charger with an Olympus battery?

snerkler
21st February 2019, 05:31 PM
Does it stop blinking and show a continuous light? That is the signal that it has finished charging.


Is this an Olympus charger with an Olympus battery?

Just keeps on the fastest blinking amber, doesn’t go solid and doesn’t go green (apart from that brief moment described above). Genuine battery and charger.

MJ224
21st February 2019, 05:32 PM
This is what charger is supposed to do, and it goes through all the series of different speed flashing amber light, but then it never seems to go green. However, when I turn off the charger it turns green momentarily before the light turns out and when I put it in my camera it says 100%.

Any ideas whether this is a charger fault, battery fault, or just lack of paitience on my behalf?

Job done by the sounds of it...……….*chr

snerkler
21st February 2019, 05:35 PM
Job done by the sounds of it...……….*chr

It is yeah, but without the confirmation from the charger it’s hard to know when to turn it off. I could be leaving it on hours more than necessary ;) Also, if it's not turning green is the charger staying on rather than clicking off when it's charged?

Growltiger
23rd February 2019, 07:38 AM
It is yeah, but without the confirmation from the charger it’s hard to know when to turn it off. I could be leaving it on hours more than necessary ;) Also, if it's not turning green is the charger staying on rather than clicking off when it's charged?
It certainly is not working correctly. The charger is continuing to charge and not reaching completion. You are unlucky.

Do you have another battery? If you have you can determine if the problem is the battery or the charger.

If you don't then I suggest buying a second battery.

snerkler
23rd February 2019, 07:50 AM
It certainly is not working correctly. The charger is continuing to charge and not reaching completion. You are unlucky.

Do you have another battery? If you have you can determine if the problem is the battery or the charger.

If you don't then I suggest buying a second battery.

Thanks, I have a second battery on the way already to check just that :tup

MJ224
23rd February 2019, 08:15 AM
Yes understand the idea that the charger is not switching off, and thus might damage an expensive battery. My batteries are usually charged in about 2 hours, but as suggested you need to get it sorted. Presumably the kit has a warranty, so perhaps you should go straight back to the retailer...…….:(

snerkler
23rd February 2019, 10:42 PM
Ok so the new battery arrived today, charged it and the charger LED turned green at the end of the charge, suggesting the original battery is at fault not the charger. However, I then tried the old battery again and this now also went green, very odd. Completely guessing here but could the new battery have reset a glitch on the charger somehow?

Growltiger
23rd February 2019, 11:29 PM
Ok so the new battery arrived today, charged it and the charger LED turned green at the end of the charge, suggesting the original battery is at fault not the charger. However, I then tried the old battery again and this now also went green, very odd. Completely guessing here but could the new battery have reset a glitch on the charger somehow?
No, the most likely thing is that the first battery finally decided to take a bit more charge and that pushed it up to full. You can relax now.

MJ224
24th February 2019, 10:22 AM
Good news, but an odd story/sequence...……….*chr

kbouk
25th February 2019, 06:03 AM
No, the most likely thing is that the first battery finally decided to take a bit more charge and that pushed it up to full. You can relax now.

I had exactly the same behaviour from my charger with one of my batteries on a recent trip, for 2 days I couldn’t use one battery, it was blinking as yours but only with this battery, after 2 days I examine close the charger and press the contacts inside out and try also the other battery several times it seems a reset is happened and the first battery charges since then as the second one. No problem six months now on both batteries.

jima
2nd March 2019, 03:48 PM
Ok so the new battery arrived today, charged it and the charger LED turned green at the end of the charge, suggesting the original battery is at fault not the charger. However, I then tried the old battery again and this now also went green, very odd. Completely guessing here but could the new battery have reset a glitch on the charger somehow?
No, the most likely thing is the simplest thing which is dirty contacts. Clean them.

snerkler
2nd March 2019, 03:52 PM
No, the most likely thing is the simplest thing which is dirty contacts. Clean them.

I’d be surprised if either a brand new charger or brand new battery would have had dirty contacts tbh, either way it’s now working as expected :tup

Graham_of_Rainham
2nd March 2019, 05:54 PM
I have cleaned the contacts on the batteries and charger and that has always solved the flashing issues.