PDA

View Full Version : Warranty extension?


raichea
22nd December 2016, 11:15 PM
I've registered my MkII on MyOlympus but only see the standard 2-yr warranty. Is the additional 6-month extension no longer applied?

I asked Olympus directly, a few days ago but haven't had a response as yet.

Beagletorque
23rd December 2016, 11:06 AM
No 6 months here either, does it only apply to lenses though?

raichea
23rd December 2016, 12:21 PM
My original E-M1 received an extra 6 months... still no reply from Olympus.

Wee man
23rd December 2016, 12:37 PM
I got the six months then paid 99 for a three year extension.

Wee Man

Olybirder
23rd December 2016, 12:53 PM
Have you subscribed to the Olympus Newsletter? It seems you have to do that and they will send you a link to confirm it.

See: MyOlympus > MyPremium Services > 6 Months Extended Warranty.

Ron

Eclairewilliams
23rd December 2016, 01:29 PM
I got the six months then paid 99 for a three year extension.

Wee Man

I couldn't see that option. Just registered the camera and no option for six month extension I looked at the warranty section on the website but I couldn't see a three year extension for the standard plus. Only three years I can see are 209 for the middle level or a staggering 289 for Elite which I am sure is aimed at professionals who rely on the camera for their business.

The six month extension applied to my 300 I registered just now.

I'm confused!

raichea
23rd December 2016, 01:36 PM
Have you subscribed to the Olympus Newsletter? It seems you have to do that and they will send you a link to confirm it.

See: MyOlympus > MyPremium Services > 6 Months Extended Warranty.

Ron
I was already signed up. I've tried unsubscribing and resubscribing but haven't received any emails and still no 6-month extension.

Olybirder
23rd December 2016, 01:45 PM
I couldn't see that option. Just registered the camera and no option for six month extension I looked at the warranty section on the website but I couldn't see a three year extension for the standard plus. Only three years I can see are 209 for the middle level or a staggering 289 for Elite which I am sure is aimed at professionals who rely on the camera for their business.

The six month extension applied to my 300 I registered just now.

I'm confused!Is this it?

https://www.olympus.co.uk/site/en/c/cameras_support/premium_services/3_years_extended_warranty_s/index.html

Ron

Gwyver
23rd December 2016, 02:12 PM
I've registered my MkII on MyOlympus but only see the standard 2-yr warranty. Is the additional 6-month extension no longer applied?

I asked Olympus directly, a few days ago but haven't had a response as yet.

Steve,
I also had this problem (as mentioned in my thread a couple of days ago).
I subsequently emailed Olympus customer support and they replied explaining that there was a known problem with the registration website, but nevertheless the 6months warranty extension applied to all registered cameras and the details would be updated as soon as the site is fixed,

raichea
23rd December 2016, 02:32 PM
Steve,
I also had this problem (as mentioned in my thread a couple of days ago).
I subsequently emailed Olympus customer support and they replied explaining that there was a known problem with the registration website, but nevertheless the 6months warranty extension applied to all registered cameras and the details would be updated as soon as the site is fixed,
Thanks Chris, I didn't spot your earlier thread. I did contact Olympus to ask about it but haven't received a reply as yet, as previously noted.

It might help anyone else who runs into the problem if you added a comment about your communication with Olympus at the end of that thread too.

Gwyver
23rd December 2016, 03:05 PM
Thanks Chris, I didn't spot your earlier thread. I did contact Olympus to ask about it but haven't received a reply as yet, as previously noted.

It might help anyone else who runs into the problem if you added a comment about your communication with Olympus at the end of that thread too.

As requested, please see my post at:
http://e-group.uk.net/forum/showthread.php?p=401952#post401952

Harbrimar
23rd December 2016, 04:47 PM
I had the same problem with the extra 6 months not showing and have taken it up with Olympus. But, I have since found out if you go into 'My Olympus' and then click on the Star i.e. 'My premium Services' on the menu to the left of the screen, this will take you to another screen, scroll down and in my case '6+' is shown as activated.

Olybirder
23rd December 2016, 05:06 PM
I had the same problem with the extra 6 months not showing and have taken it up with Olympus. But, I have since found out if you go into 'My Olympus' and then click on the Star i.e. 'My premium Services' on the menu to the left of the screen, this will take you to another screen, scroll down and in my case '6+' is shown as activated.Yes, if you then click on the 'see more' button it comes up with a list of your equipment which has the 6 months extended warranty. In my case they have all expired now apart from my 17mm f/1.8 lens. Does your E-M1 Mk 2 show up in that list?

Ron

raichea
23rd December 2016, 05:32 PM
My Mk II doesn't show up in that list :(

Eclairewilliams
23rd December 2016, 06:41 PM
Nor does mine. I'll wait and see when they fix the website as mentioned above.