PDA

View Full Version : EM1 4.2 firmware - be careful!


Beagletorque
2nd December 2016, 10:41 AM
http://www.43rumors.com/bug-warning-do-not-install-firmware-4-2-on-your-e-m1/

Bikie John
2nd December 2016, 12:41 PM
Oh fiddlesticks, just done mine :( I don't think I use any of the functions mentioned though.

I did the update because I have been having a problem with the 300mm f/4 which I haven't aired on here yet. It might be time to go public on it.....

John

Beagletorque
2nd December 2016, 12:55 PM
Interesting, not had a problem with my 300 what it yours???

Ross the fiddler
2nd December 2016, 01:19 PM
Info included in that link is:-
As reported by many readers (including Pen And tell and Denjw) the 4.2 firmware update for the E-M1 contains a major bug on. It locks down and creates corrupted images when using those functions:
– Focus Stacking
– Keystone
– HDR
– Starlight mode

So please do not install the firmware. Or if you already installed it don’t use those functions until Olympus will release a bug fix (hopefully soon).

Also,
"According to Reinhard Wagner from the German Oly forum, the bugs occur if RecView (display of the image right after the shot) is disabled."

Also discussions here. http://e-group.uk.net/forum/showthread.php?t=43551&page=2

pault
2nd December 2016, 01:23 PM
Hi
It seems if you have "rec view" set to "off" then the problems occur. I tried "rec view" at 0.3 sec and all works ok.
Mind you Olympus still have to provide a fix

bassman
2nd December 2016, 05:36 PM
Many thanks everyone, did firmware update this morning ! I do normally have my rec view disabled, I'll set it to 0.3 sec and keep look out for any updates.

Greytop
6th December 2016, 09:17 AM
I updated mine before I saw the problems that it's caused. I have rec view enabled anyway so not a huge problem. Will keep an eye out for the fix (revised firmware).

Ross the fiddler
6th December 2016, 12:35 PM
Oh fiddlesticks, just done mine :( I don't think I use any of the functions mentioned though.

I did the update because I have been having a problem with the 300mm f/4 which I haven't aired on here yet. It might be time to go public on it.....

John

John, just a silly question, but I assume you've also updated your 300mm F4 lens as well?
http://e-group.uk.net/gallery/data/500/Oly_lens_updates_22-11-2016.JPG (http://e-group.uk.net/gallery/showphoto.php/photo/91234)

Bikie John
6th December 2016, 02:11 PM
Thanks for your concern, Ross - yup, did the 300 and the 40-150 at the same time. In fact I checked all my m43 lenses and gave myself a little pat on the back because the others were all up to date </SMUG MODE>

John

Ross the fiddler
7th December 2016, 01:49 AM
There's another update statement for this FW update now.

This has been posted on DPR.

Olympus has suspended Firmware 4.2, and has today issued the following statement (edited slightly for clarity from a Japanese translation)

The award-winning Olympus OM-D series has received excellent reviews from a wide range of users. With stunning, compact designs packed with revolutionary technologies, the OM-D series provides incredible speed, outstanding image resolution and a host of shooting features to meet the needs of the professional and enthusiast photographer, alike.

There have been a small number of reported issues with the latest E-M1 firmware version 4.2. As a result, Olympus has proactively suspended this firmware update in an effort to evaluate the reports.

Olympus has been able to confirm that it is a unique group of settings that cause the issue. The camera does not perform properly under the following conditions:

Using HDR, Focus stacking, Hand-held starlight in scene mode, and keystone compensation with Rec view 'Off'.

When Rec view is turned on, the problem does not happen. Affected users are advised to turn Rec View on to avoid issues.

For those E-M1 owners who have not yet updated their Olympus firmware to version 4.2, and whose current firmware version is version 4.1, no action is necessary.

On the Olympus global page, Joint update service for OLYMPUS E-SYSTEM - OLYMPUS Digital Camera (http://cs.olympus-imaging.jp/en/support/imsg/digicamera/download/software/firm/e1/) they do have the note under the listed update.
The firmware update service for E-M1 version 4.2 has been temporarily disabled.
The update service for version 4.1 is available at this time.

Bikie John
7th December 2016, 09:40 AM
Thanks Ross.

I quite happily used it for a gig at the weekend without any problems. But that was without HDR, focus stacking etc. etc.

John