PDA

View Full Version : BLM-5 Battery Charger - Problem


WPJ
14th September 2013, 08:26 PM
Hi,

Has anyone experienced a problem with their charger. I've just hear an almighty crack from mine while charging a battery.

It was very hot to the touch and now there are no lights showing. I've swapped batteries over and the lead, nothing showing.

Just wondering if their is a cutout on it or if the charger is now dead.

Cheers

Paul

peak4
14th September 2013, 08:36 PM
Well, given that it seems too light to house a transformer, I assume that there is a switch mode power supply in there somewhere.
When they let go, they do sometimes do it with style. I can remember opening one to find several wires sticking out of the PCB without any components on the end.
One for the warranty I guess, but it doesn't help you in the short term.

WPJ
15th September 2013, 07:09 AM
Thanks Bill.... hope your well mate.

Looks like a new one needed. Luckily I should have enough charge in the two batteries to get me through the horse show today. I've also got some batteries from the E3, which I believe work.

60 for a new charger though :-(

I also lost a battery out of the OMD last weekend, not doing very well at the moment.

Paul

peak4
15th September 2013, 07:15 AM
E-3 batteries will work fine in the E-5, just a slightly lower capacity.
Enjoy the show

Naughty Nigel
19th September 2013, 07:11 PM
E5 batteries will charge in an E1 / E3 charger, but not the other way round.

These chargers do indeed contain a switch mode power supply circuit which controls charging current, etc.