PDA

View Full Version : 50-200SWD Problem


knikki
31st August 2008, 09:15 AM
I have just usd the lens yesterday and today, not used it for a few weeks.

I started to notice that the lens was struggling to focus :(

E3 works fine with the 12-60 so I know it is not the body.

When the 50-200 is trying to focus you can hear a clicking sound, like the drive train has not engaged correctly, you can focus it manually and get focus conformation, just.

The lens has not been dropped but anybody any idea or is it going to have to go to Olympus. It was a brand new lens but not bought from a shop so not sure what to do. :(

PeterD
31st August 2008, 10:44 AM
I have just usd the lens yesterday and today, not used it for a few weeks.

I started to notice that the lens was struggling to focus :(

E3 works fine with the 12-60 so I know it is not the body.

When the 50-200 is trying to focus you can hear a clicking sound, like the drive train has not engaged correctly, you can focus it manually and get focus conformation, just.

The lens has not been dropped but anybody any idea or is it going to have to go to Olympus. It was a brand new lens but not bought from a shop so not sure what to do. :(

Sorry to hear of your mis-fortune. You say you did not buy from a shop, where did you get it from? Have you registered the lens with Olympus?

Peter

PS
Just noted that you are no-longer on line so I will add this:
1. Phone Olympus Technical Support and tell them what has happened and ask them what they would recommend.
2. Contact Customer Service in Watford and advise them of what you have been told by Technical Support. If they pronounce it dead, then ask if its posible for a foc replacement.
3. I have always found both Technical support & Customer Services helpful and sympathetic.

Good luck

knikki
31st August 2008, 11:11 AM
Thanks Peter

I bought the lens from one of the other forum members, it was new boxed and had all the paper work with it.

Just check i have not registered the lens on the Olympus Website, so would not have sent the paper work from the lens off either

Cathal
31st August 2008, 12:15 PM
I have no experience with this lens, but before you get depressed just check that all contacts are clean and that the lens is mounted on the body properly. Are their any modes or switches on the body / lens that could have been changed accidentally?

A call to Olympus in the AM may put your mind at ease.

knikki
1st September 2008, 08:11 AM
Thanks Cathal

No switches on the lens, and have cleaned the contacts but still not working. Will give Olympus a ring later

Jeremy Evans
15th October 2008, 11:36 AM
I have a similar problem. Having worked perfectly my 50-200 SWD suddenly refused to autofocus. I sent it to Olympus who said they would give it a full service. 3 weeks later it came back and is still not right. The lens intermittently locks up and won't focus at longer focal lengths, but is fine anywhere close to 50mm. Olympus collected the lens today. I asked them to send me a new lens instead, but they have so far refused.
I used a standard 50-200 to take thousands of images with my E1. No problems with that lens. My E3 works perfectly with the 12-60 at all focal lengths.
At this point, I am very disappointed with Olympus, not least because I need that lens for my work.

knikki
15th October 2008, 01:07 PM
That is unlucky

I ended up sending my lens back to Oly and after about 2weeks it came back all sorted and has been working ok since.

Hope it gets sorted soon.

PeterD
15th October 2008, 03:15 PM
I have a similar problem. Having worked perfectly my 50-200 SWD suddenly refused to autofocus. I sent it to Olympus who said they would give it a full service. 3 weeks later it came back and is still not right. The lens intermittently locks up and won't focus at longer focal lengths, but is fine anywhere close to 50mm. Olympus collected the lens today. I asked them to send me a new lens instead, but they have so far refused.
I used a standard 50-200 to take thousands of images with my E1. No problems with that lens. My E3 works perfectly with the 12-60 at all focal lengths.
At this point, I am very disappointed with Olympus, not least because I need that lens for my work.

Sorry to hear your story Jeremy. I have a lot of praise for my experience with Oly as they have always been sympathetic to my issues. What actions are you taking?

That is unlucky

I ended up sending my lens back to Oly and after about 2weeks it came back all sorted and has been working ok since.

Hope it gets sorted soon.

Knikki

Meant to ask how you got on. I am pleased to hear that all is well again.

Peter