PDA

View Full Version : Problems with focusing


rutwij
15th April 2013, 11:19 PM
On Saturday, on my trip to the Isle of May, I had also taken along my EM5 with the 12mm strapped on, for landscapes.
It was then that I found the EM5 not focusing at all. In one shot it seemed to wake up and focused. But then it went back to a big blur. Tapping the screen to focus/click didn't work either, and neither did pressing the shutter. There was no attempt by the camera to focus.
1. SAF was on
2. I tried with the focus ring of the 12mm pushed forward as well as pulled back
3. MF didn't work either
4. restarting the camera didn't work either

The AF problem seemed to go away when I got back home.

I checked the EXIF for the images with the mucked up focusing and noticed something unusual... the aperture value was showing as f-.- and the FL was showing as 0mm
The one image which worked, the FL was shown correctly as 12 mm and aperture f2.0
Is there some setting I didn't get, which made the camera/lens behave this way? Or is there a problem with the camera or with the lens?

Does anyone have an idea what could have caused this aberrant behaviour?

Rutwij

peak4
15th April 2013, 11:44 PM
I'd say either dirty contacts or the lens fitted with the release button depressed, so the lens turned a fraction too far round.
Don't clean the contacts with anything more abrasive than a soft pencil eraser; not one of the old ones with sand in them. Personally I use an alcohol swab that's had most of the fluid evaporate.
Good luck

Imageryone
16th April 2013, 06:24 AM
I, too, would say bad contacts, I notice it on my 70-300mm sometimes. Hope it is that simple :)
If it happens again, refit the lens and see if that fixs the problem.

StephenL
16th April 2013, 06:51 AM
I would say too that Bill's second idea about the lens pin not being correctly in place is the most likely scenario. I have had this happen on one occasion, and it was definitely my error in not checking the lens was properly locked in.

Bikie John
16th April 2013, 08:54 AM
It should show you at the time - if you check the aperture it probably shows up as f/-.-, the same as recorded in the EXIF. I have seen it a few times on E-1/3/5 when I've been a bit careless mounting the lens and it hasn't quite seated properly. I haven't seen it on the E-M5, but of course that doesn't mean it doesn't happen.

Ciao ... John

Zuiko
16th April 2013, 01:40 PM
Sometimes I fail to fit the lens on my E-M5 correctly and get the same problem. Reseating the lens cures it. There seems to be a rather fine margin for error.

rutwij
16th April 2013, 04:18 PM
AH thanks very much guys. The problem seems to have disappeared just now and I haven't been able to recreate it. The scary thing was on Saturday I wasn't able get the thing working!
At least now it saves me from having to get a replacement from Amazon yada yada!

Chevvyf1
16th April 2013, 04:41 PM
I know this is going to sound MAD ... BUT wasn't there a meteor storm or somthing ? that was messing up the Satillite signals and causing electrical pulses ?


MY 14-54 was messing on Saturday and f -.- and other exif data I was trying to compare was not there :( ...

DerekW
16th April 2013, 06:20 PM
I read somewhere that if the screws that hold the mounting plate on the front of the body are slightly loose then the various contacts and pins do not work. So check that all the screw are tight and that the mounting plate is not loose.

George Dorn
16th April 2013, 06:28 PM
Something like this happened on my E-620. Swapping the lens cleared it up, so I would guess at misaligned electrical contacts.