PDA

View Full Version : Underexposed or black frames with legacy lens


Tordan58
2nd April 2013, 07:21 AM
Hi

When using the E-M5 on legacy lens (a scope with fixed aperture) I get a strange behavior.


The first frame is usually either totally black or severely underexposed (-3EV or so). If I take additional frames after the first one I get the following
Sometimes the second frame is underexposed as well, but not as bad as the first one (I would say about -1.5 EV). Usually it is correctly exposed, though.
The third frame and beyond are correctly exposed.


If I for instance operate the camera menu, playback pictures etc. then I am back at square one. This is quite... irritating.

For reference: The camera shows the same behavior using both A and M exposure modes. The camera reports F/0.0 and the focal length is empty (I guess that is what happens when no lens information is reported).

Anyone experienced similar behavior?

/Tord

Melaka
2nd April 2013, 07:54 AM
I sent my first EM5 back after a few days because it began to produce black frames.

I have also had exposure problems with the first of a series being up to one stop over exposed. Olympus were most unhelpful with this as the lens is a Panasonic. I suspect a lens problem as I've tried it on Who'sE's G3 with similar results so the lens is off this week to be looked at.

Tordan58
2nd April 2013, 08:51 AM
I don't think it is an issue pertaining to the lens. What I forgot to mention is that the issue sometimes also materializes when using the 12-50 lens.

More precisely: In between sessions with my legacy lens I mounted the 12-50 lens, and when useing A and M modes I got black or severely underexposed frames.

It was'nt until I started taking pictures with the iAUTO mode that the camera repeatedly produced correctly exposed frames on the 12-50. After that I could use the A and M modes on the 12-50 with expected results.

From memory I recall that the camera produced correct exposures when I started using legacy lens, the issue wasn't there at start. It started a week ago or so.

Strange, isn't it?

Tordan58
4th April 2013, 07:23 AM
This is the latest on this topic. Sorry for bothering again, hopefully someone here has clues to what the issue is due to.

Already before coming across the issue with black/underexposed frames, I had removed the AF confirm chip when using with EM-5 since I believe it was the cause of weird behavior and since it was reprogrammed by the EM-5 camera anyway without me asking for it, it was kind of useless. (And the EVF + magnification is a better solution anyway.) Now the camera reports F/0.0(strange, isnt't!) and focal length = "empty"

I went out for a photo session yesterday evening, using A and M mode. Looking at about 50 frames taken:

1 slightly underxposed about -0.5 EV,
20 underexposed about -1.5 EV,
5 severely underexposed -3EV or worse
20 black frames.


Exposure times were in the range 1/1000 to 1/1600 s which does not make sense. Looking at good results from previous sessions in similar light conditions I was shooting at typically 1/400.

So something is wrong, I just don't get what it is. The exposure is OK when using the 12-50 lens.

So I was wondering if the F/0.0 could be the source of errors and leading to unpredictable results. (I would have expected the camera to report -.- or "unknown", but not F/0.0 which is not possible if you see what I mean - division by zero)

I updated the FW last night to 1.6, maybe that will help. Will test again today.

Do you know if there a way to reset the camera to factory settings?

/Tord

Falk
4th April 2013, 12:58 PM
Can't be of real help as I don't have that body but, photos taken with the E-520, E-30 and legacy glass also say F/0.0 - so this notation seems to be the standard way Oly-bodies write their EXIFs.
Have you tried a full camera Reset?

Imageryone
4th April 2013, 05:47 PM
I really hate to say this, but the first intimation that the shutter was going on my e300 was black and wrongly exposed frames. Sounds like a problem for Olympus?

Tordan58
4th April 2013, 08:17 PM
I don't think it is the shutter since the exposure times are in line with what you would have expected with respect to the final results. Furthermore the exposure is correct when I am using the 12-50 lens.

It has to be the exposure metering in some way.

Ian
5th April 2013, 09:05 AM
I know when I get wildly unpredictable exposure it usually means I forgot to switch back from using spot metering - no chance this could be the cause?

Ian

Tordan58
5th April 2013, 03:18 PM
Ian,

I am aware of this potential issue associated with spot metering.

In this case I have used evaluative metering. Some variations are shown between similar frames, but as much as 3EV is not possible since the EXIF reports about same exposure times for all frames in a series on similar subject shot in similar light conditions.

And I don't understand how some frames can be totally black. There is not a pixel that does not have the value (00, 00, 00).

/Tord

Tordan58
7th April 2013, 08:14 PM
From this thread on DPreview http://www.dpreview.com/forums/thread/3466720 where other people have reported the same issue it sounds like my camera is among those that have a defect shutter.

Tordan58
8th April 2013, 12:33 PM
Sorry for bothering but I tought some of you may be interested in how this evolves.

I am now in dialog with Olympus support (Sweden) who first claimed that non (micro)four-third lenses are not supported and did not want to deal with the issue when using the camera with a third part odd lens. (The camera is still under guarantee).

I am now at a stage where I try to convince them that at a mininum they must support OM legacy lenses since they provide an adapter (MF1) that is designed for that purpose, and explaining that the issue is about incorrect exposure only - might be a defect shutter? So what I will try to do is to somehow reproduce the issue on a OM Zuiko legacy lens.

From memory I recall the issue with underexposed frames has also happened when using on the 12-50 lens that I bought with the camera, but since I have not used it that much I need to find out how to reproduce it. Perhaps it is in conjunction using the camera when using high ISO, aiming for short shutter times?

/Tord

Tordan58
9th April 2013, 07:45 AM
I really hate to say this, but the first intimation that the shutter was going on my e300 was black and wrongly exposed frames. Sounds like a problem for Olympus?
Here is the latest status on this issue.

I discussed with other fellow photographers and they pointed at a defect shutter with a "sticky" second curtain.

I could easily reproduce the issue using any lens e.g. the 12-50 lens, by simply shooting at a bright object, opening the aperture and increasing the ISO in order to come down to around 1/2000s. That is the critical time when frames become underexposed or sometimes even black.

The background for encountering the issue on the 600 mm lens is that I, whenever possible, aim at short exposure times assisted by high ISO. (That's one of the reasons for me buying an OMD).

The camera is now on its way to Olympus Service. FYI they initially refused to accept the return since I was using a non-Olympus lens! :eek:


Though you wanted to know.