PDA

View Full Version : Flash wont fire


Phill D
27th January 2013, 10:10 PM
Anyone got any suggestions? I tried to use my FL36R flash but it just wont fire. Everything seems to light up OK on the back panel but even when I press the test lamp the lamp just flickers and no flash. Is this something I've done? a setting I've changed inadvertantly (he said hopefully) or has it gone kaput :(. I'm afraid I've hardly ever used the flash since getting it a couple of years ago maybe only taken a dozen flash shots in all, so I really don't know my way around it, therefore any help would be gratefully received.

Wee man
27th January 2013, 10:46 PM
Not really sure but check the batteries are in the correct way round?

Imageryone
27th January 2013, 11:12 PM
I have found with my Fl50 that it does not work well with rechargable batteries, but always works perfectly with Duracell. I get both lights on but no reaction, and I have tried 6 makes of rechargable.

Ross the fiddler
27th January 2013, 11:54 PM
See if there is any corrosion on the battery terminals & clean if needed, but if there is, there might also be corrosion in the switch area (could be pc board contact pads). If this is the case then it may not be a cheap solution. Batteries aren't always reliable as normal Nickel Metal Hydride batteries can lose their charge after a relatively short time but I am now using the 3rd generation Eneloop batteries by Sanyo which can retain 70% of the capacity after 5 years storage once fully charged (90% in 1 year). These are better than their 2nd generation batteries that will still be available from most places but I highly recommend getting their 3rd generation ones. I believe these are the best AA batteries made by anybody. No more flat batteries when you need them. ;) :D

Check this thread. http://e-group.uk.net/forum/showthread.php?t=12087&highlight=testing+batteries

Phill D
28th January 2013, 05:56 AM
Thanks guys. The batteries are in OK. I've tried several sets and even new Duracell ones as well instead of the rechargable ones incase they had died. But the LCD panel works fine and so does it's backlight. No corrosion on the terminals either, I never leave batteries in it so I'd have been supprised but I did check. PC board contacts hmm sounds like a tricky fix as these things can be deadly internally not sure I want to venture inside, will have to think about that.

Bikie John
28th January 2013, 09:41 AM
It sounds as though you have eliminated the obvious things. You could try ringing good old Luton Camera Repair Services - http://www.lutoncameras.co.uk/ - to see what they say. They are official Oly repair agents and are very helpful, several of us here have used them. They should be able to quote a standard price for a service/repair on the spot, or if they recognize it as a common problem they might be able to tell you more.

Good luck ... John

cliff
28th January 2013, 06:35 PM
Hi Phill, just looked at mine, you can adjust the target distance from gn36(max) down to gn3.2(min), if you've got it mounted on the camera as well you could further reduce the flash power in the scp by selecting 1/2-1/8 flash( I think)?.
With mine off the body(free standing)on the min settings I still get a small flash,and set to gn36 I get a bloody photon torpedo *yes
If your getting nothing then I don't know, could be the bulb?
Good luck
Cliff *chr

Phill D
28th January 2013, 08:52 PM
John thanks I might try them in a day or so I just want to be sure it's not me being stupid first. Cliff I just tried all the gn changes and nothing :( . It's definitely looking more & more like a repair bill.

alfbranch
30th January 2013, 08:24 PM
Same the happened to a Metz flas of mine in just over a year and it was going to cost as much as it cost to buy to repair but it was a cheaper unit.

For the Metz flash apparently the capacitor goes out of shape if it is not fired at least every 2 months several times