PDA

View Full Version : E-3 HELP - it's Brand New & DEAD


Graham_of_Rainham
11th July 2008, 12:38 PM
Just received a new E-3 and it's locked up. Nothing works, except lens reacts to switch on & off. :(

Mirror is in the up position and shutter is closed. :confused:

Changed battery, Changed Card, Changed Lens, left it switched off with no battery in it. Still Nothing :mad:

Just emailed the company for a full refund.

This week I also got hit with a TAX return and a Parking Ticket :eek:

So if anyone can tell me that I simply press U,U,L,R,L,R,D,D and it all works again, I'd appreciate it.

Haisbro
11th July 2008, 12:47 PM
Sorry to hear your probs. Are all the menus visible on the LCD?

David

andym
11th July 2008, 12:56 PM
Sorry to hear that.When its turned on have you tried a full reset ie pushed the ISO and Exp comp button together.

Good luck

Nick Temple-Fry
11th July 2008, 01:03 PM
Right, send the camera to the Inland Revenue in 'full and final settlement', and err well...........

Sorry to hear this, ********** frustrating.

Nick

Graham_of_Rainham
11th July 2008, 01:25 PM
Thanks Guys,

As you can imagin, I've tried everything... and in the best traditions of Monty Python "It has ceased to be" :(

I have to admit I do rather like the idea of sending it to Revenue & Customs

*chr

Graham

B.P.S Studios
11th July 2008, 05:05 PM
Sorry to hear that Graham, I was going suggest a reset but Andym got there before me.

PeterD
11th July 2008, 07:12 PM
Graham,

I am sorry to hear your story. The camera is dead. My first E3 went into mirror lock up and the symptoms you describe. Although I got a replacement, I also got the repair details. The mirror assembly required rebuild. Mine was one of the first releases in the UK and at the time I put it down to poor build quality. To hear your story horrifies me.
Mind you, the replacement camera also failed in that it went into a full factory reset on its own, several times during a shoot. This time I opted for a repair and was glad I did. I hope all the gremlins have now been laid to rest.

PeterD

Barr1e
11th July 2008, 08:12 PM
Graham -

Sorry to learn about the problem your new camera has given you. :(

I hope they sort this out before October. Reading PeterD's comments I wonder if your unit is one of those early ones?

I know you will keep us all informed of the outcome.

Regards. Barr1e

Graham_of_Rainham
11th July 2008, 08:41 PM
Hi All,

The company has agreed to a full refund, so it will be in the post tomorrow.

Once I get it, I shall write the full story... :o

Thanks for the many messages of support. :)

On the bright side, my new 70-300 is brilliant. I have never had such a versatile lens. :cool:

Graham