PDA

View Full Version : Another new OMD owner


Alpha1
25th August 2012, 08:20 AM
In anticipation of getting my OMD I had already registered on the forum, so hello to everyone. Yesterday pm I received a call from my local LCE branch to say that they had just taken delivery of one all black OMD with 12-50 kit lens if I was interested.

Of course one look and I was very interested! They had previously agreed to take some other gear including my Fuji X100 kit in Px. So here we are, batteries (yes they were able to sell me a spare!) all charged, settings all done and hopefully menu's all sorted to give me the shooting style that I am used to with my FF and APS-c DSLR's.

One thing though, I noted that the camera firmware is 1.2 and the lens is 1.1. Are these the latest firmware up dates? If so, I read here that some have experienced difficulty with firmware 1.2 yet that is how the camera was delivered!

I am hoping after a thorough evaluation that this camera might replace my DSLR's as I am finding it getting more difficult lugging around heavy cameras and lenses, especially when photographing wildlife, which is my favourite "thing".

snaarman
25th August 2012, 11:36 AM
Hi there and welcome to the forum. An excellent choice of camera if I may say so...

V1.2 is kinda current.I updated mine to 1.2 but then it was withdrawn from the Oly website, however I have seen no problems nor have I heard of any.

Get snapping, and pop some results up on the free gallery here..

All the best

Pete

StephenL
25th August 2012, 11:55 AM
Hi and welcome.

As Pete says, 1.2 is current and is shipping with new cameras, but due to some (minority) having difficulty following instructions, Olympus have strangely withdrawn it from public release. I know of no-one who is experiencing any problems. And 1.1 is current for the lens, so no worries there.

ayewing
25th August 2012, 03:52 PM
Hello and welcome. I think the OM-D has attracted a lot of new users to the Olympus fold. Like you I bought a OM-D to replace my DSLR gear and have now burned my boats by selling off my Pentax K-5 and lenses.

I am sure that you will enjoy your new camera.

Zuiko
25th August 2012, 04:16 PM
Hi Alpha1 and welcome. I've just bought a new (well, secondhand actually) E-M5 too. Just been finding my way around it so far but hopefully will get to use it properly tomorrow. I think the issue with v1.2 was more related to download problems rather than the firmware itself. If you have it already installed then that' a good thing. :)

wellyboot
25th August 2012, 09:50 PM
Hi Alpha1! Like you, I am a new OMD owner, and have also just joined this forum, and thank goodness I did, because I have already had some good advice from the good people on here!!
Enjoy the camera, and forum!

Alpha1
26th August 2012, 07:54 AM
Thank you everyone for the warm welcome to the forum. I know that I am going to enjoy it here! The sun is shining here to today, so off out for a walk with my new toy.