PDA

View Full Version : Dropping like flies!


DJMC
13th November 2011, 02:57 PM
:(

Last Sunday my XZ-1 went wrong, today my E-PL1's flash has packed up.

Worked for a little while then not a glimmer from it!

What could it be?

:confused:

Internaut
13th November 2011, 03:26 PM
Ok, first question I always ask when there's a cluster of equipment failures (well one of the first - but we're talking battery powered here): Do you live very close to a hospital?

DJMC
13th November 2011, 03:52 PM
Ok, first question I always ask when there's a cluster of equipment failures (well one of the first - but we're talking battery powered here): Do you live very close to a hospital?

Mental hospital?

:rolleyes:

DJMC
13th November 2011, 04:07 PM
Just discovered that if I pull the extended flash back a tiny amount, about one degree or more, the flash works.

Also, the flash symbol, top right of the screen, doesn't flash orange unless I'm moving the flash arm as I half press the shutter button. Even with the flash held in a position where it will fire, the flash symbol doesn't stay on to denote it's charged.

Anyone any idea what's going on?

Rapidly going off Olympus! :mad:

:confused:

IainMacD
13th November 2011, 05:09 PM
Someone said that "if Olympus went bust all the cameras wouldn't suddenly stop working"; now I'm not so sure!!
Seriously though, I do hope you can fix these issues easily.
Good luck
Iain

Internaut
13th November 2011, 05:20 PM
Mental hospital?

:rolleyes:

Nah, kind of hospital that has large items of electromagnetic equipment. I used to work for software company that specialised in healthcare applications and there was a story of a former employee who'd had to deal with a bit of an X File regarding PCs we's supplied that kept dying (and in Scooby Doo style, it wasn't the ghost that the staff there had thought it was)......

DJMC
13th November 2011, 05:23 PM
Someone said that "if Olympus went bust all the cameras wouldn't suddenly stop working"; now I'm not so sure!!
Seriously though, I do hope you can fix these issues easily.
Good luck
Iain

The XZ-1 went off last week, under warranty, so hopefully they won't blame me for breaking something internally!?

The E-PL1 isn't under warranty. I'll phone Olympus technical and/or Luton Cameras tomorrow and see if they can 'shed any light' on the problem.

:rolleyes: