PDA

View Full Version : 14-54 MKI with Fungus? How to clean??


DJMC
25th June 2011, 11:17 AM
:confused:

You may recall I successfully cleaned a Zuiko OM 50mm f1.4 by dismantling it and removing the fungus inside.

I've seen a 14-54 MkI with fungus inside the front element and thought I might 'rescue' it, clean it up, and then sell it on (or my current identical one), putting any profit toward more kit.

However, examining my own 14-54 MkI I cannot see how the front lens ring unscrews. The front is threaded but there are no spanner holes in the lens retaining ring?

Does anyone have any idea how this is unscrewed? It may be that there is a rubber faced ring tool that is pressed up against it and turned but I'd think the pressure on it to get a grip would stop it from turning?

I don't particularly want to knacker my one by random experimenting before I buy the faulty one!

Any ideas appreciated.

;)

francois
25th June 2011, 01:33 PM
The pic enclosed might help.

DJMC
25th June 2011, 03:13 PM
The pic enclosed might help.

Thanks Francois. Looks like a threaded retaining ring, but still not sure what to use to undo it!?

Cutaway of a 14-54 Mk2 (& E-30) here: http://forum.mflenses.com/cutaways-and-transparent-cameras-t28075,highlight,cutaways.html

Also, a full parts diagram of an E-1 here: http://www.micro-tools.net/pdf/Olympus/E%20Series/E1.pdf

And other oldies: http://www.micro-tools.net/12.html

;)

francois
25th June 2011, 06:49 PM
YOu can buy some sort of rubber thingy that looks like a large cork to unscrew the front plastic bit. Then ytou have access to the screws and the rest is easy.