PDA

View Full Version : New firmware for kit lenses


j.baker
27th March 2008, 12:29 PM
Olympus have released a firmware upgrade for two of their kit lenses

ED 14-42mm F3.5-5.6
ED 40-150mm F4.0-5.6

IMAGER AF is available when supported by the camera.
* IMAGER AF is unavailable on the following cameras.
E-1, E-3, E-300, E-330, E-400, E-410, E-500, E-510

More information at http://www.olympus.co.jp/en/support/imsg/digicamera/download/software/firm/e1/

PeterD
27th March 2008, 12:56 PM
Olympus have released a firmware upgrade for two of their kit lenses

ED 14-42mm F3.5-5.6
ED 40-150mm F4.0-5.6

IMAGER AF is available when supported by the camera.
* IMAGER AF is unavailable on the following cameras.
E-1, E-3, E-300, E-330, E-400, E-410, E-500, E-510

More information at http://www.olympus.co.jp/en/support/imsg/digicamera/download/software/firm/e1/

Thanks for the heads up John

PeterD

Garrie
27th March 2008, 07:31 PM
Olympus have released a firmware upgrade for two of their kit lenses

ED 14-42mm F3.5-5.6
ED 40-150mm F4.0-5.6

IMAGER AF is available when supported by the camera.
* IMAGER AF is unavailable on the following cameras.
E-1, E-3, E-300, E-330, E-400, E-410, E-500, E-510

More information at http://www.olympus.co.jp/en/support/imsg/digicamera/download/software/firm/e1/

errrr :confused::confused:

andym
27th March 2008, 07:44 PM
errrr :confused::confused:

Assume that unless you are getting an E420 its not worth downloading.

PeterD
28th March 2008, 04:28 AM
Hey guys,

Ever since I updated Olympus Master to 2.05 it seems that the program can no longer 'see' the cameras connected for firmware update (E3 + E500) but I can download my images.

Anyone else experiencing this?

PeterD

blu-by-u
28th March 2008, 08:37 AM
Ever since I updated Olympus Master to 2.05 it seems that the program can no longer 'see' the cameras connected for firmware update (E3 + E500) but I can download my images. ..

If Master 2 can't "see" then how to update the firmware in the future??:confused:

Ian
28th March 2008, 08:40 AM
Assume that unless you are getting an E420 its not worth downloading.

In a way, that's correct, but you might need to use your lenses with an E-420 in future... or something else with Imager AF mode :)

Ian

Ian
28th March 2008, 09:06 AM
Olympus have released a firmware upgrade for two of their kit lenses

ED 14-42mm F3.5-5.6
ED 40-150mm F4.0-5.6

IMAGER AF is available when supported by the camera.
* IMAGER AF is unavailable on the following cameras.
E-1, E-3, E-300, E-330, E-400, E-410, E-500, E-510

More information at http://www.olympus.co.jp/en/support/imsg/digicamera/download/software/firm/e1/

You're mentioned here :)

http://fourthirds-user.com/2008/03/enhanced_live_view_af_for_olympus_kit_lenses.php

Ian

OlyFlyer
28th March 2008, 07:37 PM
If Master 2 can't "see" then how to update the firmware in the future??:confused:Master 2 can only "see" the gear which is not updated. Once it is ready it will no longer report the equipment.

In my opinion this is not a good way, confusing because it hides faulty equipment. If you remember, I had some issues with my ED50/2, it was not recognized by Master 1, but Master 1 always identified every other updated or not updated equipment. With Master 2 I would have never detected my problems because it would never see the lens.

PeterD
28th March 2008, 08:15 PM
Master 2 can only "see" the gear which is not updated. Once it is ready it will no longer report the equipment.

In my opinion this is not a good way, confusing because it hides faulty equipment. If you remember, I had some issues with my ED50/2, it was not recognized by Master 1, but Master 1 always identified every other updated or not updated equipment. With Master 2 I would have never detected my problems because it would never see the lens.

Err the problem I have is that I tried to use Master 2 to update the kit lenses with the latest firmware update. I couldn't because Master 2 did not see the cameras. Are you saying that if the cameras have the latest firmware uodate that they would ignore the lens even if it required updating.

Judging from the lack of comments from others, it seems that I am alone with this proble:(

PeterD

Ian
28th March 2008, 08:32 PM
Err the problem I have is that I tried to use Master 2 to update the kit lenses with the latest firmware update. I couldn't because Master 2 did not see the cameras. Are you saying that if the cameras have the latest firmware uodate that they would ignore the lens even if it required updating.

Judging from the lack of comments from others, it seems that I am alone with this proble:(

PeterD

Hi Peter,

I don't know if you were stumped by something that tricked me - you need to set the camera to 'storage' mode in the USB settings, not camera control, which seems the more obvious option.

If that's not the problem, connect the camera, switched on, to your PC before running Master in case the USB device driver needs more time to install.

Fingers crossed!

Ian

Rod Souter
28th March 2008, 08:36 PM
I had the same problem, the screen on the camera was showing "STORAGE" but master was not seeing the camera and/or lens.
I the pressed the OK button and it then all worked, with camera being seen and the update proceeded.

HTH

Rod

PeterD
28th March 2008, 08:39 PM
Thanks Rod & Ian

I shall try again a bit later when I can claim more space around my PC;)

PeterD

CaptainD
28th March 2008, 09:25 PM
I have just updated both my versions of the lenses without any problems using Mater with the camera in storage mode.

In case you are reading this Ian, Cherry-ann has ordered her E-420 after seeing yours and playing with the demo at the Digital Depot day.

All the very best

Chris *chr