PDA

View Full Version : Register of Olympus Kit that I look after


DerekW
18th March 2011, 09:26 AM
The last bit of Oly equipment I had previously bought was in 2008, I was able to register the lens on the Oly web site and see all the other Oly euipment I had previously registered starting with the E1s, the 500-200s etc etc.

Recently I bought a new Oly toy and went to the registration process web site via the Olympus Viewer 2 and it does not appear to know about me or my arsenal of Oly kit. Is this a new feature or another indication of the downscaling of the marketing effort in the UK.

or am I looking in the wrong place ??

Thanks for any help

meach
18th March 2011, 11:27 AM
I just last week added some new lense I've bought and had no problem at all. But I didn't go through Viewer I went directly to the Olympus site. Maybe that makes a difference.

DerekW
18th March 2011, 12:13 PM
What URL did you use to do the registration. All viewer does is redirect you to a registration web site.

Shaw
18th March 2011, 12:25 PM
What URL did you use to do the registration. All viewer does is redirect you to a registration web site.

Try this

http://www.olympus.co.uk/consumer/208_17616.htm

DerekW
18th March 2011, 12:43 PM
That is the URL I used - but it does have any reference to the old terms like Nickname or a user id number - however if I change my logon data - I get back to my list of toys - sorry for the false alarm.

Shaw
18th March 2011, 01:00 PM
Once you are in the URL, you should select 'your personal account log in', which opens your Olympus account, then, at left hand side, select 'Personal Profile' or 'Product registration.

StephenL
18th March 2011, 05:54 PM
I had this problem a while back and spoke to a helpful Olympus service person. Apparently there were at one time two separate databases which did not talk to each other and it was pot luck which one you got registered on. There is now only one database. Olympus helped me out by transfrerring all "old" database entries onto the new, current, one. But I think you have to ask - it's not done automatically.

DerekW
18th March 2011, 07:01 PM
As I added in the second post above the problem is now resolved thanks for all your comments

DerekW
23rd November 2011, 09:30 PM
Problem is back - cannot get to my full list of products.

Back to phoning them tomorrow

peak4
23rd November 2011, 10:08 PM
Problem is back - cannot get to my full list of products.

Back to phoning them tomorrow

It came up as a problem a couple of days ago as well
http://e-group.uk.net/forum/showthread.php?t=17821

Good luck

Wee man
23rd November 2011, 10:52 PM
Just logged in to the Olympus site and found a whole new site layout, the one strange thing was that two of the lens I own were duplicated. All it showed on the page I was on was an illustration of the lenses with their name and date purchased the serial nos. etc did nor appear, I did not hunt for them but it was the main record I had of those details.

Shaw
24th November 2011, 08:37 AM
Just logged in to the Olympus site and found a whole new site layout, the one strange thing was that two of the lens I own were duplicated. All it showed on the page I was on was an illustration of the lenses with their name and date purchased the serial nos. etc did nor appear, I did not hunt for them but it was the main record I had of those details.

I've just logged on, and all my stuff is there, but if you click on the product description for each item, the serial number is displayed in a separate widow.