PDA

View Full Version : No display !!!!!


ringneck
15th August 2010, 05:09 PM
A few weeks ago all of a sudden I noticed there was NO display in the viewfinder.
The camera would go through the focussing and take shots that were in focus but I did not know if focus was achieved through the focus mark coming up.
I tried turning off/on/off/on many times and taking the battery out/in a few times.I even tried putting the battery out of my E500 in but it was still the same.
In the next few days I charged up both batteries to full ready to go out to take some shots and had forgot about the problem ...but then looked/saw the display and it was then that i remembered it wasn't working before.
During the next couple of weeks all has seemed fine ...apart from the odd occasion when the F stop display has gone and just a ---- showing in the display.When I turned off/on it corrected the problem.

So alls been well until yesterday when the original problem came back ...and I went through all the same things as last time and charged up the batteries but this time it is still not displaying......by the way I can see ALL the lcd figures all at the same time but very dark and when the camera takes a shot they dissapear and then come back after.But no way can I get them to show red.
I don't know if a BEEP happens at focus point and never have as I cannot hear things in that frequency.

I have looked in here for similar things and have cleaned all the contacts with alcohol and they all work as well.

Also ...but I don't think it's a related problem....but it might be...is the fact that I cannot get the flash to work.....it's set to pop up and does pop up but does not fire.

Sorry this ended up a long thread but I have tried to say all I have done.
Thanks
Keith *chr

Nick Temple-Fry
16th August 2010, 12:00 AM
Is this all with the same lense, or all lenses.

Are you using the same memory card, or a different one, the camera has a pretty small processing space so errors in one area can impact others randomly.

Haven't the foggiest idea really.

Nick

Zuiko
16th August 2010, 01:03 AM
Hi Keith,

Regarding the intermittent problem of disappearing display, it sound like it could be a loose contact inside the camera. Might be best to contact Olympus for advice.

As for the flash, was the shutter speed more than the sync speed? That would prevent flash from firing.

Sorry I can't help more than this, hope you get it sorted soon.

ringneck
16th August 2010, 10:11 AM
Thanks both

NICK.....It's on all the lenses and only one card.
John...Yes it does sound like an internal thing.Will have to investigate contacting OLY.
"As for the flash, was the shutter speed more than the sync speed?"...no idea about Sync speed?...or why it might have changed.

Cheers
Keith*chr

ringneck
17th August 2010, 08:56 AM
Someone on another site thought a Factory reset might fix it.....does anyone agre and would it do any harm.If not then how would I do it.
keith *chr

OlyPaul
17th August 2010, 11:13 AM
Menu > Camera1 > Custom Reset > choose Reset and press OK button then select Yes to confirm it. and no it should do no harm apart from resetting everything to factory defaults.

Have you tried leaving the battery out for a couple of hours, for some reason this sometimes works.

Nick Temple-Fry
17th August 2010, 11:37 AM
Certainly worth doing a camera reset, (they'll do it anyway if you send it away and charge you for it), you will lose any alterations you've made to defaults.

I would also try a new card, it is totally unrelated but a recovered error on writing to a card may leave areas of the camera memory in the wrong state which then upsets other processing. Not everything gets reset when switch on/off.

Nick

Ross the fiddler
17th August 2010, 01:12 PM
Another thing with the F number appearing like --- is also caused when the lens release button is pressed. If it is bumped by accident, it may not necessarily return if there is any malfunction of the release mechanism (burs etc). I hope the problems are resolved without too much angst etc.

ringneck
18th August 2010, 11:14 AM
Thanks everyone for your positive efforts to get me up and running again.

Reset...done it...no different.
Tried swopping the cards with the one in my E500...both work in the E500 and the problem still exists in the E 510.
Left battery out and charged both up and it still exists.
I agree the F number ----could be a dodgy connection with the release button.
Still no further to finding the answer to the NO FLASH problem.

Thanks
Keith *chr

ringneck
20th August 2010, 11:23 AM
I finally got through to OLY support and the only suggestion was check the pins are not sticking....they then refered me to the repair service.
There is a set fee,for any repair,for each model and the 510 is about 150 + vat and postage one way.
As the camera would not fetch that much I feel I could not take up their offer.

keith *chr

gregles
23rd August 2010, 08:11 PM
Any more news Keith?

ringneck
23rd August 2010, 09:38 PM
Blimey just looked at the Live View and thats gone wrong now...when I press O.K. to zoom in it just brings up info pages.

Wonder whats next !!
Keith *chr