PDA

View Full Version : HELP! E-620 shooting issue


Kittykat23uk
11th August 2010, 08:06 AM
Hi all,

Just last night and this morning I've been trying out my new E620 and I'm rather concerned. When I press the shutter button half way and lock focus, it bleeps. If I then press the shutter all the way down, it doesn't take a picture sometimes. I thought last night it was the flash charging, because sometimes the flash would strobe before locking on and wouldn't let me take the shot, but tried it out this morning in the garden and I had the same problem. Is this user error or did I get a dud? :confused: It seems to happen in auto, macro and various other modes.

MY OH had a similar problem with his 30D and it turned out to be a dodgy shutter button switch. But this camera is a lot newer so I wouldn't have thought the switch would have gone already?

Any help most appreciated

Thanks

Jo

snaarman
11th August 2010, 08:48 AM
Sounds unlikely to be a shutter switch on a new camera.. The only times my 620 has refused has been when the battery is almost flat. It will power on and do the usual things, and seems fine, but maybe it showed me the red battery symbol but I missed it.

Quite often that is the end, I only get a couple of shots after the red symbol then it stops dead. You don't get "Flat battery" on the rear display, it just switches off. It may well switch on again if you ask it, but it won't take pictures... Like so many things on the E620, the point that the red symbol appears is adjustable.

BTW - Have you worked through the many, many menus and read the manual so you can tweak the camera to your preferences. I did it and came up with 106 settings - so many in fact I saved them in a spreadsheet in case I ever reset the camera and have to enter them all again *yes

Pete

PS. You didn't set the delay timer did you. That has caught me out. Press the shutter and nothing happens.... :-)

ardvorlich
11th August 2010, 09:03 AM
Hi.I could be wrong but I think you'll find with 620 in auto ,prog,or scene modes (inc.flash)the bleep is focus confirm which is fine however the shutter wont fire if the camera can't find the right settings I.E. shutter to slow,not enough light,to much light etc. under these circumstances the shutter wont fire.Not a fault just takes getting used to.
Cheers Iain.

Who's_E
11th August 2010, 09:51 AM
Jo,

Ardvorlich is right, it could be the scene modes you are in.

To test this theory try putting the camera into manual focus on aperture priority mode ("A" on the mode dial for aperture priority; right arrow to access the focus mode menu, spin the selection dial/move the arrows to "MF" and press "OK"). The shutter should be able fire off lots of shots without jamming or stopping because there is no restriction imposed by the camera.

If it works re-consider the scenes you are shooting and available light as Ardvorlich suggested. Remember to switch back to whichever autofocus you were using as you mentioned that AF is not a problem because you are getting the beep.

If it is still sticky or not firing every time then there may be a problem.

That is my experience from my E330 and the 8mm fisheye which used to have focussing difficulty through that lens and not fire rather than there being a camera or lens problem (hence forcing manual focus above).

Nick

Kittykat23uk
11th August 2010, 10:13 AM
Thanks, I'll give that a go. The battery was fully charged. I was shooting indoors last night, all on auto / P/macro /art filters basically just playing with the programmed functions, didn't adjust any settings at all.

Kiwi Paul
11th August 2010, 02:45 PM
If you are in C-AF mode it's possible by the time it beeps and you then press the shutter button it has lost focus lock again by trying to refocus, (if you are in S-AF mode this won't be the problem), so check you are in S-AF mode and see if that helps.

Paul

Kittykat23uk
11th August 2010, 07:04 PM
Hi all,

I was in S-AF I believe. However, better luck over lunch. I took the opportunity to try it out on some ducks in St James's park and I was snapping away quite happily - no problems with the shutter at all. So perhaps it was a combination of the modes I was in and the shooting conditions as some have suggested. I got mixed results focus-wise though to be honest. I think its going to take a lot of getting used to! I'll try and upload some shots for critique at some point soon.

I managed to navigate to Cont-AF and found the drive mode but neglected to switch on the IS. :rolleyes: Whoops! I think I got a passable shot of a flying pigeon and an interesting action shot of a squirrel punching a pigeon, wait til you see that! :D Other more static shots were not so successful so will definitely need your adive and more time with the camera to get the best out of it.

Thanks for you help!

Jo