PDA

View Full Version : OM-2 headaches


tonton1962
2nd July 2010, 06:08 PM
I hope some of you have an OM-2... I just got one from e-bay and put my 50 1.8 on it and pressed the button and ... the curtain is stuck and I can't advance the wind button at all. Then I saw that there is no battery in it, but I think this is only for the lightmeter that the battery is needed. Does this mean that the camera can be thrown in the garbage or what I am doing wrong here.
Thanks a million.

I found it. The shutter locks automatically because of a lacking battery. It was enough to push the reset button while turning the focus ring. Lovely!!!

Homer Simpson
2nd July 2010, 06:21 PM
From what I remember you need the batteries in there.

There is a shutter lock too - maybe thats actuated?

Try that if it doesn't work, I'll search for my instruction manual which I have somewhere.

Bikie John
2nd July 2010, 06:32 PM
The OM2 has an electronic shutter IIRC, so it will need batteries to operate at all. I think the B setting was manual as shown by the different colour on the shutter speed dial so if you turn it to B the shutter should close OK.

Disclaimer - this comes from dredging in some very ancient memory banks and may be total bannocks!

Good luck ... John

tonton1962
2nd July 2010, 06:34 PM
Problem solved. Going to the watchmaker tomorrow to get 2 1.5V batteries and I will be as happy as a kid on christmas eve

pepper
2nd July 2010, 08:51 PM
Looks like you're heading in the right direction, Get some batteries in there and the shutter will finish its job.